Manjaro installation failed - grub-install failed

Hi, I tried to install Manjaro 18.1 xfce 64bit on my x86_64 bit netbook.
I have been able to install other OSs before (e.g. Parrot OS) without any problems. However, there was an error with this installation:
grub

I've already tested other operating systems, it always came down to the same error. The Internet didn't make me smarter...it was always just problems that resembled mine, but none of the solutions helped me!

I hope you can help me out here.

See this link.. Start install media in UEFI.
Don't forget the 2 [Additional UEFI Commands] when booted up.
If need further help, provide output as stated in the link.

What was the size you gave for /boot? It says it run out of disk space.

Unlikely. If /boot/efi, the space requirement hardly needs more than 50 MB. The 'space' the error message refers to is the firmware space on his motherboard, the cmos memory.

I followed the tutorial, it all worked except for the last command

sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Output :

Could not add entry to BootOrder: No space left on device

I checked the command and executed it again...Output:

***Warning*** : Boot000 has same label manjaro
Could not prepare Boot variable: No space left on device

I will send the output of

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

Output of efibootmgr -v:

BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0003
Boot0000* manjaro HD(1,GPT,5acf664c-c1c0-4743-8102-2ce8e6e19685,0x800,0x3e8000)/File(\EFI\Manjaro\grubx64.efi)
Boot0003* UEFI: SanDisk, Partition 1 PciRoot(0x0)/Pci(0x14,0x0)/USB(7,0)/HD(1,MBR,0x0,0x474788,0x2000)..BO

Output of parted -l :

Model: SanDisk Ultra Fit (scsi)
Disk /dev/sda: 123GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 2392MB 2396MB 4194kB primary esp

Model: MMC DF4064 (sd/mmc)
Disk /dev/mmcblk0: 62,5GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 2098MB 2097MB fat32 msftdata
2 2098MB 62,5GB 60,4GB ext4

Error: /dev/mmcblk0boot0: unrecognised disk label
Model: Generic SD/MMC Storage Card (sd/mmc)
Disk /dev/mmcblk0boot0: 4194kB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

Error: /dev/mmcblk0boot1: unrecognised disk label
Model: Generic SD/MMC Storage Card (sd/mmc)
Disk /dev/mmcblk0boot1: 4194kB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

Output of blkid:

/dev/mmcblk0p1: UUID="5B96-13BA" TYPE="vfat" PARTUUID="5acf664c-c1c0-4743-8102-2ce8e6e19685"
/dev/mmcblk0p2: UUID="83dc83fa-f506-407b-8752-9e2c08c2da03" TYPE="ext4" PARTUUID="5771d998-bec2-4fc3-af16-7f1c3859fdc5"
/dev/sda1: UUID="2019-10-15-09-54-15-00" LABEL="MJRO1811" TYPE="iso9660"
/dev/sda2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="5B76-D2CE" TYPE="vfat"

Output of findmnt -s :

/boot/efi UUID=5B96-13BA vfat umask=0077
/ UUID=83dc83fa-f506-407b-8752-9e2c08c2da03 ext4 defaults,noatime

Output of findmnt /boot/efi:

TARGET SOURCE FSTYPE OPTIONS
/boot/efi /dev/mmcblk0p1 vfat rw,relatime,fmask=0077,dmask=0077,codepage=437,i

Your last command is wrong

It should be

sudo efibootmgr -c -d /dev/mmcblk0 -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

Best you also repeat the cp core.efi to bootx64.efi command also.
Looks like it (boot device) is not showing in your efibootentry as well.
And clear that usb bootentry first.
So here it is.

sudo efibootmgr -b 0003 -B
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/mmcblk0 -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

BTW, how is this mmc disk connected? Through usb, memory card (SD) slot or internally?
If it is memory card, it is highly unlikely it can boot from this.
In some cases, mmc devices are not bootable by the bios.
Also note there's 2 partitions not recognized
mmcblk0boot0 mmcblk0boot1
And looks like special boot partitions made for your computer.
What is your computer make and model?

But try the above commands first. Good luck.

ps: if at grub prompt, check with
grub> ls

If your mmcblk device is not listed, your bios cannot see this and won't boot from it.

2 Likes

Thank you so much, it worked.

btw the mmc disk is internally...

1 Like

Good to hear. There had been 2 cases here of emmc devices having trouble booting, They both, like yours, had mmcblk0boot0 and mmcblk0boot1. Phew! I wasn't that confident. Perhaps you have a newer firmware.

Cheers! And welcome to Manjaro.

2 Likes

A post was split to a new topic: Insallation failed: Could not prepare Boot variable: Input/output error

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by