Manjaro is not booting after choosing non-free drivers (gtx 1050ti)

Some time ago i installed manjaro with free drivers, it worked fine, but i started to see some graphical glitches and performance at games were horrible. I tried installing non free drivers but after install it was not booting. I tried to do fresh install with non free drivers and it didn't worked. (tried both on manjaro stable and and development)

There is some recent weirdness between nvidia 390 vs 394.
I would expect your card to be fine either way though.
How did you 'attempt to install non free drivers' - through mhwd / manjaro settings manager ?
And since you wiped/reinstalled - how did it 'not work' ? As in installation was good, but couldnt boot, or .. ?
(specific errors can be helpful, if you have them)

1 Like

I installed it through settings manager and later tried to do fresh install. After install with settings manager and reboot it wasn't booting. At fresh install it wansn't booting in live cd and there was just this ---> _

And i forgot to make it clear, i cloudn't even boot from pendrive to install. It just wasn't booting after choosing non free.

There are hundreds of topics about this issue in the forum. Have you read them and have some idea of the possible solutions and way to troubleshoot?
Boot with a LiveISO to the free drivers option and provide some information about your system:

inxi -SGxxz

Can you access the logs in your installation?
If yes, provide /var/log/Xorg.0.log or other xorg log found.
Please use code blocks for your info-text.

1 Like

Ok, now on my PC is that broken manjaro (I tried installing nvidia drivers from settings manager) and I'm gonna check live cd

Output:

System:
  Host: manjaro Kernel: 4.16.5-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 7.3.1 Desktop: N/A dm: lightdm 
  Distro: Manjaro Linux 18.0-alpha-3 Illyria 
Graphics:
  Card-1: Intel 4th Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:041e 
  Card-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nouveau v: kernel 
  bus ID: 01:00.0 chip ID: 10de:1c82 
  Display: x11 server: N/A driver: intel,nouveau 
  unloaded: fbdev,modesetting,nv,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: NV137 v: 4.3 Mesa 18.0.2 compat-v: 3.0 
  direct render: Yes 

and here is log file (not from livecd) : https://pastebin.com/R6aq5Qtu
And what's code blocks?


Which card is your display connected to?

Can you disable the iGPU in your BIOS settings?

Here is inxi -b

System:
  Host: manjaro Kernel: 4.16.5-1-MANJARO x86_64 bits: 64 Desktop: N/A 
  Distro: Manjaro Linux 18.0-alpha-3 Illyria 
Machine:
  Type: Desktop Mobo: Gigabyte model: H81M-S1 v: x.x serial: N/A 
  BIOS: American Megatrends v: FH date: 08/10/2015 
CPU:
  Dual Core: Intel Core i3-4160 type: MT MCP speed: 898 MHz 
  min/max: 800/3600 MHz 
Graphics:
  Card-1: Intel 4th Generation Core Processor Family Integrated Graphics 
  driver: i915 v: kernel 
  Card-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nouveau v: kernel 
  Display: x11 server: N/A driver: intel,nouveau 
  unloaded: fbdev,modesetting,nv,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: NV137 v: 4.3 Mesa 18.0.2 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  Card-2: Ralink RT5390 Wireless 802.11n 1T/1R PCIe driver: rt2800pci 
Drives:
  HDD Total Size: 945.97 GiB used: 10.81 GiB (1.1%) 
Info:
  Processes: 178 Uptime: 38m Memory: 7.70 GiB used: 1.43 GiB (18.6%) 
  Shell: bash inxi: 3.0.07 

and I have alerady disabled iGPU and connected graphics card is gtx 1050ti

The driver set is nouveau and not nvidia (the non-free driver)

Can you provide /etc/X11/xorg.conf, please?

If that's the case then it wouldn't be showing in the inxi output, and the intel driver wouldn't be loaded.

You didn't read the linked post did you... you just read the excerpt...

Please read the full post.

Then boot to TTY as described in the tutorial, remove your old driver and install video-nvidia with mhwd

mhwd -r {old driver}
mhwd -i --pci video-nvidia

Oh sorry, i have it enabled. Checked it while ago

Since you don't have a laptop (power saving features), you could disable iGPU and use plain nvidia.

Okay i'll try it and i'm sorry again for bad text formatting, I'm new here

1 Like

It worked! :smiley: Thank y'all so much for helping me

1 Like

Please explain what you did to solve your issue and mark the post that better describes it as Solved. (3 dots button)

Ok, I disabled intel gpu in bios, and just booted into non-free drivers and it worked and that's it

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by