Manjaro is not booting after install (windows was installed) [Dual boot]

So I installed manjaro on my asus x505za (8gb) that had windows already on it. Installation dialog showed boot and gpt in corner (, you know what i mean) installation was successful. I created partition for /boot around 200mb(fat32) (boot and esp flair) and another for swap of around 2gb and root(98gb)
However it didn't boot into some option for dual boot or even it didn't Boot in manjaro
Kindly tell me what I am doing wrong
I am newbie so please stay on earth...

Edit: it showed bios instead of Boot *mistake

From what it looks like, your Windows installation had a GUID partition table with a BIOS partition, which indicates that it was booting up in legacy BIOS compatibility mode, not in UEFI mode. An UEFI boot does not require a BIOS partition, but it does require an EFI system partition, marked with the esp and boot flags.

When you installed Manjaro, you created an EFI system partition of 200 MiB, and you designated that partition to be mounted at /boot. That makes for three things that you did wrong, namely...:

  1. If your machine is to boot Manjaro in UEFI mode, then you do indeed need an EFI system partition, but this partition needs to be about 512 MiB in size.

  2. The EFI system partition must not be mounted at /boot, but at /boot/efi. The /boot directory contains a lot of stuff that doesn't belong in an EFI system partition, such as your kernels and the boot loader's menu. The EFI system partition will contain only a directory named EFI ─ and thus, when mounted, this directory will be at /boot/efi/EFI ─ which in turn contains directories with the efivars (i.e. UEFI executables) that will boot your operating systems. It is not advised to put anything else in there.

  3. It is generally a bad idea to have both a UEFI-capable operating system and a BIOS-booting operating system on the same physical storage medium. So if you're going to have two operating systems on the same physical storage medium, then they should for good measure both be UEFI-capable or both should boot in legacy BIOS compatibility mode. Mixing UEFI-capable systems with legacy BIOS systems if you have them on physically different drives is generally not a problem.

Yes it boots into leagcy bios but I don't know any way to change it to UEFI (I checked in bios twice)
And their was no option to mount it to /Boot/efi so should i manually write it ?

if UEFI is what you want for both windows and linux there is a windows tool called mbr2gpt

there are also alternatives to mbr2gpt to do the same thing if mbr2gpt should fail for whatever reason (like being made by MS) :sweat_smile:

It is possible that your computer's firmware actually is of the legacy BIOS type, rather than that it would be a UEFI.

Either way, if you want to boot up in legacy BIOS mode but with a GUID partition table, then you must not create an EFI system partition, because it would be a waste of space. However, in that case, you must create an empty, unformatted partition of type BIOS as the first partition in the GPT. It should only be about 2 MiB in size, but you can make that 10 MiB just for future compatibility.

The reason is this: if you omit creating a partition of type BIOS in a GUID partition table, then the GRUB boot loader might end up overwriting part of your first data partition ─ e.g. your "/" partition ─ with its core.img. It'll still put the boot.img stage in the MBR of the drive, but the core.img stage needs some extra space for itself, and that's what that raw, unformatted partition of type BIOS is for.

So during installation, after having created the necessary partitions, tell the installer to put GRUB in the MBRnot in /boot! ─ and make sure you have that BIOS partition there as the first partition in your GUID partition table. GRUB will then pick up your Windows installation and will add it to the GRUB menu that you'll get to see when you reboot the machine. :wink:

I said I am using Asus x505za is it limited by that?
I thought only older hardware was limited

if windows is installed in legacy bios mode, either convert it to GPT/uefi or install manjaro in legacy bios. if you go the route of changing windows to UEFI you should remove linux and any partitions you created for it first and then install manjaro after thats done and manjaro will install grub on the EFI partition that windows already created in the process of changing to UEFI.

you dont want manjaro uefi and windows legacy bios, just search this forum and you'll see why i say that. your computer is UEFI capable otherwise you would of never been able to boot manjaro in UEFI mode in the first place, never mind install it as such.

Use this......

I checked but my system is UEFI and gpt anyways thanks for your help IMG_20190619_115602

Okay, then do the following...:

  1. Make sure that the firmware of your computer is set to boot in UEFI mode only ─ not "UEFI + BIOS" ─ and with Secure Boot disabled.

  2. Reinstall Manjaro, but do not set up the EFI system partition as /boot. It must be mounted at /boot/efi instead.

So problem was solved thanks everyone
I can't thank you guys enough

1 Like

how was the problem solved? this is what makes posts like these helpful to others.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by