Manjaro is not shutting down.Just halts at reboot: shutdown

Hey team,
Just want to ask a question that from the past week facing the problem while shut down. Shut down just hangs at reboot: shutdown.
For your information: Reboot is working fine.
I have checked for the BIOS update but no updates there.
So I suddenly started facing this problem, does this issue related to BIOS/UEFI or kernel?
System Information:
Laptop: DELL inspiron 15 3542
Processor: Intel i5 4th Gen Quad Core
Memory: 8 GB DDR3L
HDD: 1 TB
BIOS version: A15
GPU: NVIDIA GEFORCE 820M / Intel Haswell-ULT

Here is the output of inxi -Fxz

System:    Host: admin-inspiron3542 Kernel: 5.7.0-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Console: tty 2 
           Distro: Manjaro Linux 
Machine:   Type: Portable System: Dell product: Inspiron 3542 v: N/A serial: <filter> 
           Mobo: Dell model: 0926J6 v: A15 serial: <filter> UEFI: Dell v: A15 date: 05/23/2019 
Battery:   ID-1: BAT0 charge: 15.9 Wh condition: 22.8/41.4 Wh (55%) model: LGC-LGC2.8 DELL T1G4M46 status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell rev: 1 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13572 
           Speed: 798 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 798 2: 798 3: 800 4: 798 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] vendor: Dell driver: N/A 
           bus ID: 08:00.0 
           Display: server: X.Org 1.20.8 driver: modesetting unloaded: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.7.0-3-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Dell driver: ath9k v: kernel 
           port: f040 bus ID: 06:00.0 
           IF: wlp6s0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: e000 
           bus ID: 07:00.0 
           IF: enp7s0 state: down mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 2-1.6:6 
Drives:    Local Storage: total: 931.51 GiB used: 12.29 GiB (1.3%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB 
Partition: ID-1: / size: 142.71 GiB used: 12.27 GiB (8.6%) fs: ext4 dev: /dev/sda8 
           ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 51.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 190 Uptime: 7m Memory: 7.68 GiB used: 862.2 MiB (11.0%) Init: systemd Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.17 inxi: 3.0.37 

Difficult to tell based on the information you provided, unless someone happens to have the exact same issue and sees this post (unlikely).

You'll have a much greater chance of getting help if you follow this advice:

Just looked at the tag KDE :man_facepalming: - why is it that the majority of issues - besides Nvidia - is with KDE - of course it is popularity - but nonetheless?

What happens if you use this command

systemctl poweroff

Do you have any specific kernel parameter set?
Please share output of
cat /proc/cmdline

This is what I get after entering the cmmand

BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 root=UUID=84d42de0-7567-4033-bc1e-73a3f7c65876 rw quiet apparmor=1 security=apparmor resume=UUID=0b404d37-7bb7-482c-84d3-1bf331b7da4e udev.log_priority=3

Same error persists. Even I tried shutdown now shutdown -P but nothing helps

Using a process of elimination ...

Disable apparmor, snapd.apparmor and snapd

sudo systemctl disable --now apparmor snapd.apparmor snapd

Then edit the file /etc/default/grub and remove apparmor=1 and security=apparmor and save the file. Then you rebuild grub and reboot - then test if you can shutdown the system.

sudo update-grub
reboot

Sorry to say.But that did't solved my problem. My system just hangs at DELL logo (same as it was behaving previously).

On shutdown, do you see any messages on the screen indicating that systemd is waiting for something to shutdown? I've seen waits up to 2-minutes, but it eventually shuts down.

Also take a look at the system log and double check there isn't a coredump happening.
Checkout commands: coredumpctl and journalctl.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by