Manjaro just not working on my RX 5700 flashed to 5700 XT

I recently upgraded my gpu from an RX 480 to an RX 5700, on Windows everything went smoothly; the system booted and I was able to install the proper drivers. On Manjaro though... Not so easy.
Grub keeps working just fine, but I just can't get the new gpu to display anything on Manjaro. Whether it gets a black screen or gets stuck with my motherboards logo... I even tried to boot on a live usb, which works fine with the RX 480, but my 5700 just gets stuck after loading AppArmor stuff...

I removed all my old drivers, but still couldn't get anything to display, not even tty, so I entered the tty with my old card (ofcourse then it did work just fine), installed the free drivers with mhwd and Manjaro boots fine again, with the RX 480 that is... Still absolutely nothing with the 5700.

I'm running kernel 5.4.4 if I'm not mistaken and I created the live usb yesterday, so I'm pretty sure everything should work in theory.
What gives?

Hi!
Try with kernel 5.7, it have better support for those graphics card

1 Like

Thanks! I'll try that in a bit!

That didn't do anything unfortunately...

Hi! Looks like they found a solution here

I don't think that's the same issue. My system doesn't boot at all with the new gpu even though it runs fine on windows

Ok, so I think you'll have to wait for mesa.19.2 or change to testing

Can I do that on a live usb? Or is that only available after install

Try this

sudo pacman-mirrors --api --set-branch testing

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

What does that second command do exactly?

First part is speed test and used the five fastest servers that are closest to you. Second part update the repo. Then update the system.

Ah okay thanks, I'll try it out later

From your profile it looks like you flashed a RX5700 card with a RX5700XT bios.

Maybe that is the problem. Can you try flashing it back to stock BIOS?

I did, but I'm not sure how that would create an issue really, on windows it's perfectly fine

The binary blob driver in Windows would have more in-depth access to the details, where the FOSS drivers in Linux have to rely on what the BIOS sends over. It could be showing up differently in Linux and trying to get it to load something else. Do you have KMS installed and running? I had checked out the Arch WIKI thinking you could do something with nomodeset, doesn't look like it will help much, but have you tried it just to see what you can see on the console? https://wiki.archlinux.org/index.php/AMDGPU

I can't access the console with the RX 5700 :confused:

Did you try adding nomodeset to the kernel grub entry? It should force it into VESA mode so you can sort out the issues or hopefully get an error message in DMESG.

Where should I put that?

I stole the instructions from here : https://www.reddit.com/r/linux/comments/dyoalh/ubuntu_1910_rx_5700_xt_installation_instructions/

image

Obviously change it for your installation.

Well, you can't compare Windows and Linux. They are very different down to the lowest level drivers that interact with the hardware.

There is only one way to tell if the XT-bios on your non-XT card is the cause of your problems: reflash the card with the original bios and test.

Forum kindly sponsored by