Manjaro kde beta 7 - other OSs don't show - no bootmenu at all

just installed manjaro kde beta 7 it installed ok but when I do sudo update-grub it finds other os on sda,sdb but when I reboot it just goes straight back into kde on sdc

Make sure that inside /etc/default/grub you have set:
GRUB_TIMEOUT=5
Once in the grub menu, during that period of 5 seconds (as above mentioned) select with your arrow keys the detected/added installs/kernels.
It will always boot from that if in the same file you have set:
GRUB_DEFAULT=saved
and
GRUB_SAVEDEFAULT=true
Whatever modification you make in the file, make sure to:
sudo update-grub

ok thanks

No, we added new features to grub-quiet. On this we worked with Fedora together.

On systems with only a single OS installed, the grub menu's only function is to allow booting older kernels, which is only necessary as a rescue option in case of a severe kernel bug and as such not something which is directly useful for normal use.

Manjaro already has a lot of work done to not show too technical boot messages to end users during bootup, e.g. we pass quiet to the kernel and we had plymouth to show a bootsplash instead of a bunch of "Starting service-foo: OK" messages.

The grub menu with its kernel versions is another example of showing too technical info to end-users and on non multi-boot systems it normally is not necessary, so it is better to hide it.

This change will add menu-auto-hide functionality to grub, which when enabled will hide the menu if:

  • The machine only has a single OS installed; and
  • The previous boot has set a flag to indicate it successfully booted

To make the menu easier to reach when hidden this change will also extend how the menu can be unhidden. Currently to show the menu when hidden the user needs to press ESC during boot. There are 3 problems with this

  • It is not easily discoverable
  • Timing the ESC key press right may be hard
  • ESC makes the machine enter its firmware/BIOS setup screen on some machines (especially with the #bladebook)

So we added 2 new unhide methods to address these problems:

  • Press F8 to unhide the menu (F8 has been the key to show the Windows boot menu for many older Windows versions)
  • Keep SHIFT pressed during boot, this fixes the timing problem and this is what Ubuntu does

This new auto-hide functionality will be automatically enabled on new Manjaro 18.0 installs. This can be disabled by running:

sudo grub-editenv - unset menu_auto_hide

You can also show the menu once for 60 seconds on next boot:

sudo grub-editenv - set menu_show_once=1

ok I will try again ok also what if I used refind to boot operating systems

We made the changes only to grub. With refind nothing should have changed.

used refind all booting ok kde looks ok so far thanks philm

This is what I get

systemd-fsck-root.service - File System Check on Root Device
   Loaded: loaded (/usr/lib/systemd/system/systemd-fsck-root.service; enabled-runtime; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Mon 2018-10-29 09:51:55 GMT; 3h 36min ago
           └─ ConditionPathIsReadWrite=!/ was not met

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by