Manjaro KDE Desktop effect suspended after login

Hello, I've been using Manjaro KDE for some time on my laptop. Lately I've been having the following issue:

After I successfully log in I get Notification stating "Desktop effects have been suspended by another application. You can resume using the 'Alt+Shift+F12' shortcut. " and I only get simple graphics on Desktop. I can temporarily solve it by changing Rendering backend in Compositor to OpenGL 2.0 and then back to 3.0 but the problem is back after reboot and sometimes even during the same session.

Any help would be greatly appreciated.

What I've tried so far:

  1. different kernels - I run the latest at the time of writing - 5.6.8-1 as well as the LTS 5.4.36-1
  2. first disabling autostart for latte dock and then completely uninstalling it
  3. checking settings for my displays (my notebook is sometimes in a docking station with an external monitor)
  4. checking dmesg and journalctl for errors

Today I've noticed that I can replicate the problem during the session almost every time by either opening or closing the lid of my notebook while it's in the docking station. However, I haven't changed any settings regarding the displays and power saving in recent weeks.
My displays are configured as such: external monitor is the primary one and the laptop's own display is mirroring it.

My config is:

System:    Kernel: 5.6.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=f823e642-f9ec-40d2-af4f-b30bf9ca0de0 rw 
           scsi_mod.use_blk_mq=1 rd.udev.log-priority=3 i915.modeset=1 intel_iommu=on iommu=pt 
           resume=UUID=28d74c5f-19c9-4f7a-b3f3-e6f28c7b1b20 
           Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude E7470 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 0DGYY5 v: A02 serial: <filter> UEFI: Dell v: 1.20.3 date: 08/20/2018 
Battery:   ID-1: BAT0 charge: 52.2 Wh condition: 52.2/55.0 Wh (95%) volts: 8.5/7.6 model: SMP DELL MC34Y51 type: Li-poly 
           serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake family: 6 model-id: 4E (78) 
           stepping: 3 microcode: D6 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20004 
           Speed: 627 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell Latitude E7470 driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:1916 
           Display: x11 server: X.Org 1.20.8 driver: modesetting alternate: fbdev,intel,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell Latitude E7470 driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k5.6.8-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell Latitude E7470 driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           chip ID: 8086:156f 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 chip ID: 8086:24f3 
           IF: wlp1s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 154.14 GiB (33.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO M.2 500GB size: 465.76 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1B6Q scheme: GPT 
Partition: ID-1: / raw size: 448.35 GiB size: 440.31 GiB (98.21%) used: 154.13 GiB (35.0%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.12 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) cache pressure: 100 (default) 
           dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 48.0 C mobo: 43.0 C sodimm: 40.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 166 Uptime: 18m Memory: 15.60 GiB used: 1.29 GiB (8.3%) Init: systemd v: 244 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37 

More people seem to have this problem

but most commonly with Nvidia graphics.

EDIT: It could also be a program causing this

Thank you for replying, I really appreciate it.

I actually saw both of these threads while trying to troubleshoot my problem, however they didn't help me much because:

  1. My notebook has only intel Skylake integrated graphics, no nvidia gpu
  2. I can't for the life of me figure out WHAT application does this as there is only 1 application I have set to launch on startup and that is Latte dock (I've already tried disabling and later uninstalling it). I can't find any log that would indicate the name of the misbehaving application

I have the exact same problem on my laptop!
And I'm running AMD Ryzen + Vega, not Intel.

I use my laptop as media station, it is therefore connected to my TV screen via HDMI. Whenever I close the lid, my Desktop effects are getting suspended.

This problem occurs only since the last stable update, but I am too noobish to point my finger on it.

Help? Anyone?

I found this thread while searching for a solution to our problem: Reddit thread.
What they is they enabled "Background contrast" in Desktop Effects tab under Workspace Behavior control panel.

Will you please try testing if it works for you? So far it seems to work OK on my machine. I still don't know the reason for this.

1 Like

Hi Xindl,
thank you very much for the suggestion. Unfortunately in my case, this was not the solution, "background contrast" is disabled (like almost all effects in my case). I will nevertheless try to disable all effects and see, if it makes a difference.

Is there maybe a log file, where we can see what application or service triggers this issue?

journalctl -b -p6

might give you some information

1 Like

I think you've got it slightly wrong, my friend.
In my case "Background contrast" was also disabled, in order for the problem to go away, you must ENABLE it.
Just give it a try and we will see if it leads anywhere.

1 Like

Indeed, I misunderstood. English is not my first language, so I struggle from time to time.

Your suggestion is right! That does the trick. Very strange bug, would have never found that myself. Do you know, wether this has already been reported?

Thank you very much for your kind help.
All the best!

Don't worry, I'm also not a native speaker, so I know the pain. :slightly_smiling_face:

According to the reddit thread the problem was reported 2 years ago but there doesn't seem to be any work done as far as I can understand.

It's great news this worked for you as well, I'm glad I could help you.

Let's hope the KDE team will fix this in the future. It was driving me nuts.

Have a great day! :relaxed:

1 Like

It solved the problem for me as well, thanks :slight_smile:
EDIT: The problem is now back again, so in the end that wasn't the cause it seems...

I've just tried it on my computer and for me the problem still seems to be gone.
I'll install the latest update from 31. 5. and will try again to see if it breaks once more.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by