Manjaro KDE Dev Encrypted Install Fails - 19.05.23 ISO

Downloaded manjaro-kde-dev-19.05.23-unstable-minimal-x86_64.iso and attempted encrypted VBox VM install.

Simply install using erase disk auto partition, swap (no hibernation), with encrypt system selected.


Looks like the luksFormat of swap partition is failing.


Same error with both manjaro themed and vanilla 19.05.23 ISO.

Ran sudo -E calamares -d and everything fine until luksFormat statement above.

Exactly the same installation config without encryption selected installs and runs fine, so this is a cryptsetup specific issue I think.

1 Like

OK we have to see about that... Is it a regression? Or has our latest stable ISO a similar issue?

I've only tested 05-23 and 05-26 ISOs, both fail luks installs with the same error above.

I'll download the earliest of dev (05-11) and vanilla (05-20) ISOs and check them also.

The 18.0.4 stable KDE ISO does not have this issue, haven't checked any of the 18.1.0 beta ISOs yet, might download one of them also.


I have tested this with KDE-Dev, KDE-Vanilla and KDE 18.1.0-pre-testing ISOs.

All tests use erase disk auto partitioning followed by a selected swap config (ie no swap, swap no hibernation, swap with hibernation).

All encrypted installs with swap partitions failed with the error above.

All encrypted systems without a swap partition install and boot successfully.

No swap installs fine. Swap no hibernation crashes. Swap with hibernation crashes.

After each crash the root partition has been successfully created and luksFormatted, the swap partition is created the correct size, but the cryptsetup command must have crashed before mkswap.




Same crash using XFCE 18.1.0-pre-testing.


After the crash I manually ran the cryptsetup command ...

sudo cryptsetup -s 512 --batch-mode --force-password --type luks1 luksFormat /dev/sda3
Enter passphrase for /dev/sda3: 

It worked, though I had to manually enter a password.


Just to make sure I did another 18.0.4 VM encrypted install with a swap partition, and it worked fine.

KDE 18.0.4 calamares version is

KDE Dev 05-11 calamares-git version is 3.2.9.r5899.c7aa9ba05-1.

So the issue was probably introduced between these two.


This is a confirmed bug that won't be fixed for Calamares 3.2.9 release, can the KDE Dev / Vanilla ISOs possibly be built with an earlier Calamares version that does not contain this this bug?

This bug will also break encrypted installs for the Juhraya ISOs.

The problem is with kpmcore, partitionmanager and calamares. If I downgrade the partition module of CAL we have also to downgrade those other applications. Therefore we may keep it as is until a fix is given.

@sueridgepipe please check again ...

Encrypted install with swap partition now installs fine.

Will there be new KDE-Dev ISOs this weekend?

We will build kde-dev ISOs regularly. However we will use calamares-git package which is compiled against kpmcore4.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by