Manjaro KDE - Epson L360 All in one Scanner problem

Hi Guys,

I am using Manjaro KDE version recently installed on my laptop. I have epson l360 (All in one printer)

Output of $ inxi -Fxz

$ inxi -Fxz
System:    Host: falcon-pc Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: KDE Plasma 5.16.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC 
           v: 0792100000205610000610100 serial: <filter> 
           Mobo: Hewlett-Packard model: 183E v: 56.32 serial: <filter> UEFI: Insyde v: F.25 
           date: 05/29/2013 
Battery:   ID-1: BAT0 charge: 29.4 Wh condition: 31.8/31.8 Wh (100%) model: Hewlett-Packard Primary 
           status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 3072 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19961 
           Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1197 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: AMD Thames [Radeon HD 7500M/7600M Series] vendor: Hewlett-Packard driver: radeon 
           v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: intel,radeon FAILED: ati unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.1.5 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Ralink RT5390 [802.11 b/g/n 1T1R G-band PCI Express Single Chip] 
           vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 4000 bus ID: 07:00.0 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: 3000 bus ID: 08:00.0 
           IF: eno1 state: down mac: <filter> 
           Device-3: Ralink type: USB driver: btusb bus ID: 1-1.3:4 
Drives:    Local Storage: total: 465.76 GiB used: 17.04 GiB (3.7%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LM030-2E717D size: 465.76 GiB 
Partition: ID-1: / size: 259.43 GiB used: 17.04 GiB (6.6%) fs: ext4 dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A gpu: radeon temp: 60 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 180 Uptime: 16m Memory: 3.75 GiB used: 1.69 GiB (45.1%) Init: systemd Compilers: 
           gcc: 9.1.0 Shell: bash v: 5.0.9 inxi: 3.0.36 

However the printer is working fine after installing the CUPS but the scanner is not working whenever I start the image scanner for linux it simply shows an error.

[EPSON L360 driver](https://archived.forum.manjaro.org
/t/epson-l360-driver/98521/2)
How do I install this if it is the one missing?
http://support.epson.net/linux/en/imagescanv3.php

Please find the error screen from the iscan attached.

Epson%20Scanner%20not%20detecting

Could any one please help me in getting my Epson scanner work in Manjaro?

Thanks

If you also have sane and libksane packages installed and you run from terminal:
sudo sane-find-scanner
Is your scanner listed?

Yes,

$ sudo sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8 [EPSON], product=0x08d1 [EPSON L360 Series]) at libusb:001:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Great, now open skanlite if you have it installed, and see if the scanner works with it.

Scanlite is only detecting the HP Webcam and not the epson scanner.

Ok, then you will have to play with this part

I have already tried this:

scanimage -L

$ scanimage -L
device `v4l:/dev/video0' is a Noname HP Webcam-50: HP Webcam-50 virtual device

No Scanner is detected, only the HP webcam is being detected.

You can modify it back if this doesn't help. You either manually edit the /etc/sane.d/epson2.conf and add this line to it:
usb 0x4b8 0x8d1
Or you seed that inside with this command:
echo 'usb 0x4b8 0x8d1' | sudo tee -a /etc/sane.d/epson2.conf

Then allow scanner group to access it, add this to /etc/udev/rules.d/99-custom.rules
Create that file.

ATTR{idVendor}=="04b8", ATTR{idProduct}=="08d1", MODE="0666", GROUP="scanner"

Reboot.
You should also be in the scanner group, so now there should be a different behavior there. To test in what groups you are part of, from terminal run:
groups

1 Like

Hi,

groups return the following

$ groups
sys network power lp wheel falcon

I have also tried this given at https://wiki.archlinux.org/index.php/SANE/Scanner-specific_problems#Epson:

When you then start Image Scan v3 by typing in the command

$ utsushi

Your solution is working fine. I have done the same thing to /etc/sane.d/epkowa.conf
that is added usb 0x4b8 0x8d1 in the conf file and had my laptop rebooted/restarted and now both iscan and skanlite are working fine. I could able to scan from the scanner.
Thanks a lot for your help.

1 Like

Ah, cool you are in the lp groups so instead of

you could have used
GROUP="lp"

Regardless, glad is working now for you! :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by