Manjaro KDE freeze at installation to 75%

@Mel, @anon34394587, @muser, @Strit I have to tell you that I was not abble to boot from USB with a graphical interface until I've seted up the driver nonfree and edited the grubline adding before nomodeset=0, the following> systemd.mask=mhwd-live.service

Note that I edited my previous post, the proper command is sudo -E calamares -d.

There is an upload button when you are writing the post (if it doesn't appear it's maybe because you are too new here with limited forum options).

@muser I'll redo the command again. The picture that I have is on my phone because the computer was freezed :slight_smile: Anyhow, I think I might be able to log in on the forum from my phone and use the upload button that I have available :slight_smile:

Edit the GRUB boot option and add

acpi_os=! acpi_osi="Windows 2009"

See if that makes a difference (Bumblebee: GRUB ACPI boot options).

1 Like

@muser after I have issued the comands that you have indicated the laptop frozen twice and the output was like in the image uploaded2018-01-23_15-17-35

@jonathon Thank you! I will do that.

@jonathon I did not know where to put in grub that line. Anyhow, I've tried to install Manjaro Architect, messed up and lost about 100 Gb of data that hasn't backuped. :disappointed_relieved: Above all I didn't manage to install Manjaro. The installation freeze at 75% with GUI. I don't know what to do. If you have any ideas it will be helpfull.

You'd use the "Edit" option of the boot menu:

boot-option

@jonathon Thank you! I'll do that and when I'll finish I will let you know the result.

@jonathon, @Strit I come back with the result I've tried to install Manjaro 17.1.2 KDE. I mentioned you in this post because it seems to me that you are more experienced and in touch with the development team.

  1. I have booted with a) driver free and b) with acpi note that @jonathon mentioned it. The screen made a loop and the state is in the picture attached. The next 4 cases will follow this post.IMG_0641

  2. I have booted with
    a) driver nonfree
    b) acpi_os=! acpi_osi="Wndows 2009"
    the result is in the image attachedIMG_0642

  3. I have booted with
    a) driver free
    b) acpi_os=! acpi_osi="Wndows 2009"
    c) edited the grub line and added before nomodeset=1 the following systemd.mask=mhwd-live.service
    the result is belowIMG_0643

  4. I have booted with
    a) driver non
    b) acpi_os=! acpi_osi="Wndows 2009"
    c) edited the grub line and added before nomodeset=1 the following systemd.mask=mhwd-live.service
    and the computer frozen at 75% of the installation. I think until a solution for installing Manjaro KDE will not be available, I will use other Linux distro with KDE.... unfortunately :disappointed_relieved:

What is your advice @jonathon, @Strit, @Mel, @muser and @anon34394587?IMG_0644

Have a look at the other options here:

One of these may help with your specific hardware.

Try with the non-free drivers and each of the ACPI options.

Hello @jonathon! :slight_smile:

I have finally installed Manjaro 17.1.2 KDE. I've done it in two steps:

  1. A first screen I've chosen driver non free, then I edited the grub line and added systemd.mask=mhwd-live.service started the installation. Without the line mentioned in grub I couldn't have a graphical interface. The computer frozen at 75%. Before to install Manjaro on HDD I've started system info and watched the memory, remembered what @Strit said in a previous post. The screen looked like this, consuming more than 8Gb of RAM (which is abnormal to me to use in a normal installation).2018-01-25_11-36-37

Anyhow I was forced to restart the computer from the power button and to redo all the steps from above until the partition point. At that point, after I've defined /boot/efi and /home partitions (I use GPT) I've chosen the same boot partition, from the first attempt but I did not marked it to be formated, just to keep. The installation passed through 75% in about 1minute and a half, hanged there for about 5-7 seconds and continued up to the end.

Those are the steps that helped me to install Manjaro. :smile:
I can say that this problem is SOLVED for the moment.

All the best to you, @muser, @Mel, @anon34394587, @Strit and thank very much for your help and support!

Updated After rebooting from power button edit the grub configuration line and before ”quiet” I've added apci_osi="Windows 2015"as I saw in a post on this forum. Then I was able to boot in GUI and update the system.
This worked for me, on my laptop: Asus N752VX, with Skylake processor i7-6700HQ, and 2 GPU: Intel HD Graphics; NVIDIA GeForce GTX 950M. I still have to make NVIDIA to work, but the laptop is working.

1 Like

I would look into what is taking up 8 GB's of RAM, because that is not normal! At all... Maybe run ksysguard from the menu to see the offenders?

1 Like

Right now, I have 1.8Gb with KSysguard and three Firefox tabs open. I don't think that I'll redo the installation conditions again to see what have eaten so much memory. :slight_smile: Thank you!

It's visible in the ksysinfo. Disk cache and disk buffers. It's a setup w/o swap, which probably didn't help.

Hi @Strit and @Mel!
I have been forced to reinstall Manjaro because after upfating Intel Graphic driver and Nvidia the system wasn't boot. I have followed the same steps as I did in the first install, however I was not so lucky to go though all install process. I watched Ksysguard and Memory from Info and the Disk Cache went up to 99% of my 8Gb of RAM until the install process was at about 17%, then at 75% system frozen. The swap was not used in the installation even I specified that the swap partition is 8 Gb. How can I make the install process using swap, or how can I decrease disk cache? I could not found in Ksysguard any indication about what process is using so much memory. (or I did not know where to look). I think the system freeze because the memory is full as @Strit said. Maybe a solution to this will help other users to install Manjaro KDE smoothly than me.

On a side note, did you check the checksum and the signature of the manjaro iso file to make sure it's intact?

Hi @muser! I did.

1 Like

5 posts were split to a new topic: Can't update, conflicting files in NVIDIA driver packages

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by