Manjaro KDE Plasma Sluggish, Docker COPY command super slow...

Hi guys,
I'm new to Manjaro, heard good things about it.

I've decided to move from Ubuntu 18.04, and so I've dual-booted with Manjaro. I've started noticing that it's in general slower (boot fast as hell though) where the most obvious difference is with the docker build command, where a simple COPY of a small 10 lines file takes ~1 second per command when in Manjaro, and ~100 milliseconds in Ubuntu (again, on the same machine).

> inxi -Fxz            
System:    Host: ilai-manjaro Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude 7490 v: N/A serial: <filter> 
           Mobo: Dell model: 0KP0FT v: A00 serial: <filter> UEFI: Dell v: 1.8.0 date: 12/24/2018 
Battery:   ID-1: BAT0 charge: 48.3 Wh condition: 55.3/60.0 Wh (92%) model: LGC-LGC7.780 DELL 2X39G91 status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33615 
           Speed: 2780 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 2816 2: 3054 3: 3006 4: 3008 5: 2868 6: 3033 7: 3035 
           8: 3042 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.7 driver: modesetting tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.6 Mesa 19.3.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.18-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           IF-ID-1: br-b7eb8bd87ce7 state: down mac: <filter> 
           IF-ID-2: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 50.27 GiB (10.5%) 
           ID-1: /dev/sda vendor: SK Hynix model: SC401 SATA 512GB size: 476.94 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 233.72 GiB used: 50.25 GiB (21.5%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 264 Uptime: 3h 32m Memory: 31.25 GiB used: 4.21 GiB (13.5%) Init: systemd Compilers: gcc: 9.2.0 
           Shell: zsh v: 5.7.1 inxi: 3.0.37

I've gone through every possible topic that I could find in the forum, and in Archlinux related articles involving Drivers, GPU, CPU, Memory, Disk (ran all sorts of benchmarks) and overall everything looks pretty standard.

Please help me, don't want to return to Ubuntu :fearful:

Thanks, Ilai


Take a look at this discussion Can avahi be disabled safely without causing other problems?

I had earlier on this, I also come from Kubuntu.

Did it help @ilaif ?

Thanks, @anon88164414

I tried disabling baloo, and ahavi is not enabled on my system, but it's still the same thing. Just to show some statistics, with 7 empty files:

ᐅ ls
Dockerfile  tmp1  tmp2  tmp3  tmp4  tmp5  tmp6  tmp7

ᐅ cat Dockerfile   
FROM python:3.7

COPY tmp1 .
COPY tmp2 .
COPY tmp3 .
COPY tmp4 .
COPY tmp5 .
COPY tmp6 .
COPY tmp7 .

ᐅ time docker build -t test .
Sending build context to Docker daemon  5.632kB
Step 1/9 : FROM python:3.7
 ---> 879165535a54
Step 2/9 : ARG d="disable-cache"
 ---> Running in ae2e42254f45
Removing intermediate container ae2e42254f45
 ---> 0fef1ccc9338
Step 3/9 : COPY tmp1 .
 ---> 6a56d481bf9f
Step 4/9 : COPY tmp2 .
 ---> 987610991299
Step 5/9 : COPY tmp3 .
 ---> 7b609886de0f
Step 6/9 : COPY tmp4 .
 ---> 0e33673cf934
Step 7/9 : COPY tmp5 .
 ---> ded12b9c9bb8
Step 8/9 : COPY tmp6 .
 ---> ce3cbf730920
Step 9/9 : COPY tmp7 .
 ---> 7984e0372e26
Successfully built 7984e0372e26
Successfully tagged test:latest
docker build -t test .  3.35s user 0.25s system 32% cpu 11.160 total

Takes 11 (!!!) seconds to build the container with python:3.7 cached. It should take 250ms...

I get what you are saying unfortunately I can only direct you to this thread How do I speed up or slim KDE?

Thanks, I've read this thread, tried everything there. Not sure even what could be the source of the problem. My laptop has good hardware.

1 Like

Could be related to this

Thanks again, @anon88164414 !:
I've tried running dd benchmarks, and using strace to analyze the docker build command, but that did not help. They are using RUN and I'm using COPY. Also, it seems to take a few seconds until seeing the "Sending build context to Docker daemon 5.632kB" which should also be a ~100 ms for 5kB... Again, this all works very fast on my Ubuntu dual boot.

1 Like

Try moving your question to technical issues assistance maybe you will have better luck there to receive an answer.

How to: Use the flag to request a nice moderator to do that for you.

One thought off the top of my head would be the kernel or the scheduler - as both are problably different than ubuntu. At least the kernel is a quick check - just add one (4.19,5.5,etc) from Manjaro Settings Manager and boot into it.
(also it seems you are using a RAID setup here? - maybe there are differences there too?)

Thanks, @cscs

I've changed my kernel to 5.5 and still nothing changed.

How would you go about inspecting the RAID setup?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by