Manjaro KDE unstable lately?

My manjaro kde all of a sudden became unstable.
First, when I boot up to Manjaro. My pc would freeze for like 5-10 seconds. Then everything would start appearing slowly like my start menu would appear and the widgets in it would slowly appear one by one.

Then after a short after. Everything would be unresponsive. The start menu would disappear. Everything in octopi would disappear. At this point, all I can do is restart.

I have no idea what happened here but Manjaro KDE was very fast the first month I have used it. Since I am using SSD, it will load to Manjaro really, really fast as in no slow loading like what's happening now.

Also weird issue happened to me prior to this, my virtualbox won't work with NS_ERROR_FAILURE (0x80004005) which I made another post about and remained unsolved. It's like the whole OS is slowly deteriorating. Right now, I am in Windows as I type this.

I really hope that I don't have to do a fresh installation of Manjaro again because I have performed many tweaks. This problem is the reason I am skeptical of Linux in general. Manjaro was the first distro that I was able to make my daily driver so it'll be a shame to ditch it and Linux all together.

And we are sure none of these are the culprit?
With no info we can only guess, so it remains a distinct possibility..

..Do you 'save sessions' ? Have you tried clearing old KDE configs/cache?
(cant think of all of them off the top of my head ... but theres some posts about it)

Also.. the most basic thing to usually include:
inxi -Fxxxz

[I run KDE on unstable on a newish ryzen machine .. no big issues here .. though there is an upstream QT bug that results in memory leak for some .. but it hasnt been pushed to stable]

If it isnt the profile/sessions/whatever stuff .. maybe check on baloo ( the file indexer )

1 Like

Are you using the Oxygen theme? There is a current issue with Qt 5.12.1 and Oxygen causing plasmashell memory usage to spike. If so change to Breeze, reboot / restart plasmashell, and see if that helps.

I will be honest, I am very sceptical of this thread, but we'll plow on regardless.

We cannot help without system info and log messages though.

inxi -v8
journalctl -p err -b

Please place all output text in code blocks.

Output Text

Your system honestly sounds like a complete mess from the other thread ... given your virtualbox "issue" was caused by installing all the available virtualbox packages in the repos ... all the host packages, all the guest packages, the vnc client package, the sdk ... all of them.

You are also running the real time kernel, any particular reason why?

Yeah ... but not taking the time to properly learn how Linux hangs together would be a shame also.

Sorry, I am very new to Linux. The Tweaks I have performed are mainly mounting my hard drives automatically in fdisk and installing mullvadd which is pain in the ass and also I had to learn how the file structure of linux works so I could understand all the mounting and just not blindly follow instructions.

I haven't really made any major tweaks for the past month. Last week I installed Virtualbox and the past few days when things start getting unstable.

I'm also sorry if I couldn't provide logs for I don't know where to find them or what to type. Yeah, really really noobish here but I really don't want to give up.

No worries. Dont give up :wink:
When we post commands like inxi -Fxxxz put those in terminal.
Then copy the output here and highlight and click the </> button so it is readable

1 Like

Thanks will report back.

tbh, Linux is just too complicated for me. There are so many codes you need to type and remember to get it running. I suck at memorizing. For me to properly use Linux. I'll have to have a sticky notes around my monitor. lol.
I was hoping that I don't have to deal much with this with Manjaro.

I mean, I am a big Android fan which I believe is also part of Linux but you can do most complicated things in there like rooting, unlocking the bootloader, custom kernels, without typing codes. The most you need to type in Android is basically. "fastboot" commands.

anyway before I stray so much from the issue. I don't want to give up. It's just I am so clueless in what to do.

There are often 'easier' (meaning GUI button pressing) ways to do much of what might be suggested as a command. But it is actually 'easier' (as in known input/output and to explain or copy/paste, with text output .. and 'simpler in that it is one command, not many click steps) to use terminal commands .. especially from a 'helper' point of view.
As to the android thing - yes android uses an (old,slightly modified and branded) linux kernel.

1 Like

A rolling release like Manjaro may not be the best distro for you then. It requires a degree of knowledge and learning, has updates almost every week, and needs to be maintained to stay healthy.

Maybe something like MX Linux or Linux Mint would be more suitable, although they don't offer KDE.

Or maybe a Debian or Ubuntu flavoured LTS distro where the package base doesn't change much for years and requires less knowledge to maintain. Software is pretty long in the tooth, but it is easier to user.

1 Like

Just went back to manjaro.
I could confirm that I am not using oxygen theme. I use Air so hopefully there's nothing wrong with that theme too.

System:    Host: ---- Kernel: 4.19.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.0 
           tk: Qt 5.12.1 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 2441A75 v: ThinkPad W530 serial: <root required> Chassis: type: 10 
           serial: <root required> 
           Mobo: LENOVO model: 2441A75 serial: <root required> UEFI: LENOVO v: G5ETB0WW (2.70 ) date: 03/08/2018 
Battery:   Device-1: hidpp_battery_0 model: Logitech M570 serial: 1028-a8-e8-bd-0d charge: 95% rechargeable: yes 
           status: Discharging 
Memory:    RAM: total: 7.61 GiB used: 997.8 MiB (12.8%) 
           RAM Report: permissions: Unable to run dmidecode. Are you root? 
PCI Slots: Permissions: Unable to run dmidecode. Are you root? 
CPU:       Topology: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
           stepping: 9 microcode: 20 L2 cache: 6144 KiB bogomips: 41519 
           Speed: 2034 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 2034 2: 2165 3: 1643 4: 3282 5: 1952 6: 2957 7: 2470 
           8: 2511 
           Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de 
           ds_cpl dtes64 dtherm dts epb ept erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs ida lahf_lm lm 
           mca mce mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 
           pti pts rdrand rdtscp rep_good sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
           tsc tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0166 
           Device-2: NVIDIA GK107GLM [Quadro K1000M] vendor: Lenovo driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:0ffc 
           Display: x11 server: X.Org 1.20.3 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.3.3 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k4.19.23-1-MANJARO 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: 3.2.6-k port: 7080 bus ID: 00:19.0 
           chip ID: 8086:1502 
           IF: enp0s25 state: down mac: 3c:97:0e:69:b7:24 
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: 6000 bus ID: 03:00.0 
           chip ID: 8086:0085 
           IF: wlp3s0 state: up mac: 84:3a:4b:32:28:e2 
           IP v4: type: dynamic noprefixroute scope: global broadcast: 
           IP v6: fe80::3c50:12aa:769d:c0eb/64 type: noprefixroute scope: link 
           WAN IP: 
Drives:    Local Storage: total: 655.85 GiB used: 260.12 GiB (39.7%) 
           ID-1: /dev/mmcblk0 model: UD128 size: 119.28 GiB block size: physical: 512 B logical: 512 B serial: 0xbafb05ee 
           scheme: MBR 
           ID-2: /dev/sda model: SPCC Solid State Disk size: 238.47 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: AA000000000000000588 rev: 2A0 scheme: GPT 
           ID-3: /dev/sdb vendor: HGST (Hitachi) model: HTS725032A7E630 size: 298.09 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: TF645AY1GP6YDL rev: B550 scheme: MBR 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 36.00 GiB size: 35.31 GiB (98.08%) used: 18.89 GiB (53.5%) fs: ext4 dev: /dev/sda8 label: N/A 
           uuid: deb35027-61a3-46c1-b9fc-478c39c1de87 
           ID-2: /boot/efi raw size: 512.0 MiB size: 511.0 MiB (99.80%) used: 284 KiB (0.1%) fs: vfat dev: /dev/sda5 
           label: N/A uuid: 1615-FCAA 
           ID-3: /home raw size: 15.00 GiB size: 14.70 GiB (98.01%) used: 3.90 GiB (26.5%) fs: ext4 dev: /dev/sda7 label: N/A 
           uuid: 5bdbe87f-b58a-4ab4-a317-04c3e1415be8 
           ID-4: /locald raw size: 264.62 GiB size: 264.62 GiB (100.00%) used: 133.33 GiB (50.4%) fs: ntfs dev: /dev/sdb2 
           label: Local Disk uuid: 104643324643183C 
           ID-5: /sdcard raw size: 113.27 GiB size: 113.27 GiB (100.00%) used: 103.72 GiB (91.6%) fs: ntfs dev: /dev/mmcblk0p1 
           label: N/A uuid: 01D1DAB2F34A9440 
           ID-6: swap-1 size: 2.00 GiB used: 279.5 MiB (13.6%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda6 label: N/A uuid: 3005d7c7-46f9-4738-a9c3-126f4e37713e 
Unmounted: ID-1: /dev/sda1 size: 499.0 MiB fs: ntfs label: Recovery uuid: 70A402C6A4028EB2 
           ID-2: /dev/sda2 size: 100.0 MiB fs: vfat label: N/A uuid: CA07-04CF 
           ID-3: /dev/sda3 size: 16.0 MiB fs: <root required> label: N/A uuid: N/A 
           ID-4: /dev/sda4 size: 184.37 GiB fs: ntfs label: N/A uuid: F2B817D2B81793E7 
           ID-5: /dev/sdb1 size: 499.0 MiB fs: ntfs label: System Reserved uuid: 8ACEF7F1CEF7D403 
           ID-6: /dev/sdb3 size: 2.98 GiB fs: ntfs label: Recovery uuid: AC6EF9CB6EF98DF8 
           ID-7: /dev/sdb4 size: 30.00 GiB fs: ext4 label: Storage uuid: 938a7928-84d6-48c1-b168-6b67bdfcb777 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s chip ID: 8087:0024 
           Device-1: 1-1.1:3 info: Lenovo Integrated Smart Card Reader type: Smart Card driver: N/A interfaces: 1 rev: 2.0 
           speed: 12 Mb/s chip ID: 17ef:1003 
           Device-2: 1-1.2:4 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid 
           interfaces: 3 rev: 2.0 speed: 12 Mb/s chip ID: 046d:c52b 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 speed:
           Hub: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed:
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A gpu: nouveau temp: 39 C
           Fan Speeds (RPM): cpu: 1988 
Repos:     Active pacman repo servers in: /etc/pacman.d/mirrorlist 
Processes: CPU top: 5 
           1: cpu: 10.2% command: firefox pid: 1359 mem: 362.8 MiB (4.6%) 
           2: cpu: 7.3% command: firefox pid: 1144 mem: 279.8 MiB (3.5%) 
           3: cpu: 4.4% command: kwin_x11 pid: 1003 mem: 63.8 MiB (0.8%) 
           4: cpu: 4.0% command: plasmashell pid: 1009 mem: 128.2 MiB (1.6%) 
           5: cpu: 3.6% command: xorg pid: 768 mem: 76.2 MiB (0.9%) 
           Memory top: 5 
           1: mem: 362.8 MiB (4.6%) command: firefox pid: 1359 cpu: 10.2% 
           2: mem: 279.8 MiB (3.5%) command: firefox pid: 1144 cpu: 7.3% 
           3: mem: 169.7 MiB (2.1%) command: systemsettings5 pid: 1605 cpu: 0
           4: mem: 160.5 MiB (2.0%) command: firefox pid: 1382 cpu: 1.6% 
           5: mem: 128.2 MiB (1.6%) command: plasmashell pid: 1009 cpu: 4.0% 
Info:      Processes: 218 Uptime: 8m Init: systemd v: 241 Compilers: gcc: 8.2
           inxi: 3.0.30 

-- Logs begin at Wed 2019-01-30 15:26:41 PST, end at Fri 2019-02-22 23:09:04 PST. --
Feb 22 23:03:20 ----- kernel: ACPI Error: Field [TBF3] at bit offset/length 188416/196608 exceeds size of target Buffer (368640 bits) (20180810/dsopcode-201)
Feb 22 23:03:20 ----- kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.PEG.VID.GETB, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Feb 22 23:03:20 ----- kernel: ACPI Error: Method parse/execution failed \_SB.PCI0.PEG.VID._ROM, AE_AML_BUFFER_LIMIT (20180810/psparse-516)
Feb 22 23:06:51 -----sudo[1786]:    ----- : a password is required ; TTY=pts/2 ; PWD=/home/----- ; USER=root ; COMMAND=/sbin/file -s /dev/sda3

Is air a kvantum theme?

Try changing to Breeze / Breeze-Dark and see if your instability goes away.

Your symptoms sound like a plasmashell memory leak.


I love Manjaro and I rather just learn it. It's hard to let go of pacman too. And of course, the community of Manjaro which is the most helpful community I've seen.


True dat ... makes learning easier too when the community is willing to help out when you get stuck, no other distro really compares in that regard.

Just remember to use the Manjaro wiki, Arch wiki and this forum to research how to do something before diving in and making a mess (ie virtualbox :wink: ).


Awesome man! I changed to Breeze and It booted up instantly again just like before! And to my surprise my machines finally booted up on vritualbox. I never experienced memory leaks so I have no idea that this symptom is actually a sign of memory leaking. It's also weird how memory leaking can actually render your whole system unstable. Yikes!

anyway, thank you so much and @cscs ! My system is stable again.

1 Like

Glad to hear it. Well-curated themes usually dont exhibit this behavior .. but especially with big changes to KDE sometimes some themes become 'dated' because of some new code .. again, usually not something to worry about with well-maintained themes, but as you found it can happen.
Welcome back!
[Breeze is the one KDE uses in-house .. so its the default to check]

1 Like

Just one more thing.
What did you mean by?

You are also running the real time kernel, any particular reason why?

Your kernel is of the kernel-RT variant ... unless you are doing professional media production (album recording, etc) .. then it is not necessary .. and possibly a less-than-optimal choice.
Use Manjaro Settings Manager to switch to a regular LTS like 4.19 and reboot to it :slight_smile:

1 Like

This is a kernel specifically built with the real time kernel patches applied.

As @cscs pointed out, you should only be using real time kernels for specific applications and specific use cases.

If you don't know what this is then you shouldn't be using it, best to install either / both 414 and 419 kernels, boot into one, and remove both real time kernels.

1 Like

Good idea, lol. :smiley::+1:t2: I've kept one document and updated it, since coming to Linux 21 months ago (Mint, then a few months on Neptune, and now 2 months on awesome Manjaro). I'm not too good with remembering code, and just add a note of things I learn along the way eg 1st I have a section on how to update, and any important main commands, then any hardware stuff ie installing a couple of packages so Ugee 2150 is seen and works fine, then specific software installs/settings. I just add anything learnt into the right section.

Great to have the information there, and easier to steadily learn a little bit at a time.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by