Manjaro Keeps Freezing

Ok, I'll try this again since my other account got deleted apparently for some reason... Anyway, so I installed Manjaro KDE on my machine... I updated everything, installed the GPU drivers, but it keeps freezing at random times...? Everything just stopped working, mouse, keyboard, everything so I'm forced to do a hard restart... but now it won't even load!! What's going on??


Unless psychics frequent this forum, I don't think anybody could find what's going on :wink:


Please post your specs as requested:

inxi -Fxxxz

I would also test several newer kernels and several older kernels to see if things improve. Install all kernels through Manjaro Settings Manager, and always keep at least 2 kernels installed for safety.

If you cannot boot then use the terminal to install the kernels:

sudo mhwd-kernel -i linux414 

sudo mhwd-kernel -i linux419 

sudo mhwd-kernel -i linux50

sudo mhwd-kernel -i linux51
1 Like

I don't think you can install Manjaro KDE without GPU drivers. :wink: In fact there is a forced choice -> free or non-free, which did you make?

Did the install reboot and work fine before updating? After updating did you reboot and confirm that it was still working. What GPU drivers did you later install, and how? (Were the older ones removed?)

There was no selection for GPU drivers... I don't believe so anyway and I installed and reinstalled it probably 10 times now lol

Have you tested different kernels or perhaps different kernel boot parameters yet.

You have also still not posted your specs yet. Generally, you will not receive any useful assistance until you post your specs. This has been requested twice from you now.

You can use USB phone tethering to get a temporary internet connection if you currently don't have a working connection.

By specs do you just mean my machine or OS info as well? AMD Phenom II X6 3.2ghz, 8GB DDR3 RAM, 2x Nividia 550ti SLI, GPU driver 391.35, 500GB HDD. I WAS running Manjaro KDE stable, not sure which kernel, whatever one comes on a fresh install... I never got a chance to see that... Back on my Windows partition for now until I figure this out... I'm sorry, I know everyone is trying to be helpful and I'm not helping you all be helpful lol. Just new at this I guess

So, I've been doing some reading and apparently the Nvidia drivers don't really support SLI yet. I have two GPUs in SLI, could that be why it keeps freezing?

I always run a very basic video setup as my graphics demands are very slight. I have never used SLI mode so I can't really comment on that. I could easily see that causing issues though.

Perhaps someone else can give you a more informed opinion.

Ok... Thank you... It is rather frustrating because I've tried a couple different distros and the same thing happened in all of them...

At least in general Nvidia SLI does work. See: It might need some configuration to setup.

Also a quick forum search reveals several users happily rocking SLI setups.

1 Like

Ok, so I just did another fresh install of Manjaro, loaded up the first time, but when I went to reboot I got stuck on this... (Image attached) IMG_20190428_220326590

there is irqbalance package
install it and
systemctl enable irqbalance
also you may try updating your bios
or restore bios to its factory default settings.

1 Like

So is this a newish Manjaro-kde install on a slightly under-spec? If your hardware tests and checks ok. And you've low level formatted your drive if its had windows on it and its not an SSD. Baloo and krunner are the usual culprits. As baloo begins to index your system. Once this is complete you'll be good to go. Or you can disable Baloo in system settings then let it run when not in use. Of all distros with kde, Manjaro seem to have this sorted though. I found Baloo in Kde-neon to be brutal on sys. resources until indexing had finished.

There IS a option at install for Free Driver. your Manjaro ISO is not special.

Select that option and you are presented with Free Driver or Non-free Driver.
Choose non-free driver. This will make a huge difference.
Before you reinstall...
Default your bios. Make sure Secure Boot is OFF. Other OS Compatability is ON.
If you Motherboard has an Optimal setting activate it. Turn on IOMMOU AMD Virtualisation (something like that)
Make sure your RAM is set for right frequency in Bios. Make sure the HDD is set UEFI. Set AHCI ON.

Is the Graphic option set correctly? Is the nVidia the primary card with the onboard vga turned of?
Is Graphics BOOST turned off on you board or Bios? This is for onboard use only.

AMD Phenom II / nVidia 550ti are a notoriously bad coupling. Fault finding is a skill. Start at the beginning and the fault is the last thing you'll find. I promise!

Have you blown the PC power supply, Motherboard and heatsinks out with a water filtered compressor. Is your CPU fan functional? Have you tested your PC power supply? All system voltages are correct? cmos battery holding correct charge? Memtested your ram? Low Level formatted your drive (if not ssd) and software tested with Parted Magic? Have you pulled your system apart to check for Box screws under mainboard? Nothing causing micro shorts? Reseated your cards ? Updated the bios? Checked the fidelity of your installation media/usb? Checked the iso? Verified the Iso? If the previous check O.K! then its the Baloo file indexing. Perfectly normal. Check whats dragging the resourses down in the Kde system monitor app. Check cpu usage, Memory usage. Go to system setting and turn Baloo off if its dragging your system down.

I installed the proprietary drivers, but still got that bug... I'll try going through the list of tasks you suggested. Maybe I'll find a fix

The system isn't dragging, it's simply not moving. Just gets stuck on the screen I posted an image of...

If it is Baloo however, what is the command line to disable it? I can still access that by pressing CTRl+ALT+ F2

balooctrl disable
Dont know if this is still valid.

Oh it's still valid, my friend lol. It's still stuck on that mostly black screen whenever I load into Manjaro... I will try that command and the other functions in the article. Thank you!

Forum kindly sponsored by