Manjaro MATE - Update fails after fresh install

Hi There,

I ran into troubles updating Manjaro after a successful installation. I used a USB drive with the Manjaro MATE 18.1.0 Iso on it.
Firstly when first booting the new install I noticed that there is Kernel 5.2 installed, which is actually not supported anymore (is this normal when using a fresh Iso image?). However I updated to Kernel 5.4 as suggested, which installed fine. Then I installed the new updates with pamac but then pamac failed to install this step.

Checking keyring...
Checking integrity...
Loading package files...
Checking file conflicts...
Checking available disc space...
Error: hook /usr/share/libalpm/hooks/90-mkinitcpio-install.hook line 2: invalid value Path
Error: hook /usr/share/libalpm/hooks/60-mkinitcpio-remove.hook line 2: invalid value Path
Failed to commit transaction:
failed to run transaction hooks

I found something like this in the following thread: Package install in chroot

So once before I ran into similiar problems and rebooted Manjaro after updating the kernel but then Manjaro did not boot with this message:

IMG_20200129_182504

Any ideas how to fix this? I do not have the heart to reboot right now.

Kernel Linux 5.2.11-1-MANJARO x86_64

yes, good link. old iso ! with pacman 5.1
new packages (with hook) are only pacman 5.2 compatible. And if no pacman hook, we can't install kernel

2 Likes

Hi @papajoke,

thanks for your answer. I downloaded the image yesterday so I am a bit confused. I'll try it now again to be sure.

You're right pacman is in version

Pacman v5.1.3 - libalpm v11.0.3

Mickey

I downloaded the Manjaro MATE Iso right now and booted to the live system.


[manjaro@manjaro-mate ~]$ pacman -V

 .--.                  Pacman v5.1.3 - libalpm v11.0.3
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2018 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.

[manjaro@manjaro-mate ~]$

So do you know how I should proceed? Do I have to upgrade pacman before proceeding?


[manjaro@manjaro-mate ~]$ sudo pacman -Sy pacman
...
 installing pacman (5.2.1-4) breaks dependency 'pacman<5.2' required by pamac-common
[manjaro@manjaro-mate ~]$ 

Mickey :slightly_smiling_face:

Why does this keep coming up? This is exactly the wrong way to install packages.

If for some reason you must sync while/before installing a new package you must also update:

sudo pacman -Syu pacman

(though, obviously, pacman is already installed so an update would .. update it.. sudo pacman -Syu)

Back to your general issue ... yeah there is a bit of a problem here because the MATE ISO has not been updated in a while so it is in a virtually broken state out-of-the-box.

(I quickly tried to find the maintainer of mate commuity edition ... bubt going back over 6 months I still couldnt find out who it was .. so it feels arguably abandoned...)

1 Like
  1. remove pamac
  2. update pacman
  3. update system
  4. re-install pamac

You're completely right, however the update process fails. Maybe @Ste74 has a hint to make this function properly.

Mickey

I think I have to update the package database to make this possible

[mickey@manjarohp ~]$ sudo pacman -R pamac
error: target not found: pamac

Mickey

Sorry, I don't know what pamac packages are installed on your system, try querying them:

$ pacman -Qsq pamac

I get the same error as on updating:


[mickey@manjarohp ~]$ pacman -Qsq pamac
pamac-cli
pamac-common
pamac-gtk
[mickey@manjarohp ~]$ sudo pacman -R pamac-cli pamac-common pamac-gtk
[sudo] password for mickey: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: manjaro-application-utility: removing pamac-gtk breaks dependency 'pamac>=8.0.0'
[mickey@manjarohp ~]$ sudo pacman -R pamac-cli pamac-common pamac-gtk manjaro-application-utility
checking dependencies...
:: manjaro-hello optionally requires manjaro-application-utility

Packages (4) manjaro-application-utility-1.1.4-5  pamac-cli-8.0.4-7
             pamac-common-8.0.4-7  pamac-gtk-8.0.4-7

Total Removed Size:  3,70 MiB

:: Do you want to remove these packages? [Y/n] 
error: hook /usr/share/libalpm/hooks/90-mkinitcpio-install.hook line 2: invalid value Path
error: hook /usr/share/libalpm/hooks/60-mkinitcpio-remove.hook line 2: invalid value Path
error: failed to commit transaction (failed to run transaction hooks)

Ah pacman on the ISO is too old for current hooks, see

You can try getting pacman-static and updating with that one:

Yeah thank you,

This solves the issue Unrecognized archive format pour fichier pkg .tar.zst.
Albeit I know that there is already mich to do I wonder whether the ISO will be updated soon.

(is there something like a gitlab repository where these Images are beging created?)

Mickey

As mentioned in post #5: Mate ISO is a community edition and at the moment it looks like it's not been kept up to date. The last announcement is 3 months old.

Well an updated isos coming soon.. this week end can be the days..

3 Likes

That's awesome!

Mickey :blush:

Very sad -
Being new to the distro, this is not really acceptable. For other new users, my hope is they get it worked out. Back to the old guys..., :*(
/thks

For those users experiencing the same issue described Manjaro MATE - Update fails after fresh install :
You can resolve this issue by updating pacman

wget https://pkgbuild.com/~eschwartz/repo/x86_64-extracted/pacman-static
chmod +x pacman-static
sudo ./pacman-static -Syyu

thanks to Philip Müller!

Mickey :slightly_smiling_face:

1 Like

Hate to tell ya, but you did technically download the MATE edition from the "Community Maintained" section. Not the officially supported section. Meaning that one or more individuals from the community volunteered their time and effort to maintaining the MATE edition. They either don't have the time, or the desire to maintain it anymore. In all honesty they were under no obligation to maintain it anyway so the reason is irrelevant.

I will admit I found this post because I am having the exact same issue, I just loaded an official version and installed the MATE desktop after the fact. Your post did inspire me to create an account on the forums though. :+1:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by