Manjaro not booting from hard disk, just stays in the boot menu

I have made a clean install on manjaro (xfce) using a live USB, but when i try to boot from Hard disk, it just stay at the boot menu.
The boot menu shows the Hard disk & the CD drive.

I have UEFI disabled in the boot and fast boot too is disabled

I tried to multiple times (once created the hard disk partitions manually, once let majaro erase the complete hard disk and install). None of them worked.

Can someone help me


Can you provide a pic of what you are seeing on the screen where it is stuck?

Try booting up using this and let us know if this boots. (It may not). If booted, let us know

sudo parted -l
sudo blkid
cat /etc/fstab

If you have other OS's, let us know and in which partition.

1 Like

This is the screen where it stops. When I choose the"SATA HDD", it comes back to the same screen again.



@gohlip. No luck with the option you mentioned, it didn't boot.

I had windows and Ubuntu installed prior to this(windows was corrupt and not letting me in). I had erased the entire disk while trying Manjaro install.

FYI.., couple of more information, if it helps to troubleshoot.

When it boots from live USB, it says this line "Installed BIOS-System on hd1, msdos1"

Also, when I remove the live USB power on the laptop, it powers off for couple of seconds and then powers on automatically.

Okay. If it doesn't boot, even when using grub prompt at the link, I suggest you reinstall.

A few points when reinstalling.
Prepare your disk using gparted first. Set 'device' --> partitioning --> msdos
Set up your partitions in that gparted after above.
When booting up install media, boot in bios-legacy mode.

Good luck.

Man… I had the same issue… just worked when I setted as UEFI and the disk as GPT…


Are you sure you only have one harddrive and not two or maybe a special boot drive? We need that screen shot for sure.
What laptop is it?

Please make sure your root device/partition has the "boot" flag set. You might use GParted to check that. Example: /dev/sda1


Thanks everyone, I had reinstalled once.
I guess the issue was the "boot" flag was missing, I did choose the flag while installing, but looks the flag didn't stay, it worked after I applied the flag using gparted



Forum kindly sponsored by