Manjaro not booting on raspberry pi after update


I installed Manjaro Arm for Raspberry Pi 4, the latest, 19.10 I believe. I got the /boot partition on a sd-card and the OS on a SSD. Everything works great. Until I update..

When I update and reboot, my system hangs at ‘Started TLP system startup/shutdown’ and
‘Started hide bootsplash after starting the system’.

I can get into the terminal and use it. Only the whole screen glitches and seeing things is really hard. So far, the only thing that worked is reinstalling the whole OS. But that’s not a long time solution.

Does anyone have the same issue? Or even better, a solution? I tried every google link I found on this subject but no luck.

Thanks in advance!

You could have posted /var/log/Xorg.0.log. Just login to the terminal, run startx, wait for it to fail and run

sudo pacman -S pastebinit
pastebinit -i  /var/log/Xorg.0.log

and share the link.

Thanks for answering.
Here is the link:

Best regards!

1 Like

I would say you need to downgrade Xorg.
Can you run
pastebinit -i /var/log/pacman.log

Here u go:

I don't know, the fle doesn't contain old enough logs. On which date was that update?

I reinstalled Manjaro on the 30th of October. Yesterday I updated Manjaro to recreate the problem. That why the logs aren’t very old. Even when I update right after I installed, I get the same problems.

1 Like

Ok, then I would try to downgrade

  • mkinitcpio
    because of changes which can make Manjaro unbootable:

If that doesn't help try downgrading either

  • mesa or
  • linux-rp4 linux-rp4-headers
1 Like

I don’t really know how to downgrade. I tried to install the package ‘downgrade’ but Pacman can’t find it.

Have you found this article?
But I don't know if it works on ManjaroARM.
You could search the location on a mirror and then run:
sudo pacman -U URL

Edit: Can you post /etc/pacman.d/mirrorlist content? Then I can help to find the address of the package.

Here is the link:

ETA: Yes I have found and tried that link. But it didn’t work...

mkinitcpio 26-1 isn't available anywhere anymore. You can try to upgrade to mkinitcpio 27-2. Just run sudo pacman -Syu
If 27-2 doesn't resolve the issue, reinstall Manjaro and edit /etc/pacman.conf like this:
Uncomment the line with IgnorePkg = and set it IgnorePkg = mkinitcpio.

When I ask Pacman to upgrade mkinitcpio it says that 27-1 is the latest version. It can’t find 27-2.

Okay I reinstalled Manjaro and I am updating now.
In the config I am ignoring the following packages:

  • mkinitcpio
  • mesa
  • linux-rpi4
  • linux-rpi4-headers
  • kmod
  • libglvnd

I’m ignoring also libglvnd because it could not be upgraded without mesa apparently.
Is it a good idea to upgrade the last 6 packages one by one so I can determine what breaks Manjaro or should I just wait for fixes?

ETA: Update finished and Manjaro is booting!
My question remains tho :wink:

1 Like

Clone the current system to a different SD card and try a full update after commenting out IgnorePkg in pacman.conf
If it works, then it's resolved. If not then use the other SD card.

Going to do that.
I wanted to be sure and updated linux-rpi4 and linux-rpi4-headers and then the pi wouldn’t boot anymore. So the problem is in one of these packages I think.

ETA: I have Manjaro on my SSD and a boot partition on the SD card. Do I need to copy the boot partition again to the SD card after updating linux-rpi4 and linux-rpi4-headers? Or is that not necessary?

ETA 2: Narrowed it down to linux-rpi4. That’s the only package that is causing problems for me. Perhaps you know why?

ETA 3: Updated linux-rpi4 and surprise surprise it wouldn’t boot. So I tried to copy the updated boot partition of my SSD to my SD and it booted fully upgraded. Only one problem.
As soon as I connect a keyboard or mouse via usb, it crashes. Like my tv says no signal.
Any thoughts?

I don't know. Maybe @Strit knows.

This is an ambiguous question. Maybe you can post your /etc/fstab?

The /boot partition needs to be on the SD card. And it needs to be mounted via fstab, to get the updated kernel files.

Regarding the USB issue, I don't know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by