Manjaro not starting. Can't find any solution and pinpoint exact reason!

I've looked everywhere and I still can't find the fix fot my problem

I installed Manjara two days ago to give Linux another try and just see how it performs nowadays.
At the beginning everything seemed to be working fine, until changed kernel, although I also had problems with setting Manjaro in UEFI.

I'm trying to run it as secondary system to Windows.
I have HP laptop with NVMe ssd, UEFI, GPT and TPM, secure boot is off of course, although I can't find any fast boot options in BIOS so I'm not sure if it's even there.

I think I've looked through every guide for fixing GRUB, and correctly setting up dual boot, and still nothing worked.

To the point:

I switched kernels, pretty much just to see how that works and on next reboot, OS just got stuck on this:

But from what I've read these are harmless.

Space pointer is just flickering like crazy, and ctrl+alt+f4 console (I'll be glad to know how it's called :wink: ) is unusable. It also flickers. I was able to access terminal by editing grub settings though. I can also perform manjaro-chroot in LiveCD environment, but no luck with
mhws-chroot. Strange thing is that I can launch Manjaro in UEFI-Legacy mode, hower the screen is offset, and there are definitely many other graphics problems. But it's still somewhat usable and sometimes it even has correct colors.

Not having much to loose I decided to re-install Manjaro. I used "replace partition" option as I did the first time. After making sure everything is uptodate I changed kernel once again to see if the problem would show up again... and it did.

I re-installed Linux for third time, but this time I decided to follow this post
I followed it step by step and because of that I was also able to create correct (I think) UEFI setup.
I tested the same thing again, but this time Manjaro launched without any problems after switching kernels!!! I went back to original one and everything went smoothly again.

I started setting up system to my liking. I only installed apps like Chrome, Spotify etc. and edited theme a bit. (The first time I installed Manjaro nothing wen't wrong with that).
Then I restarted my laptop... and I was back to the start. Manjaro wouldn't boot again!

I know that the simple answer would be to just not switch kernels :smile: but I worry that if I start using Manjaro more as my main operating system that could happen again with something like system update and I would really like to avoid that. Even if not I think that having something small that doesn't work in bigger system is never a good thing.

I hope I included enough information to work with. Thanks from replies upfront anyway :relaxed:

P.S. EFI partition is shared by Manjaro and Windows

You worry has a strong base! If you want to avoid "incidents" like that you should stay away from Manjaro and Archlinux. They are for men heroes!
Just joking.. But the answer is the same.. sorry.

The guide also suggest to post output from the following

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi
note: ‘parted -l’ --> small ‘L’ and provide information of all disks. [a]

Short answer

Long answer

But first you have to decide if you are going down the road with Manjaro. Have you read my previous post?

So that's the output:

efibootmgr -v

BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0000,0002,0001,0004,0003
Boot0000* Windows Boot Manager  HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...t................
Boot0001* Solid State Disk      PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-25-38-B3-71-B3-65-85)/HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)..BO
Boot0002* manjaro       HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0003* USB Drive (UEFI) - Generic USB Flash Disk 0.00        PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/CDROM(1,0x3fa900,0x8000)..BO
Boot0004* USB Drive (UEFI) - Generic USB Flash Disk 0.00        PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(2,MBR,0x788db7cc,0x3fa900,0x2000)..BO

parted -l

Model: Generic USB Flash Disk (scsi)
Disk /dev/sda: 4043MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2136MB  2136MB  primary               boot
 2      2136MB  2140MB  4194kB  primary               esp

Model: Unknown (unknown)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  524MB  523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32           EFI system partition          boot, esp
 3      629MB   646MB  16.8MB                  Microsoft reserved partition  msftres
 4      646MB   201GB  201GB   ntfs            Basic data partition          msftdata
 6      201GB   223GB  21.5GB  ext4
 7      223GB   225GB  2147MB  linux-swap(v1)
 8      225GB   255GB  30.2GB  ext4
 5      255GB   256GB  971MB   ntfs                                          hidden, diag


/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/nvme0n1: PTUUID="e8ab7348-3987-40b7-a68b-4e1e0fbd95c0" PTTYPE="gpt"
/dev/nvme0n1p1: LABEL="Recovery" UUID="6AD026FBD026CCDF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="0d10c6ba-6ee7-4bbf-b837-4f82204b54dd"
/dev/nvme0n1p2: UUID="B627-E000" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="9a6ac096-cef1-458c-9c67-b06d9dc60477"
/dev/nvme0n1p3: PARTLABEL="Microsoft reserved partition" PARTUUID="b2bd6fcb-f6d9-4569-b4e4-ca5b40b97740"
/dev/nvme0n1p4: UUID="9AD234EAD234CBEF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="77d1ebae-4567-4f8f-8d8e-46f007521d44"
/dev/nvme0n1p5: UUID="66B09482B09459FF" TYPE="ntfs" PARTUUID="5350639b-7707-4eaf-aa22-f45110cba200"
/dev/nvme0n1p6: UUID="cbe695da-ab4b-4788-80d8-dd65295dc8c6" TYPE="ext4" PARTUUID="2b3e10fa-4ec5-498e-baf0-ab7b29323fa6"
/dev/nvme0n1p7: UUID="8a6150e1-e99a-4832-b2f5-fbc251995fc7" TYPE="swap" PARTUUID="fb3ed039-f3fe-41d0-bd54-c866f8c404bb"
/dev/nvme0n1p8: UUID="6c41c854-324d-4aa5-9057-56f5be7ef4cf" TYPE="ext4" PARTUUID="e3453ed2-44e8-4cc0-9b21-27783f9dab20"
/dev/sda1: UUID="2018-05-07-19-31-30-00" LABEL="MJR17110" TYPE="iso9660" PARTUUID="788db7cc-01"
/dev/sda2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="0040-24ED" TYPE="vfat" PARTUUID="788db7cc-02"

findmnt -s

TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=B627-E000                            vfat   defaults,noatime
/         UUID=cbe695da-ab4b-4788-80d8-dd65295dc8c6 ext4   defaults,noatime
swap      UUID=8a6150e1-e99a-4832-b2f5-fbc251995fc7 swap   defaults,noatime
/home     UUID=6c41c854-324d-4aa5-9057-56f5be7ef4cf ext4   defaults,noatime

findmnt /boot/efi/

/boot/efi /dev/nvme0n1p2 vfat   rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,

Use proper wrapping for the code, it's hard to read. Use the pre-formatted text button.

I hear you. Maybe I'll do my homework with something more stable, and maybe one day I'll move to Manjaro / Arch if I feel like it :upside_down_face:

1 Like

You need to feel comfortable with reading manuals/wikis etc (have you heard of RTFM?), so it will not be a nightmare for you. It's just not fair!..

Stay close! :raised_hand_with_fingers_splayed:

Well... I haven't :grin:

I like solving problems, so for the harder the better but I guess if I don't have enough experience I shouldn't make my life living hell

Thank You very much for reply

1 Like

I'm going to make a wild assumption and suggest you reinstall but sudo pacman -Rncs kernel-alive on your first boot of the installed system. Then, update and install a new kernel and see if the issue persists.

@moso 2 things.

  1. Your efibootmgr does not have 'manjaro' as first boot. It has 'windows'
    To set 'manjaro as first boot.
    sudo efibootmgr -o 0002,0000

  2. It is still possible not to boot manjaro because of your 'acpi' issues
    But we can see if that boots to prompt. To boot to prompt,
    At grub menu, press 'e’
    Arrow down to linux line
    Arrow right past ‘quiet’ and 'splash’
    Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
    Add ‘3’ (without apostrophes meaning just 3)
    Press F10 or ‘ctl’ + ‘x’ to boot
    login with password to prompt.

If it boots to prompt, then your grub is not an issue and you just have to fix the acpi issue but I'm no good in it. Follow jonathon or other people's solution on this.
But I suggest you do the following first at prompt and then follow their instructions.
sudo pacman-mirrors -f 5
sudo pacman -Syyu

Should kernel-alive be installed by default?
Because it I get this:
sudo pacman -Rncs kernel-alive error: target not found: kernel-alive

I installed it and just rebooted the system without kernel change. On next bootup and shutdown I didn't see any acpi errors though, so I think it did something anyway. However after next reboot kernel-alive was gone once again.

I know since it didn't work I just switched to Windows as my primary.
But thank you on advice on how to do it from terminal!

I did that before (although in slightly different manner), so I also don't think it's the GRUB

although I'm not sure if I could run sudo pacman -Syyu with wi-fi because I don't have Ethernet port and I wasn't able to set up connection with router, but maybe I just haven't done it the wright way.


Okay, I agree too.

Okay, tough. As said, others have to come in here.
How's jonathon's idea?

Just look here :wink:

Now I'm waiting for his response

Ok, sorry. Missed seeing this also (on other topics as well).
Good luck. Hope you got this solved. Take care.

1 Like

Why would you install something I suggested you remove?

That's the exact opposite of the intended outcome.

As it is, if it's not installed by default then it's not a factor.

I'm sorry I misunderstood your directions :persevere:
I'm a bit hot-headed sometimes and English is not my mother tongue, so I hope you can forgive me this one time

But I assume that doesn't really help you in finding the solution, so if there is any more info I could provide to make it easier just tell me.

On the other hand changing kernel is not something I really need wright now so I can just ditch it

1 Like

I guess so.
Have you tried the initial advices about your UEFI boot problem?
See my first post (short answer) and gohlip suggestion Nr.1, to change boot order.

Well I think my UEFI setup has been working fine from the beginning.
From my initial post:

so Manjaro is showing in UEFI and as I said earlier here the boot order was changed because I wanted it to be, at the time.
I could always just start it manually from boot device selection at least from EFI file so as inconvenient that would be it would work.

Forum kindly sponsored by