Manjaro not starting. Can't find any solution and pinpoint exact reason!

I hear you. Maybe I'll do my homework with something more stable, and maybe one day I'll move to Manjaro / Arch if I feel like it :upside_down_face:

1 Like

You need to feel comfortable with reading manuals/wikis etc (have you heard of RTFM?), so it will not be a nightmare for you. It's just not fair!..

Stay close! :raised_hand_with_fingers_splayed:

Well... I haven't :grin:

I like solving problems, so for the harder the better but I guess if I don't have enough experience I shouldn't make my life living hell

Thank You very much for reply

1 Like

I'm going to make a wild assumption and suggest you reinstall but sudo pacman -Rncs kernel-alive on your first boot of the installed system. Then, update and install a new kernel and see if the issue persists.

@moso 2 things.

  1. Your efibootmgr does not have 'manjaro' as first boot. It has 'windows'
    To set 'manjaro as first boot.
    sudo efibootmgr -o 0002,0000

  2. It is still possible not to boot manjaro because of your 'acpi' issues
    But we can see if that boots to prompt. To boot to prompt,
    At grub menu, press 'e’
    Arrow down to linux line
    Arrow right past ‘quiet’ and 'splash’
    Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
    Add ‘3’ (without apostrophes meaning just 3)
    Press F10 or ‘ctl’ + ‘x’ to boot
    login with password to prompt.

If it boots to prompt, then your grub is not an issue and you just have to fix the acpi issue but I'm no good in it. Follow jonathon or other people's solution on this.
But I suggest you do the following first at prompt and then follow their instructions.
sudo pacman-mirrors -f 5
sudo pacman -Syyu

Should kernel-alive be installed by default?
Because it I get this:
sudo pacman -Rncs kernel-alive error: target not found: kernel-alive

I installed it and just rebooted the system without kernel change. On next bootup and shutdown I didn't see any acpi errors though, so I think it did something anyway. However after next reboot kernel-alive was gone once again.

I know since it didn't work I just switched to Windows as my primary.
But thank you on advice on how to do it from terminal!

I did that before (although in slightly different manner), so I also don't think it's the GRUB

although I'm not sure if I could run sudo pacman -Syyu with wi-fi because I don't have Ethernet port and I wasn't able to set up connection with router, but maybe I just haven't done it the wright way.


Okay, I agree too.

Okay, tough. As said, others have to come in here.
How's jonathon's idea?

Just look here :wink:

Now I'm waiting for his response

Ok, sorry. Missed seeing this also (on other topics as well).
Good luck. Hope you got this solved. Take care.

1 Like

Why would you install something I suggested you remove?

That's the exact opposite of the intended outcome.

As it is, if it's not installed by default then it's not a factor.

I'm sorry I misunderstood your directions :persevere:
I'm a bit hot-headed sometimes and English is not my mother tongue, so I hope you can forgive me this one time

But I assume that doesn't really help you in finding the solution, so if there is any more info I could provide to make it easier just tell me.

On the other hand changing kernel is not something I really need wright now so I can just ditch it

1 Like

I guess so.
Have you tried the initial advices about your UEFI boot problem?
See my first post (short answer) and gohlip suggestion Nr.1, to change boot order.

Well I think my UEFI setup has been working fine from the beginning.
From my initial post:

so Manjaro is showing in UEFI and as I said earlier here the boot order was changed because I wanted it to be, at the time.
I could always just start it manually from boot device selection at least from EFI file so as inconvenient that would be it would work.

out of interest what is your first language? the forum can be posted to in English, German, French, Brazilian, Polish, Russian, Spanish and Turkish. your last post made little sense but i'm guessing you mean consistency rather than incontinence which means manjaro cannot control it's bladder and leaks urine everywhere :wink:

1 Like

I wanted to say inconvenient, but I guess I didn't recheck my autocorrection :joy:
Thank you for pointing that out :wink:

Well it's Polish and I know I could post on Polish thread and to why I didn't the short answer would be the power of habit.

I use English as my main language on all of my devices.
I also just find it much faster and easier to lookup anything on the internet in English and I'd say Polish sites were hardly ever useful to me.
It's also that English speaking communities are just so much bigger.

This setting is in WinOS. You have to disable it.
Since you say you have correct boot order, Manjaro first, then post it, please.

efibootmgr -v
efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000,0002,9999
Boot0000* Windows Boot Manager  HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...t................
Boot0001* manjaro       HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot0002* Solid State Disk      PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-25-38-B3-71-B3-65-85)/HD(2,GPT,9a6ac096-cef1-458c-9c67-b06d9dc60477,0xfa000,0x32000)..BO
Boot9999* USB Drive (UEFI)      PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)..BO

Find how to disable fastboot and if it still fails, re-install grub with --recheck

I've just disabled fastboot and haven't seen any ACPI errors this time, so I guess that was causing them.
Should I repeat this command?

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

Forum kindly sponsored by