Manjaro not working properly after update [solved!]

Nobody can care more about your system than you ... :slight_smile:

Yes, the wifi connection was unstable. Probably didn't finish, I was distracted when I closed the laptop.

Yes I can enter the tty command prompt, but then what I can do?
The problem is that the network connection won't start, I cannot connect to internet.

I assume my responsability, but the connection was faulty and unstable anyway.

Hi, never use scratched install dvd's, bad install media or bad internet connections on updates.
You can try to reverse the latest updates from pacman.
https://wiki.manjaro.org/index.php?title=Pacman

find a network cable and maybe:

Option 1: Basic Resolution

To resolve this issue, first follow the basic procedure provided below. If this does not work, then there is a more comprehensive procedure available.


1. Download the package databases and update your system:

sudo pacman -Syyu

2. Clear out the software packages downloaded during the aborted installation by entering the command:

sudo pacman -Sc

3. Re-attempt the aborted download. 

Thanks LinuxFreak, but I cannot do that because my terminal is not working.

Thanks jonathon, I followed your instructions, I booted from a live usb and tried to update from there, but didn't work.

What didn't work?

1 Like

I got an error after trying to update via terminal: Pacman -Syyuu. I don't remember exactly, but was not possible to start the update process.

Then reboot into the live environment/chroot and get the actual error message so it can be fixed.

OK, I will do that again. Wait a moment...

OK, I reproduced my steps. Entered in live, opened the terminal, then:
manjaro-chroot -a (all went fine)
sudo pacman -Syyuu (output: pacman: error while loading shared librarie: libidn2.so.4: cannot open shared object file: No such file or directory

[notice: I have started in live Manjaro Xfce, and my broken installation is Manjaro Mate, if that matters]

Well thats not good. A bunch of stuff from systemd to curl rely on libidn2.

Looks like you werent the first though...

Which pretty much looks like after you chroot in make a symlink:
ln -s /usr/lib/libidn2.so.0.3.5 /usr/lib/libidn2.so.4
Then a full upgrade including downgrades to sync with server:
sudo pacman-mirrors -f && sudo pacman -Syyuu

Thanks cscs. I re-enter the system with a new usb live with Mate, and the error output is identical.

If the system cannot be repaired I will do a fresh install, but will take some time to customize it again, sadly.

???

Both that thread and my summary state it can be fixed. It also doesnt have anything to do with DE.

It should also be a reminder to keep yourself up to date and pay attention to warnings from the update process. In this case you would have been told that the versions were amiss. This also should have happened weeks ago if you were keeping up with the repos.

Go ahead and read the other thread - theres a handful of ways for you to repair.

Wait... I just digited ln -s /usr/lib/libidn2.so.0.3.5 /usr/lib/libidn2.so.4

and then

sudo pacman-mirrors -f && sudo pacman -Syyuu

the system is reacting...
Now is updating mirrors...
In some time I will tell you if it worked...

OK, mirror synchronization went fine. But pacman -Syyuu not:

:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: (repeat 4 times update: extra, community, multilib, and syncronize all databases)

Looks like you have to remove the lock first:
sudo rm /var/lib/pacman/db.lck

Thanks cscs! The system is updating now.
When finished I will tell you what happened...

Forum kindly sponsored by