Manjaro on Raspberry Pi 4: Cannot Boot To SSD Installation

Recently I purchased an ssd and a hard drive enclosure to use for my new Raspberry Pi 4. I was hoping to utilize the increased speed, storage, and reliability of an ssd with my pi.

I followed these instructions to get my pi to use the root installation on my ssd:

Unfortunately, when I power on both my ssd and Raspberry Pi I get kicked to an emergency shell with the error that "special device /dev/sda2 has not been found." Why is my pi not detecting the root partition on my ssd?

Here's a list of the hardware I bought:

  • Sabrent USB 3.0 to SATA External Hard Drive Lay-Flat Docking Station for 2.5 or 3.5in HDD, SSD [Support UASP] (EC-DFLT)
  • Samsung SSD 860 EVO 250GB 2.5 Inch SATA III Internal SSD (MZ-76E250B/AM)

Did you follow all the steps in:

The link you posted above is for booting from sdcard and and having the ssd for root. The link Strit pointed to is setting up Th new MSD boot where you do not have the sdcard inserted to boot off. Everything is done with the ssd.

It sounds like in your situation the ssd is not being seen at all by the pi4 and that needs to be addressed first. I would verify that the pi 4 can see the ssd by disconnecting the usb and on the sdcard boot partition change the cmdline.txt root= back to root=/dev/mmcblk0p2. Then boot up on the sdcard and go through the setup.

After rebooting on the sdcard plug in the ssd and verify that it has 2 partitions and you can get to both and browse the files.

I would also want to add that you did not give enough information on what you did there. Have you tried root=/dev/sda1 in cmdline.txt if you only have one partition on the ssd (root)?

Sabrent USB/SSD-Adapters are notorius for having Problems with the Pi (or Vice Versa).
Mine starts booting but then it goes slower and slower, same SSD on an Innatek-Adapter boots fine
In this old Guide is a workaround wich might help, but the Adapter still wont run at full Speed

There is also a list of known good/bad Adapters

1 Like

Lot of good info on that link.

I thought this Guide was commenly known.

BTW: Just did a rpi-update to see if there any changes in compatibilty, but now Manjaro wont boot anymore. The Screen just goes black.
Raspian still works though.

What do you mean by rpi-update? Not enough info given.

Are you booting off a ssd?
What packages upgraded?
Do you have a monitor config in config.txt like I have to have?
What branch did you upgrade on?

rpi-update as I said, the low-level bootloader AFAIK

Yes SSD via USB-Adapter, Innatek and Sabrent.
Packages were already fresh, System was running fine.
Branches are Unstable for Manjaro and Beta for Eeprom

what do you mean with Monitor config?

initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4


Strangly enough it wont boot on anther Pi too, so there must be something else wrong

I am guessing you mean rpi-eeprom-update then.

The pi4 will not get the edid info from my vizio monitor so I have to manually specify or I get a black screen although it will boot and I can ssh to it.

I updated the need files yesterday and flashed my new pi4 8G from the unstable branch and there was no issue here for MSD boot:

[ray@pi4 ~]$ pacman -Ss raspberrypi-boot
core/raspberrypi-bootloader 20200601-1 [installed]
    Bootloader files for Raspberry Pi
core/raspberrypi-bootloader-x 20200601-1 [installed]
    Bootloader with extra codecs for Raspberry Pi
[ray@pi4 ~]$ pacman -Ss rpi-eeprom
community/rpi-eeprom 2020.05.28-1 [installed]
    Raspberry Pi4 boot EEPROM updater
[ray@pi4 ~]$ sudo rpi-eeprom-update
BCM2711 detected
VL805 firmware in bootloader EEPROM
BOOTLOADER: up-to-date
CURRENT: Wed 27 May 2020 05:47:29 PM UTC (1590601649)
 LATEST: Wed 27 May 2020 05:47:29 PM UTC (1590601649)
 FW DIR: /lib/firmware/raspberrypi/bootloader/beta
VL805: up-to-date
CURRENT: 000137ad
 LATEST: 000137ad

[ray@pi4 ~]$ ls -lah /lib/firmware/raspberrypi/bootloader/beta
total 2.2M
drwxr-xr-x 2 root root 4.0K Jun 3 11:45 .
drwxr-xr-x 6 root root 4.0K Jun 3 11:45 ..
-rw-r--r-- 1 root root 512K May 29 20:11 pieeprom-2020-04-16.bin
-rw-r--r-- 1 root root 512K May 29 20:11 pieeprom-2020-05-15.bin
-rw-r--r-- 1 root root 512K May 29 20:11 pieeprom-2020-05-26.bin
-rw-r--r-- 1 root root 512K May 29 20:11 pieeprom-2020-05-27.bin
-rw-r--r-- 1 root root 96K May 29 20:11 recovery.bin
-rw-r--r-- 1 root root 97K May 29 20:11 vl805-000137ad.bin

No, rpi-update and rpi-eeprom-update are different things.
rpi-update was already in the older Raspis, the eeprom thing is only on the Raspi4


There is no rpi-update in the manjaro-arm repo and I have no clue with your issue.

One thought that comes to mind is since raspian boots maybe cp the *.dat *.elf and bootcode.bin from the raspian boot partition over and see if it boots. If not maybe the .dtb for your device as it may be tied all together. But make a back up of your boot partition first.

Yepp, just copying the dat and .elf-Files brought it back to life.
And you are right as the about the the rpi-update, altough I thought I saw in in the Repo.
Maybe I installed it by Hand once, since the System on the SSD is old. it already booted Manjaro via the old SD-Card-Trick a while ago. It is just for messing around a bit there is nothing serious on it, so there would be no harm in killing it.


Thanks for the Hint.
rpi-eeprom-update seemed to be a bit confused afterwards, but reinstalling bootloader etc via pacman as you mentioned in the MSD-thread made all OK.

But I think we are way of Topic now, I just wanted to test if this cursed Sabrent-Adapter now works (which it still doesnt) :wink:

I had to buy a BAD ADAPTER before READING THE LIST. UGH! I shot myself in the foot...

Edit: ok, does an ssd really bring a speed boost that's worth the hassle? Would I just be fine with the sd card, or should I really get on board with using an ssd only on the pi?

So I bought a new enclose just do native MSD booting, I thought I picked the StarTech one but I received from Sabrent. Even worse it is has a flashing blue light to show device activity. Now I know it has issues, but I forged ahead anyway. I did find it worked in the USB2 port and world fail on the USB3 port. I also had to add a BOOT_ORDER=0xf41 to my config.txt on the SD card and do a boot cycle before it would attempt MSD booting. I'm wondering if I enable quarks mode might it boot on on the USB3 ports. That might be tomorrows project.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by