Manjaro OPENBOX Polybar 3.3 Freezes

Hey guys~!
My OPENBOX polybar freezes frequently and I can't find the reason,
But when I run polybar -r openbox-bar, everything will go fine.
Help me ; )_

System:    Host: kaner-pc Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Openbox 3.6.1 
           info: tint2, polybar dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Portable System: Dell product: Inspiron N5110 v: N/A serial: <filter> Chassis: type: 8 serial: <filter> 
           Mobo: Dell model: 0FXK2Y v: A07 serial: <filter> BIOS: Dell v: A07 date: 07/18/2011 
CPU:       Topology: Dual Core model: Intel Core i5-2430M bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19167 
           Speed: 1637 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 995 2: 955 3: 978 4: 1016 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0116 
           Device-2: NVIDIA GF108M [GeForce GT 525M] vendor: Dell driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:0df5 
           Display: x11 server: X.Org 1.20.3 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: compton resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.3.2 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0bea 
           Sound Server: ALSA v: k4.19.16-1-MANJARO 
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
           bus ID: 05:00.0 chip ID: 10ec:8136 
           IF: enp5s0 state: down mac: <filter> 
           Device-2: Intel Centrino Wireless-N 1030 [Rainbow Peak] driver: iwlwifi v: kernel port: d000 bus ID: 09:00.0 
           chip ID: 8086:008a 
           IF: wlp9s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 6.35 GiB (1.4%) 
           ID-1: /dev/sda vendor: Toshiba model: MK5076GSX size: 465.76 GiB speed: 3.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 2D scheme: GPT 
Partition: ID-1: / size: 47.81 GiB used: 6.10 GiB (12.8%) fs: ext4 dev: /dev/sda3 
           ID-2: /boot size: 525.3 MiB used: 53.5 MiB (10.2%) fs: ext4 dev: /dev/sda2 
           ID-3: /home size: 401.17 GiB used: 202.3 MiB (0.0%) fs: ext4 dev: /dev/sda4 
           ID-4: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A gpu: nouveau temp: 60 C 
           Fan Speeds (RPM): cpu: 3766 
Info:      Processes: 190 Uptime: 51m Memory: 3.76 GiB used: 1.05 GiB (27.9%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: zsh v: 5.6.2 running in: termite inxi: 3.0.30

Read this and act accordingly:

1 Like

I can't reproduce your issue, hence i think you might have edited at least one of the following files:
line 12 sleep 1; manjaro-polybar-session &

line 8 ~/.config/polybar/config openbox-bar

As pointed above, please give more details about your setup/configs ...

Thank you for providing this info

My config file:

;     File Includes

include-file = $HOME/.config/polybar/master.conf
include-file = $HOME/.config/polybar/modules.conf

;     Openbox Bars

inherit = bar/master

; Use $ xrandr -q | grep " connected" | cut -d ' ' -f1
monitor = 
monitor-fallback = 

;tray-position = center
;tray-padding =
;tray-transparent = true
;tray-background = #0063ff

modules-left   = manjaro workspaces window_switch
modules-center =
modules-right  = battery pkg memory temperature coreuse clock

My master:

;     Colors & Settings

;The top and bottom triangles and logo: 304048
;The yellow stripe: gradient from bottom corner a07f00 to middle f0c100 to top corner c89f00
;The maia stripe: gradient from 0f6957 to 1ed2b0 to 16a085
;The two adapta stripes: gradient from 304048 in the corners to 62808e in the middle
;The adapta light blue stripe: gradient from 006a78 to 00bcd4
;The orange stripe: gradient from c85000 to ff6905
;I cannot give you an exact value for the light background,
; because there is a noise texture on the top of another layer (plus the grid),
;  so I could also only give you an approximate value based on colour picking,
;   but due to the noise, it varies based on where your picker is placed.
brightyellow = #f0c100
lightyellow = #c89f00
darkyellow = #a07f00
brightmaia = #1ed1b1
lightmaia = #16a085
darkmaia = #0f6957
verydarkmaia = #002b2b
lightblue = #62808e
darkblue = #304048
verydarkblue = #222D32
lightbrightblue = #00bcd4
darkbrightblue = #006a78
darkorange = #c85000
lightorange = #ff6905
white = #e0e2e3
transparent = #00808080
brownish = #525252
verydarkgreen = #104D50

active = ${theme.brightmaia}
foreground = ${theme.white}
;background = ${theme.verydarkgreen}
background = ${theme.verydarkmaia}
border = ${theme.transparent}
moderate = ${theme.lightyellow}
occupied = ${theme.brightyellow}
urgent = ${theme.lightorange}
trim = ${theme.lightblue}
blue = #8fa1b3
pink = #bf616a
orange = #ebcb8b
purple = #b48ead
yellow = #ebcb8b

throttle-output = 5
throttle-output-for = 10
throttle-input-for = 30
compositing-background = source
compositing-foreground = source
compositing-overline = source
compositing-underline = source
compositing-border = source
screenchange-reload = true
format-foreground = ${colors.foreground}
format-background = ${colors.background}

;    Master Bar

width = 99.5%
height = 36
border-size = 0
border-top-size = 0
border-bottom-size = 3
;radius-top = 15
radius = 5
bottom = false
line-size = 3
tray-maxsize = 20
font-0 = "DejaVu Sans Mono:size=12:antialias=false;2"
font-1 = "font\-logos:size=16:antialias=true;1"
font-2 = "MaterialIcons:size=12:antialias=false;2"
font-3 = "icomoon:size=12:antialias=false;2"
font-4 = "Ubuntu Nerd Font:size=12:antialias=false;2"
offset-x = 5
offset-y = 3
fixed-center = true
border-color = ${colors.border}
background = ${colors.background}
foreground = ${colors.foreground}
margin-bottom = 3
module-margin = 0
padding-right = 1
padding-left = 1
separator = │
scroll-up = pamixer -i 2
scroll-down = pamixer -d 2
;click-middle = skippy-xd --activate-window-picker
;double-click-left = networkmanager_dmenu
;double-click-middle = skippy-xd --activate-window-picker
;double-click-right = pavucontrol &

My modules:

;     Modules

## Uncomment for alsa module
#include-file = $HOME/.config/polybar/modules/alsa.conf
## Uncomment for battery module
include-file = $HOME/.config/polybar/modules/battery.conf
## Uncomment for clock module
include-file = $HOME/.config/polybar/modules/clock.conf
## Uncomment for compton toggle module
#include-file = $HOME/.config/polybar/modules/compton_toggle.conf
## Uncomment for cpu use module
include-file = $HOME/.config/polybar/modules/coreuse.conf
## Uncomment for custom menu module
#include-file = $HOME/.config/polybar/modules/custom_menu.conf
## Uncomment for ethernet status module
#include-file = $HOME/.config/polybar/modules/ethernet.conf
## Uncomment for filesystem inf module
#include-file = $HOME/.config/polybar/modules/filesystem.conf
## Uncomment for keyboard module
#include-file = $HOME/.config/polybar/modules/keyboard.conf
## Uncomment for jgmenu module (Manjaro)
include-file = $HOME/.config/polybar/modules/manjaro.conf
## Uncomment for memory module
include-file = $HOME/.config/polybar/modules/memory.conf
## Uncomment for media player daemon module
#include-file = $HOME/.config/polybar/modules/mpd.conf
## Uncomment for network status module
include-file = $HOME/.config/polybar/modules/network.conf
## Uncomment for update status module
include-file = $HOME/.config/polybar/modules/pkg.conf
## Uncomment for pulse audio module
#include-file = $HOME/.config/polybar/modules/pulseaudio.conf
## Uncomment for redshift module
#include-file = $HOME/.config/polybar/modules/redshift.conf
## Uncomment for CPU temperature module
include-file = $HOME/.config/polybar/modules/temperature.conf
## Uncomment for window switcher module
include-file = $HOME/.config/polybar/modules/window_switch.conf
## Uncomment for wireless network module
#include-file = $HOME/.config/polybar/modules/wireless.conf
## Uncomment for workspaces module
include-file = $HOME/.config/polybar/modules/workspaces.conf

Nothing edited by me

How about the files i mentioned, not other files that i didn't mentioned :slight_smile:

I just updated my manjaro, I can't find something about polybar in my autostart file,
another file you mentioned includes line:
sleep 1; manjaro-polybar-session &
with a # in first of the line

# Polybar base sessionfile
# DO NO edit this file, it will be overwritten by manjaro-polyzen
# Instead make a custom sessionfile and use the -z FILE or --session FILE option
# To load session at startup use the following line
# sleep 1; manjaro-polybar-session &

$HOME/.config/polybar/config openbox-bar

That does sound strange - I have been running this setup since the very beginning of Openbox edition - I have never seen the polybar freeze. But in the world of computer anything can happen :wink: so I believe you.

This is the reload command - it is issued when you have edited your configs - what kind of issue does it solve?

I mean - which function of polybar freezes? Is it the :manjaro: menu? What is it?

Have you tried launching with the -c argument?

$ pkill polybar
$ polybar -c /home/$USER/polybar/config

thank you for the reply,
the reload command will solve my problem,
in the default situation the whole polybar functions freezes suddenly till I reload it.
It seems config path is OK

I have no idea what you are referring to - and I have never heard of such issue the past years.

I think - you are facing another issue, but I have no idea what.

I will suggest you disable all active modules and slowly test where the freeze occur.


Have a look at the issues section at the source - it seems that at least one other have experienced something similar.

It seems I have a battery issue, the polybar tell it from shell,
I need to test
anyway thank you : )

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by