Manjaro-Optimus Indicator v3.0 - An Optimus-Switch GUI for multiple Desktop-Environments

Laptop is in Intel mode

[philippe@Probook-450 ~]$ glxinfo -B | grep "OpenGL vendor string"
OpenGL vendor string: Intel Open Source Technology Center
[philippe@Probook-450 ~]$ 

And I edit previous post also !

Okay so it is detecting your card okay.

It is not showing an icon?

Nothing!
It should be in the upper right corner right ?

@Lopasilver

Are you using the Kstatusnotifieritem/appindicator support extension?

https://extensions.gnome.org/extension/615/appindicator-support/

If not, it will not show the icon on the top bar or in the system tray of Dash to Panel.

Also check to make sure that the python-gobject package is installed.

sudo pacman -S python-gobject

Yes this is "KStatusNotifierItem/AppIndicator Support" extension that was missing! I Have the intel logo now and the menu to switch to Nvidia mode :partying_face:
I have disable extensions yesterday believing it was conflicting with your Optimus Indicator :confused: . I just enable this KStatus-thing extension in order to make it appeared. Anyway, this extension was never enable on my laptop, I think it needs to be mention somewhere.
Thank you very much for you help

Edit: switching GPU is working perfectly. Thank you for this useful fonction

2 Likes

Glad to hear that it is working. Enjoy!

Greetings to all. Version 1.1 of Manjaro-Optimus Indicator has been released. Existing users do not need to do anything. This was just a maintenance release to fix some minor issues with the readme. I also added a couple of icon sets to the "More Icons" folder.

Thank you to everyone for your feedback so far. I really do appreciate it.

1 Like

By the way, I just want to let you know the extension I use is coming from community repository and is called gnome-shell-extension-appindicator 29-1. Once installed one can see it as Kstatusnotifieritem/appindicator support.

[philippe@Probook-450 ~]$ sudo pacman -Ss gnome-shell-extension-appindicator*
[sudo] Mot de passe de philippe : 
community/gnome-shell-extension-appindicator 29-1 [installé]
    Integrates AppIndicators into GNOME Shell.

I've check your github update and notice you cite the gnome website. As far as I know by reading Manjaro forum, it is safer to stick to gnome extensions available via manjaro repo. So no need to go thru gnome website, everything is include already :sunglasses:

Greetings to all. Version 1.3 of Manjaro-Optimus Indicator has been released. Existing users do not need to do anything. No functionality has changed. This was just a maintenance release. I updated the format of the readme to look more professional, added beta LXQT support, changed the default icons (thanks @SGS) , and added some more icon sets to the "more-icons" folder.

The initial post will be updated with new screenshots and the information about LXQT shortly.

3 Likes

Greetings to all. Version 1.3.5 has been released. Existing users do not need to do anything. No functionality has changed.

This release adds an uninstall script.

Thank you all for your time.

3 Likes

I am just weeks into using Manjaro. I came from Mint (without dual-screen problems) and was only on it for 18 months or so. I was previously Windows user, so I know very little about Linux. So I really appreciate your being patient with me. I have tried many different approaches that I have found to get my dual screens to work and this looks like it has the best promises for me to get them back. I have not had dual screens to work at all on Manjaro. I really do not want to go back to Mint, but I am getting close to giving up. I have had so many back screens from making the wrong change, I have lost count. Thank God that Timeshift and that it works so good and so fast at restoring my computer. I am an expert on that! :joy: I would be fine with either intel or the nvidia driver. I just want dual screens. I don't need Nvidia for anything really. After attempting the Light DM installation instructions for the Switch, I did get get the icon in my panel, but when I click on either of the options, I get a "Error accessing /usr/local/bin/set-nvidia.sh: No such file or directory" or the set-intel.sh.

I would really appreciate any help that you can give. I am a good cut and paster! Please don't assume I know a lot, just enough to be dangerous.

Here are the results from inxi -Fxxxz
System:
Host: johnny-L702X Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 9.2.0 Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
Type: Portable System: Dell product: Dell System XPS L702X v: N/A
serial: Chassis: type: 8 v: 0.1 serial:
Mobo: Dell model: 0K4H3G v: FAB1 serial: UEFI [Legacy]: Dell
v: A19 date: 09/07/2012
Battery:
ID-1: BAT0 charge: 46.8 Wh condition: 46.8/73.3 Wh (64%) volts: 12.3/11.1
model: LGC Dell type: Li-ion serial: status: Full
CPU:
Topology: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP
arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19962
Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798
3: 798 4: 798
Graphics:
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126
Device-2: NVIDIA GF106M [GeForce GT 550M] driver: N/A bus ID: 01:00.0
chip ID: 10de:0dd6
Display: x11 server: X.Org 1.20.5 driver: intel unloaded: nvidia tty: N/A
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1b.0
chip ID: 8086:1c20
Sound Server: ALSA v: k5.2.21-1-MANJARO
Network:
Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0083
IF: wlp3s0 state: up mac:
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
bus ID: 3-1.1.4:6 chip ID: 0bda:8153 serial:
IF: enp0s29u1u1u4 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 4.55 TiB used: 74.94 GiB (1.6%)
ID-1: /dev/sda vendor: Western Digital model: WD5000BEKT-75KA9T0
size: 465.76 GiB speed: 3.0 Gb/s rotation: 7200 rpm serial:
rev: 1A01 scheme: MBR
ID-2: /dev/sdb vendor: Western Digital model: WD5000BEKT-75KA9T0
size: 465.76 GiB speed: 3.0 Gb/s rotation: 7200 rpm serial:
rev: 1A01 scheme: MBR
ID-3: /dev/sdc type: USB vendor: Western Digital
model: WD My Passport 25E2 size: 3.64 TiB serial: rev: 4005
scheme: GPT
Partition:
ID-1: / size: 220.40 GiB used: 74.93 GiB (34.0%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 15.89 GiB used: 9.7 MiB (0.1%) fs: swap dev: /dev/sda5
Sensors:
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 213 Uptime: 2h 29m Memory: 15.56 GiB used: 2.66 GiB (17.1%)
Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11
running in: xfce4-terminal inxi: 3.0.36

Did you install and configure optimus-switch?

1 Like

I thought I did... I have the icon in the panel and when I click on it, it gives me the two options. I have done so many things and then had to restore I am not not sure what state my system is at. I can't remember what broke when. I went back to go through the LightDM instructions and noticed that this is a problem, but I can't find nor understand how to do this instruction. "Note: output like this 00:02.0 VGA has to be formatted like this 0:2:0 in nvidia-xorg.conf for it to work properly." How do I do this format? I can't even find this file.

that indicator is not part of optimus switch, it's something @linesma made to work with optimus-switch and it works great but only if optimus-switch is actually installed and it's not.

your BusID's already match the defaults in the configurations so you dont need to edit them.

follow the directions top to bottom

1 Like

[quote="dglt, post:34, topic:105870"]
your BusID's already match the defaults in the configurations so you dont need to edit them.
[/quote] It doesn't match. Mine is 00:02:0 and not 0:2:0 like your instructions warn. Where/how do I find this file? I really appreciate your helping me dgit.

From the readme:

Note: output like this 00:02.0 VGA has to be formatted like this 0:2:0 in nvidia-xorg.conf for it to work properly.

As he said above, you will not have to edit any files. You can just use the default install.

1 Like

but they do match.

0:2:0 = intel
2:0:0 = nvidia

I'm sure I am missing something here, but this is what I get when I do inxi -Fxxxz (below). I see Intel bus ID: 00:02:0 and NVIDIA bus ID: 01:00.0. Am I looking in the wrong place? I really want to get this right because I just went through your procedure carefully again today and when I got though, it wouldn't finish booting. I ended up having to do another Timeshift restore. This is the only thing that I didn't follow exactly. I am really fried with this thing and will probably be my last ditch effort to use Manjaro.

Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0126
Device-2: NVIDIA GF106M [GeForce GT 550M] driver: N/A bus ID: 01:00.0
chip ID: 10de:0dd6

since this is not any issue related to @linesma 's optimus-switch indicator and this is not a support thread, i'm gonna PM you and try to get you up and running but im low on time so please just follow instructions

Version 2.0 is released. It now gives the user the option to switch their GPU and have their laptop reboot automatically.

Existing users who want that functionality will have to do a re-install.

To re-install:

  1. Delete the folder ~/manjaroptimus-appindicator

  2. Follow the readme to install.

1 Like

Forum kindly sponsored by