Manjaro Plasma Installation fails with bootloader issue

Hello forum,

I'm trying to speed up an old laptop with Manjaro instead of Windows 10, but I'm encountering an issue when installing. While I have a good amount of experience with consoles, BIOSes and system hacking stuff, I am pretty new to Linux itself. So don't hold back any advanced techniques to get this working because I'm desperate.

A couple infos about this setup:

The laptop is some form of a Medion Akoya with an SSD and an HDD. I want to dual-boot Windows 10 and Manjaro for software purposes, but have formatted the drive that ran Windows trying to fix this issue.
When installing Manjaro on any of the drives, it progresses until about 70 % progress and then throws this error:

Screenshot_20200227_115013

A friend of mine says I should try to run the installer in BIOS mode, but there doesn't seem to be any option like that.

The BIOS is EXTREMELY limited in its' options. Secure Boot is turned off and Secure Boot Mode set to Standard. Fast Boot is disabled, and the USB stick I'm booting from is the only option. I want to make clear that there are no other settings in the BIOS.

Manjaro runs from a USB 2.0 Stick and has been installed using Rufus. Using a 3.0 Port does not make a difference, and neither does what partition mode I use. The SSD has been formatted multiple times using the installer.
I have yet to try the installer on another old laptop to confirm it's a device specific issue, but will update this thread once that's done. Right now I can't think of any other important information, but will supply anything if needed.

Please let me know if you know any ways to fix this or if the laptop is just a piece of garbage.

Thanks to everyone for taking the time to read this wall of text and any helpful responses.

Boot into the bios and look for a setting called 'CSM' and disable it (it'll probably be under boot options somewhere), you need to be pure UEFI for the installer to work.

If you want to install in bios/legacy mode instead you need to boot the installer in bios legacy mode, there should be two partitions you can boot from on the Manjaro usb, the one you just tried to install is EFI mode, the other will be BIOS.

Disabling CSM and installing in UEFI mode would be the preferred option.

If that doesn't work (but it should) try burning the iso again using etcher instead and make sure you've verified the checksum (check on the Manjaro download page for details).

There is no option for CSM anywhere in the BIOS. The only mention of CSM is on the explanation of Secure Boot Mode. See the Boot menu below:

IMG_20200227_114304

When you say there should be two partitions on the USB, does that mean there should be two boot options showing up in the BIOS? As you can see there is only a UEFI option.

I will go and try to burn the ISO using etcher and will report back.

Can secure boot mode be changed from CSM to UEFI? If so do that.

Your laptop will (probably) have a boot menu that's separate from the bios settings, you'll have to check the laptops documentation to find out what the keyboard shortcut is to bring it up. On my board I just have to smash F11 when I first turn it on but it varies from model to model.

Edit: You might also see if there's a more up to date bios available for your model, 2013 was a while ago...

Secure Boot Mode only has the options "Standard" and "Custom".

Would the boot menu be the one where I can directly choose the boot medium? I've found the key but it also doesn't show a second boot option on the stick (apart from the UEFI one).

God, a BIOS update for this laptop? I wouldn't even know how to search for and install that given I have no Mainboard, Laptop Model or Windows access. But you're right, that might also be a way to go.

What does custom entail?

Can't help you with that one, but if you run inxi -Fxxxza from the live usb it'll print off some more detailed hardware info for you that might help you track down the exact model

Yes, there's usually two options on the USB, they might not be labelled as such but one is for bios and the other is UEFI. On the installer screen it should say in the top left of the window if the install mode is efi or bios/legacy.

It allows me to set Custom Keys, but I've never seen that option and don't really know what it does.

IMG_20200227_121127

I've found the Laptop model as well as a BIOS update, but still have to figure out if I can install it without installing Windows first. All I have is a .exe that should be run on the laptop and I'm not sure if I could extract & burn it to the USB.

Weirdly enough there aren't for me. All I see is the UEFI option in the boot screen. The Manjaro installer shows the install mode as EFI.

Etcher has since finished burning the ISO (with this error message attached), so I'll try installing Manjaro on the laptop again just to be sure.

\\. \PhysicalDrive14: Source and destination checksums do not match: aa545ee882fcc31a !== 7ed9d042233f975

If that fails I might install Windows, update the BIOS and then explore if there are any new settings that might help.

EDIT: Installation has failed again. I'm installing Windows to update the BIOS.

Could be a limitation of the bios then, updating it may create more options. Otherwise the alternative is to disable UEFI and install in bios legacy. If UEFI is disabled in the bios the installer should automatically boot to bios mode.

Did you verify the checksum manually? A bad iso could also cause errors like this. Make sure verify it and then try another iso (ie if you've just tried KDE try xfce and see if it spits the same error).

If you're planning on dual booting it's easier to have Windows installed first anyway, just keep in mind that if you install Windows in UEFI you'll have to do the same for Manjaro. If you install Windows in UEFI and then find that Manjaro still won't install in UEFI you'll have no choice but to reinstall Windows again in bios mode and then do the same for Manjaro.

Before that, as we now know that the installer is booting in EFI mode, you could try creating your partitions before running the installer. That iso should come with KDE partition editor. Create a new GPT partition table, then a 500mb FAT32 partition for EFI, and then create ext4 partitions for / and /home according to your preferences and finally a partition for swap if you want one. Then run the installer and direct it to use the partitions you've created.

Until some new information comes to light that's all I've got, report back with what you've tried and the results.

Best of luck.

After installing windows and the BIOS update the only change is a new setting called "Shipment Mode" that probably has nothing to do with this issue. Nothing related to boot options has changed.
I've also flashed the XFCE-iso to the USB as well as verified the SHA1, and the same issue still arises. When booting from the USB there is only the UEFI-option.

I don't know how I would achieve that as there is no setting to disable UEFI, at least not in the BIOS.

I didn't see an option to choose between the two modes, it just installed. Would you know how to do that?

Right now I don't know what else to try and I might have lost my drive for today. Might pick it up if there's new ideas though!

@rainerzufahl Your BIOS seems to be identical to mine. I ran into exactly the same problem, the same error, the first time I tried installing Manjaro about a year ago.
Solved it by doing the following which may or may not work in your hardware.
Downloaded ISO, checked sha256sum, used etcher and after failing with that used dd command, wrote to USB, disabled secure boot and CSM, booted USB in UEFI, did GPT+UEFI install with 500 MB /boot/efi partition.
Didn't get the error. Hope this helps. Good luck.

1 Like

So, there are some updates. Just so I knew I had tried everything I installed the Xfce-ISO on my HDD (instead of the SDD as before), and for some reason now it worked. But apparently the SSD installation was completely finished up until the bootloader, so GRUB now shows 2 Manjaro Installations as well as Windows. Also, from my first looks I prefer KDE over Xfce, which is why I now need to do two things:

  1. Uninstall the Xfce located on the HDD
  2. Install KDE over the Xfce located on the SSD

But I'm not sure how to find out which installation is located where. Can I just delete the Manjaro partition on my HDD to get rid of it? And then install KDE in the same partition the other Xfce is now located in? Or might that overwrite the GRUB and I'd be back to the beginning?

Update 1: I have now re-flashed the KDE using Etcher on my USB (which for the first time did not throw a mismatch error). Because I really don't care for the laptop I'm installing the KDE over the partition on the SSD, just to see what happens.

Installing over it is fine. Weird that it works on one disk but not the other. Double check in the bios and make sure that ACPI is enabled. (not raid or any other option available).

If the previous install was successful except for the bootloader you should be able to salvage it by booting from the grub command line on the live cd and reinstalling grub. Take a look here

While I'm not sure it's the perfect progress, I'm definitely making some. The fact that the installation now consistently fails on the SSD but works on the HDD puzzles me, but I won't complain.

I've deleted the Manjaro-partition on the SSD and installed KDE on the HDD, which resulted in the setup I wanted. I'll have to figure out why I can't resize the partition holding windows anymore but that's an issue for another day.

Well, I guess this problem kind of solved itself. Thanks to you two for all the help!

You could always try to clone it, for science.

Also for science; post output of inxi -Fxxxza

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by