Manjaro shuts down directly after starting

OS: Manjaro Cinnamon, Kernel 5.2.11-1
GPU: AMD Radeon R9 270x
CPU: Intel(R) Core(TM) i5-3550 CPU @ 3.30GHz
Dual booted with LinuxMint 19.2, Kernel 4.15.0-70-generic

I tried to install DaVinci Resolve. First with the official linux file provided on the makers webpage - didn't start. Second with the AUR package. It didn't start up either. So I went into the terminal and looked for some error. It lacked stuff. First I installed Qt4. After that it said it needed "libcudart.so.10.0". After a bit of research I found "Cuda" and "Cuda-10.0". I installed the first one which brought no solution and cancelled the installation of the second one (both from AUR). Regarding DaVinci Resolve nothing changed. Steam on the other hand only showed black fields. No more shop, no more library.

I restarted the PC and got "end kernel panic - not syncing: vfs: unable to mount root fs on unknown-block(0,0)" as message. I tried to fix this problem by

  • installing grub with "Boot Repair"
  • rescuing the MBR with "Boot Repair"
  • starting different kernel versions with "Super Grub 2" as well as the advanced settings in Grub
  • using a Timeshift Snapshot through chroot in a live-usb-version
  • changing the "Hooks" in grub.config (or something)
  • remounting the partition
  • editing the boot commands from the Grub by pressing "E" on the relevant mark

By trying to fix the problem the messages I got when booting changed a bit. The outcome didn't. Manjaro doesn't boot. Some different kernels don't crash immediately but show a black screen with a small white line in the top left corner for ages.

When booting Manjaro regularly it shows me the message
"early console in decompress_kernel
Decompressing Linux... Parsing ELF..._" for maybe 0.25 seconds before it automatically restarts the PC.

Hoping for Cuda to bring some necessary libraries with it was a bad decision.
I'm greatful for any tips.

what is suggested in Manjaro forum??
You are on kernel 5.2 which is discontinued. You may have probably updated/installed some package, without doing a full system update.
Just guessing...

Use a Live Manjaro ISO to boot and chroot to your system, in order to do a proper system update.
After that, report again any issues.

Was already done. I have 4 different Kernels installed. A newer one was somehow not the live kernel.

Have you booted fine?
Was the tutorial any useful?
Can you report any info about your system configuration?

Thanks for prividing me the link! In the end it saved me. May God bless you!

I have trouble understanding the behaviour of the system regarding the kernel though.
kernel
I installed kernel 5.2.21_rt13-2 after I read that Kernel 5.2.11-1 lost its support (I think on kernel.org).
On the picture it says "installed" and "real time" at kernel rt13 (which stands for real-time as well I guess?).
But why is it not the active kernel? Do I need to uninstall 5.2.11-1 first? I was afraid to do so since I feared my system breaking down.

1 Like

You shouldnt be using either version of 5.2. (active kernel is just whatever one you booted into)
And .. do you have a reason for 'real-time' ? Its usually only used by audio engineers and the like.

I thought "real-time" meant the latest kernel which is not experimental. When I upgraded to my kernel which is now active, it was automatically chosen by Manjaro to be the new regular kernel. This is the regular kernel I boot into when making no modifications. I don't want to go back to kernel version 4 because my Mint runs on this kernel and it doesn't recognize my gpu at all.

Whats wrong with 5.3 ? it is available and is the actual 'latest stable' kernel. Not to mention it isnt EOL.

It seems you haven't applied the recent updates:

linux419   4.19.81-1     4.19.84-1

Re-Boot to kernel 4.19 (select from grub menu) before applying updates.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by