Manjaro slow boot/Desktop manager hang with Windows SSD connected

Hi to all

Moved to Manajro from Ubuntu. But had issues with installation. I have Windows 10 installed on separate SSD and tried to install Manajaro on other SSD. Once started calamares for installation it hanged on waiting 2 modules. Looking through internet, found that can be issue with Windows drives, so I disconnected Windows SSD and Manjaro installation was successful. After first boot, I decided to connect back Windows drive and configure GRUB for dual-boot, but was surprised that boot process is slower than without Windows drive and also after loading Desktop Manager, not all desktop elements are loaded...Once Win drive disconnected, everything boot up without any issues. I can't even configure GRUB to enable dual-boot, because once I start update grub in terminal it's detecting Manjaro kernels and ..... nothing else, no even errors, it's even does not finish grub update process. Even os-prober does not finish the job, just waiting....
The issue is only with Windows system drive. I also have other NTFS drives connected and Manjaro is working with them without issue (mounting, reading...). I can't even check anything with Partition Manager, because it's hanging if Win system drive is connected....
Also in system manager 3 Cores out of 4 of CPU are always 100% in use...
Does anybody had such issues? Any ideas about that?
Thank you

1 Like

:+1: Welcome to Manjaro! :+1:

You probably have NTFS / partition errors on that drive and the Linux NTFS-3G driver has trouble reading these. Repair all the drives under Windows and run Windows SMART health check on that SSD.

As this is a Windows issue and this is the Manjaro Forum, we'll be unable to help you any further if you would not know how to do that under Windows.

Sorry!

:sob:

Hi
Thx for your reply, but I'm not quite agree with you....
As I wrote, I moved from Ubuntu to Manjaro, and I did not hove such issues on Ubuntu.
Also after your reply, I reinstalled Windows on that SSD drive with complete format of system drive. I made some test of the drive after I installed fresh Windows. No errors or problems detected with that SSD, but Manjaro still is booting slowly, 2-3 cores of CPU are always with 100% load and restart or shut down is also veeery long.

Please give us some tangible data so we can see what's going on:

inxi --full --verbosity=7 --filter --no-host
ps aux | sort --numeric-sort --reverse --key=3,3 | head --lines=10
free --human

:innocent:

Best to ditch Windows and refrain from dual booting. Windows causes no end of problems when you try to make it coexist with Linux.

1 Like

hello
here:

[alex@alex-manjaro-PC ~]$ inxi --full --verbosity=7 --filter --no-host
System:
  Kernel: 5.4.38-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: KDE Plasma 5.18.5 tk: Qt 5.14.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z77P-D3 v: x.x serial: <filter> 
  UEFI: American Megatrends v: F7 date: 08/24/2012 
Memory:
  RAM: total: 7.74 GiB used: 2.00 GiB (25.8%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i5-3570 bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB bogomips: 27234 
  Speed: 3628 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 3608 
  2: 3619 3: 3620 4: 3619 
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb 
  ept erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs 
  ida lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl 
  nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 
  pti pts rdrand rdtscp rep_good sep smep smx ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme 
  vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
Graphics:
  Device-1: NVIDIA GK106 [GeForce GTX 650 Ti] vendor: ASUSTeK 
  driver: nvidia v: 440.82 bus ID: 01:00.0 chip ID: 10de:11c6 
  Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 650 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 
  Device-2: NVIDIA GK106 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0e0b 
  Sound Server: ALSA v: k5.4.38-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 4.77 TiB used: 59.47 GiB (1.2%) 
  ID-1: /dev/sda model: SSDPR-CX400-128 size: 119.24 GiB speed: 6.0 Gb/s 
  serial: <filter> rev: 61.3 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EADX-00TDHB0 
  size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 4D77 scheme: GPT 
  ID-3: /dev/sdc vendor: Kingston model: SV300S37A120G size: 111.79 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: BBF0 scheme: GPT 
  ID-4: /dev/sdd vendor: Western Digital model: WD10EALX-759BA1 
  size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> rev: 1H19 scheme: MBR 
  ID-5: /dev/sde vendor: Western Digital model: WD30EFRX-68EUZN0 
  size: 2.73 TiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 0A82 scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / size: 39.12 GiB used: 9.62 GiB (24.6%) fs: ext4 dev: /dev/sdc2 
  label: N/A uuid: cd468c26-adc7-4066-8743-db58a5e9e0b8 
  ID-2: /boot/efi size: 511.0 MiB used: 320 KiB (0.1%) fs: vfat 
  dev: /dev/sdc1 label: N/A uuid: 4C79-978A 
  ID-3: /data size: 908.01 GiB used: 48.47 GiB (5.3%) fs: ext4 
  dev: /dev/sdb2 label: N/A uuid: 48ef6ef0-0895-44ba-9b7a-ca6f53cbbc75 
  ID-4: /home size: 69.67 GiB used: 1.39 GiB (2.0%) fs: ext4 
  dev: /dev/sdc3 label: N/A uuid: c746198c-c38f-4a07-8c4c-4cb63ce7cf6a 
  ID-5: /var/lib/snapd/snap/core/9066 raw size: 93.9 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop1 label: N/A uuid: N/A 
  ID-6: /var/lib/snapd/snap/plexmediaserver/77 raw size: 105.1 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop2 label: N/A uuid: N/A 
  ID-7: /var/lib/snapd/snap/plexmediaserver/81 raw size: 105.3 MiB 
  size: <root required> used: <root required> fs: squashfs 
  dev: /dev/loop0 label: N/A uuid: N/A 
  ID-8: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb1 
  label: N/A uuid: 4f22057f-7a93-406c-8cfd-4221808512c5 
Unmounted:
  ID-1: /dev/sda1 size: 579.0 MiB fs: ntfs label: System Reserved 
  uuid: FA1853131852CE6F 
  ID-2: /dev/sda2 size: 118.67 GiB fs: ntfs label: N/A 
  uuid: 16E45384E45364D1 
  ID-3: /dev/sdd1 size: 931.51 GiB fs: ntfs label: WD Blue 
  uuid: AC405E08405DDA22 
  ID-4: /dev/sde1 size: 128.0 MiB fs: <root required> label: N/A 
  uuid: N/A 
  ID-5: /dev/sde2 size: 2.73 TiB fs: ntfs label: WD Green 
  uuid: FC289C9D289C588A 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 
  Device-1: 1-1.3:3 info: Dell type: Mouse driver: hid-generic,usbhid 
  interfaces: 1 rev: 2.0 speed: 1.5 Mb/s chip ID: 413c:301a 
  Device-2: 1-1.4:4 info: Dell Keyboard type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s 
  chip ID: 413c:2003 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 
  speed: 5 Gb/s chip ID: 1d6b:0003 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 4-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0024 
  Device-3: 4-1.6:3 
  info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 0a12:0001 
Sensors:
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: nvidia temp: 44 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 10% 
Info:
  Processes: 228 Uptime: 2m Init: systemd v: 244 Compilers: gcc: 9.3.0 
  Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37 
[alex@alex-manjaro-PC ~]$ ps aux | sort --numeric-sort --reverse --key=3,3 | head --lines=10
alex        1907 37.6  2.1 4804100 178220 ?      Rl   11:52   0:01 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=11 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1601 37.0  3.1 882028 251640 ?       Sl   11:51   0:06 /usr/lib/chromium/chromium --ppapi-flash-version=32.0.0.363 --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so
alex        1834 34.7  2.3 4790436 189980 ?      Sl   11:52   0:02 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=22 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1871 31.8  2.0 4775732 164492 ?      Sl   11:52   0:01 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=12 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1684 31.2  2.9 9054212 237404 ?      Sl   11:51   0:04 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=17 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1839 30.7  2.2 8984976 185136 ?      Sl   11:52   0:02 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=14 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1703 19.8  2.1 4749664 172916 ?      Sl   11:51   0:02 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --extension-process --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=5 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1624 13.8  3.5 667244 290168 ?       Sl   11:51   0:02 /usr/lib/chromium/chromium --type=gpu-process --field-trial-handle=6204385453938933463,6383877555063037599,131072 --gpu-preferences=MAAAAAAAAAAgAAAAAAAAAAAAAAAAAAAAAABgAAAAAAAQAAAAAAAAAAAAAAAAAAAACAAAAAAAAAA= --shared-files
alex        1741 13.4  1.5 25711000 129352 ?     Sl   11:51   0:02 /usr/lib/chromium/chromium --type=renderer --disable-webrtc-apm-in-audio-service --field-trial-handle=6204385453938933463,6383877555063037599,131072 --lang=en-US --extension-process --disable-client-side-phishing-detection --enable-auto-reload --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=32.0.0.363 --num-raster-threads=2 --enable-main-frame-before-activation --renderer-client-id=7 --no-v8-untrusted-code-mitigations --shared-files=v8_snapshot_data:100
alex        1274  9.0  2.5 3004756 209560 ?      Sl   11:50   0:06 /usr/bin/kwin_x11 -session 1012518a17b155000158852446300000010640005_1589014151_334611
[alex@alex-manjaro-PC ~]$ free --human
              total        used        free      shared  buff/cache   available
Mem:          7.7Gi       2.2Gi       4.2Gi       223Mi       1.3Gi       5.1Gi
Swap:         8.0Gi          0B       8.0Gi

Are both systems installed in UEFI mode on gpt parted disks?
Are Secure boot and Fastboot disabled in firmware/Windows?

It's important to really shutdown Windows completely and not to end up in a kind of hibernation mode as this could lock the Windows SSD drive for Manjaro during boot.

Also, please provide the info @Fabby asked for.

1 Like

Hi
Windows-MBR
Manjaro-GPT
Secured and fastboot disabled
No hibernation enabled for Windows. Shut down completely before run Manjaro

That's the reason Manjaro doesn't find it!

Both systems must be installed in the same mode to boot Windows via grub boot menu.

1 Like

Always 2-3 cores of CPU are 100% load, without Windows SSD connected, no such issues
Screenshot_20200509_120120

hi
if I try to fix GRUB from Manjaro and to add Windows boot record there, it's does not finish update job, just nothing is doing, ctrl+c stop the process and nothing happens.

What everyone already said: use the same system for both OSes...

On top of that:

  • Cold boot between Windows and Manjaro
  • ditch Chromium: it's taking up a tremendous amount of CPU and RAM: Firefox might not be the largest one in market share any more, but it's still the best (fastest, lowest CPU/RAM usage) browser out there!

:innocent:

1 Like

hi again
After a lot of manipulations, I succeed to make it work.
Windows drive converted to GPT like Manjaro drive.
Fresh installation of Windows, after that fresh installation of Manjaro and pointed boot-loader to be installed to Windows drive and it worked.
Manjaro is not hanging anymore with Windows drive connected.
Thanks to everybody for your suggestions.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by