Manjaro-specific packages which need an update

Aaaalright ...
Will it help if you put this content in a file
/usr/share/polkit-1/actions/com.github.project-sx.tlpui.policy ?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
"-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"


 <action id="com.github.project-sx/">
    <description>Run TLPUI</description>
    <message>Authentication is required to run TLPUI</message>
    <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/tlp_ui</annotate>
    <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>

Yepp. That works :+1:

Ahh, no, sorry, I had already modified the link with "gksudo tlpui".
Still doesn't work

hrrmm (post must be at least 5 characters) :wink:

sorry, made a mistake when testing. still does not seem to work with the polkit file

It shouldn't need to be started with sudo. Privileges are only required when clicking the Complete button.

@jonathon Maybe this tlpui stuff should be split into a separate topic?

Hmm, just checked. You are right.

For some reason my /etc/default/tlp file was set to rw for root only.

instead of

Normally it should be readable by everyone I guess (as the other files in that dir) ? If I do chmod +x tlp, it works fine indeed. (a pop up will appear when saving, which is fine...)

ok, now I see what is going on. Just checked on a VM: With the old version of tlpui (r89) , when you save settings it sets the permissions in a wrong way.

2 posts were split to a new topic: Architect has a BTRFS mount option for recovery that is deprecated

It seems it might be necessary to revert the patch to steam-manjaro.

See this post: steam-manjaro package and last week's patch that broke font rendering and the links it contains.

I tried to summarise the problem in my reply.

The arch discussion is mainly above my head and it seems that they have not yet decided on a solution.

Valve will not be addressing the issue until at least the next beta cycle so any possible change from there is weeks(?) away - if it comes at all.


I can't replicate ms office works fine on my end.

Do you suggest? remove the patch and add the aur workaround as possible solution?

Remove that patch, yes. Although it fixes the black screen problem it causes another with font rendering of specifically Valve developed games. :expressionless: This can easily be worked around by not using steam-native (or STEAM_RUNTIME=1 with it installed) but we should not introduce one bug to fix another.

If it is the most recent AUR workaround you mean, this one - then I can confirm that it currently works (with the minor change of exec steam-native to exec steam in line 10 of 'steam-native-webhelper'). However I don't think that it is a good distro-level solution as it may cause trouble later:

Comment by Maarten de Vries (de-vri-es) - Friday, 19 April 2019, 16:35 GMT It's not hard to adjust the file automatically to have a new checksum. However, the big question is if we should do that when the checksum changes, since then apparently the original script changed. So whatever is bundled with steam-native-runtime might not match upstream anymore.

A straightforward solution that works until the upstream script changes:

  1. Check if the script in the user home folder has the expected checksum. If not, abort and hope for the best.
  2. If it did match, overwrite it with a fixed version that delegates to /usr/lib/steam/, which isn't checked by steam. The last script I uploaded does this.

I'm not sure we want to deal with it if 'hope for the best' fails. (The client updates frequently - several times a week - at least on the 'publicbeta' branch that I am on and that is, I think, the default for Manjaro.) How often this particular script gets updated I have no idea but when it does it will be outside of our control.

If on the other hand you mean the earlier AUR package - I can't recommend that since it pulls in libselinux.

Sorry if it is not helpful but my recommendation would be to leave the black screen issue unaddressed.

1 Like

Those requests are based from what is available in Unstable currently in my mirror. Sorry in advance if it has already been updated.



  • libcpuid: Upstream is at 0.4.1 (i-nex may need to be rebuilt) (this + i-nex could be dropped if you need to reduce your workload);
  • gimp-gtk3: Build date for current is Nov 24th, 2018. (Honestly, if there is no refresh planned for it, just remove it from repos.)
  • chromium-chromevox: Last packaged Sept 10th, 2013. Phew, more than 5 years old! Does it still even work with the current version of Chromium?
  • pamac-classic: Out-of-date upstream is at 6.7.0 1) and the project is dead. Even if there won’t be a new version anytime soon, Team must keep an eye on it in case it ceases to work. (Could be removed to reduce your workload.)
  • pamac-dev and pamac-dev-tray-appindicator: Out-of-date and not adapted to the new way Pamac is packaged nowadays. (Should be removed IMO.)
  • amarok: Has not been refreshed for months (Build date: Nov 24th, 2018). No idea if it still works with current QT. (Confirmed to be still usable with current environment, and still is ahead of upstream official releases.)

New requests


  • amdvlk: A new version (2.85.[…]) available on the source the build file is based on. (Not an important release.)
  • snapd: Upstream is at 2.38.1. We have 2.38. (Not an important release, and AUR is still at 2.38 for comparison.)


  • gnome-terminal-fedora: Gnome Terminal 3.32.1 is currently available. We have 3.32.0.

Our package is still newer than their latest release! :wink:

I just installed 200+ MB of dependencies to check on Cinnamon :wink: . So at least it opens ... and I guess if it would be broken in any way, people would have reported.

2.84.0421.g1dd300a is built against so it's the most recent release, it just has a different version number than the spec file.

There are no release assets for 2.38.1, . "Official" AUR package is still at 2.38.

Thanks for your answers and sorry for the bother then. :slightly_smiling_face:

It's all good looking out. :wink:

backintime is now at version 1.2.0.

2 posts were merged into an existing topic: Non-Manjaro packages which have been flagged as needing an update

The package command-not-found needs a rebuild because cnf-lookup is linked against libboost 1.68.0 but 1.69.0 is current.

cnf-lookup: error while loading shared libraries: cannot open shared object file: No such file or directory
1 Like

Rebuilt package is now in unstable.


Forum kindly sponsored by