Manjaro-specific packages which need an update

3 posts were merged into an existing topic: Non-Manjaro packages which have been flagged as needing an update

Those requests are based from what is available in Testing currently in my mirror. Sorry in advance if it has already been updated.



  • libcpuid: Upstream is at 0.4.1 (i-nex may need to be rebuilt) (this + i-nex could be dropped if you need to reduce your workload). (Updated in Unstable)
  • gimp-gtk3: Build date for current is Nov 24th, 2018. (Honestly, if there is no refresh planned for it, just remove it from repos.) (Got removed from repos.)
  • chromium-chromevox: Last packaged Sept 10th, 2013. Phew, more than 5 years old! Does it still even work with the current version of Chromium? (Got removed from repos.)
  • pamac-classic: Out-of-date upstream is at 6.7.0 1) and the project is dead. Even if there won’t be a new version anytime soon, Team must keep an eye on it in case it ceases to work. (Could be removed to reduce your workload.) (Got removed from repos.)
  • pamac-dev and pamac-dev-tray-appindicator: Out-of-date and not adapted to the new way Pamac is packaged nowadays. (Should be removed IMO.) (Got removed from repos.)

New requests


  • snapd: Version 2.39 is currently available. We have 2.38. I now compare with AUR instead of upstream. (Up to date in Testing.)


  • gnome-terminal-fedora: Gnome Terminal 3.32.2 is currently available. We have 3.32.1. (Up to date in Testing.)
  • gnome-shell-extension-unite: Version 30 available from upstream. We have version 27. (Up to date in Testing.)
  • gnome-shell-extension-appindicator: Version 29 available from upstream. We have version 23.1. (Up to date in Testing.)
  • gnome-shell-extension-openweather: The Github page has been archived, the URL provided in the package needs to be updated. ; Also, I see that the last commit is 5 months old, does this extension still work on Gnome 3.32? (In testing, Got updated, rebuilt and the link changed too.)
  • gnome-shell-extension-desktop-icons: Version 19.01.3 available from upstream, we currently have version 19.01.1. (Up to date in Testing)


  • deepin-file-manager-nomodule: Deepin File Manager 4.8.4 is currently available. We have 4.8.3. (Up to date in Testing.)

EDIT: Striked requests that got handled by the team. Thanks.


Built and in unstable and x32-*.

1 Like

Thanks, seems I have missed that! :wink:

1 Like

@Frog , thank you, all done in unstable :slight_smile:

1 Like

@Frog thanks for the infos, Reminder is (at last) also done

1 Like
[Testing Update] 2019-05-13 - Linux52, KDE Apps, Haskell, Gnome Extensions
[Testing Update] 2019-05-15 - Deepin, Mesa, Linux316, XFCE
[Testing Update] 2019-06-20 - Kernels, KDE Plasma, Browsers, Mesa, Qt5
[Testing Update] 2019-06-24 - Kernels, KDE Plasma, Texlive, Haskell, Python
[Testing Update] 2019-06-27 - Kernels, XFCE, Mesa, Plasma5, Systemd, Cinnamon, XFCE
[Testing Update] 2019-06-28 - Apparmor, Kodi, Pamac, XFCE
[Testing Update] 2019-06-30 - Systemd, Pamac 8.0, AMDVLK, XFCE, KDE-Git, Octopi
[Stable Update] 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT
[Testing Update] 2019-07-07 - Qt5, Browsers, Upstream rebuilds
[Stable Update] 2019-07-09 - Qt5, Cinnamon, XFCE, Deepin, Palemoon, Firefox
[Testing Update] 2019-06-17 - Kernels, KDE Plasma, Browsers, XFCE, Deepin, Nvidia, Haskell, Perl
[Stable Update] 2019-05-26 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice
[Testing Update] 2019-05-22 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice
[Stable Update] 2019-05-17 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd
[Testing Update] 2019-05-29 - Kernels, XFCE, Deepin, Mesa, Nvidia, KDE-Dev
[Testing Update] 2019-05-30 - Octopi, Deepin, ff-dev, XFCE, Haskell, Pre-ISOs
[Testing Update] 2019-06-01 - Kernels, Xorg-Server, FF-Dev, Haskell, Python
[Testing Update] 2019-06-02 - ZFS, Deepin, KDE-Git, Haskell, Python
[Testing Update] 2019-06-06 - Kernels, Browsers, Octopi, Calamares, Python, Deepin
[Testing Update] 2019-06-08 - KDE-Git, Browsers, KDE Apps, Mesa, Haskell, Python
[Testing Update] 2019-06-09 - Matcha, i-nex drop, pamac-qt
[Testing Update] 2019-06-10 - Kernels, KDE Frameworks, KDE-Git
[Stable Update] 2019-06-11 - Kernels, KDE Apps & Frameworks, Browsers, Nvidia, Xorg-Server, Mesa


To continue the cleanup of the repos, this guy posted a list of packages build in 2017 and before. It could be good to check this out eventually.

1 Like

NVIDIA Drivers 430.14

beta is only at 430.09-1 ..

Edit: Ocasionally, nvidia release branch is more updated.

1 Like

"manjaro-alsa" and "manjaro-pulse" are meta-packages:

  • manjaro-alsa will install "alsa-utils", "alsa-firmware", "alsa-lib", "lib32-alsa-lib" and "lib32-alsa-plugins".
  • manjaro-pulse will instal "pulseaudio", "pulseaudio-alsa", "lib32-libcamberra-pulse" and "lib32-libpulse".

Well it was just a list of package that has a build date in 2017 and before. It doesn't mean that all of them are irrelevant or useless, but some of them may be.

optimus-manager ( is out of date.
Version 1.0 is out!

Done - 1.0-2 is available in unstable


steam-devices needs a redo, because of maybe legal reason I had to rename it to game-devices-udev. Also it have a new version and there is an AUR pkgbuild

Also steam-manjaro needs an update, replace the steam-devices dependency with game-devices-udev and there is a new version

Thank you.


Done :+1:

1 Like

Version 1 is already out:

@philm, optimus-manager new versions have important fixes for Manjaro users.

Also, there is a question of why Manjaro is adding:


in /etc/sddm.conf

At the moment we need to comment those lines out to make optimus-manager work in Manjaro. Many of the past optimus-manager issues were caused by that (lack of switch, shutdowns, etc.) and now when we know what to change and some other bugfixes, optimus-manager is working quite nicely. Arch doesn't have this ssdm.conf addition as far I heard.

I'll see, what I can do.
It's the original version from Robin Lange with no patches done by Manjaro.
Will have a look on it until the end of this week - please be patient.

optimus-manager 1.0-2 is already available in unstable and testing

Please test this version and let me know if it works.

1 Like

I refreshed the database and yeah, it finally bumped to the newest version.
I was staying on 0.6 for the whole time and it was the only version that worked for me, while 0.7 and higher had some bugs that didn't allow me to use it. I believe version 1.0 was released last week and came with needed fixes and only today I found time to test it but since in Manjaro there was still 0.7, the next best thing was to use git version and that finally worked great for me. The last time I was testing git (before version 1.0 was ready) I had to restore system from a backup because the usual roll back to 0.6 didn't work quite well.

Anyway, since current git is working for me, I'm not going to take chances and won't test repo version at this time, although I believe it's solid now, because most of the issues that I saw were really addressed and many came from the sddm.conf problem. Now that we know what to change, everything is working as expected.

Kind of the reverse here ...
Apparently acetoneiso2 is in the arch repos, but not in ours? ..

Forum kindly sponsored by