Manjaro stopped booting after only a week

if you have do a update with windows ,
only microsoft can change something ( fast boot , suppress entry line boot linux , etc)

Move it back manually in BIOS settings?

These things don't just change by themselves.

As pointed out could be a Windoze update that made such a change.

No windows updates, I have it turned off.

Tried that, it remains in the position I move it to (or at least has done so far) but still will not boot. I've tried moving it to position 1 so that it should boot automatically, but the PC just ignores the drive with Linux on and boots to Windows.
In my boot menu, it used to say "Manjaro..." as a boot option, now it just says "P2:Samsung EVO 860..."(the name of the hard drive Linux is on).

Clearly not, but whilst I can't claim a perfect memory of everything I did on my last Linux session, the one thing I can clearly remember is that I didn't randomly move the hard drive to position 8 on my boot sequence for no reason at all and then wonder why it was at position 8 the following day!

sudo parted -l

Could be grub on Manjaro SSD needs to be restored, @gohlip has many posts on that.

Any other Linux distros installed and updated?

1 Like

Great, thanks. I will have a go at the GRUB restoring instructions. Could be some time...

No. I installed Manjaro on my laptop, liked it, now installing on my main computer. I've only had it on there a week and haven't really done anything except follow a few instructions from here on tweaking the system to suit my hardware and loading some packages from pamac. Can't think how I could have corrupted the GRUB, but must have done so somewhere.

This [Simple First Start] should fix it.
And do the 2 [UEFI - additional commands] when booted up.

This is a great help, thanks. But before I get into all that, if you've a moment, can I just check it's not simpler to just start again? I know it sounds drastic, but I've only had the OS loaded for a week and I've not really done anything on it (except screw it up apparently!). I'm happy to follow your instructions (if only to learn a bit more about this stuff), but if there's any advantage to wiping the disk and starting again, I could do that, having nothing to lose. Which do you think would be best?

What is best is what you yourself deem to be best. Seriously and sincerely.
What you are comfortable with, what is within your comfort zone; and sometimes even some want to venture out of their comfort zone to learn or mess around or to find out. These things are never fatal, so some jump right to it, yet some hesitate. And it is all okay whatever one chooses. Nobody should tell you what to do, unlike Mike Pence or Pompeo :rofl: F_r_e_e_d_o_m

Good luck, have fun and welcome to Manjaro.


So, I've made a couple of start but without promising results. I've done...

Start ########################

boot up livecd in the right mode, uefi or bios-legacy
Do not boot up to live OS, but press ‘c’ at the menu and we’ll get to the grub prompt (grub>).

grub> search.file /etc/manjaro-release root
grub> configfile /boot/grub/grub.cfg

all I've got is a black screen with the word grub_

Attempted the second approach...

grub> search.file /etc/manjaro-release root grub> probe -u $root --set=abc grub> ls ($root)/boot/


I got an error message along the lines of "attempt to read or write outside of disk 'hd2' "

Now it won't even boot from the liveUSB. It says "error file /boot/vmlinuz-x86_64 not found"

go back into your bios and make sure secure boot/fast boot are not enabled.

if only that mattered, windoze does what it wants, not what you want.

do you get to the grub screen of the live usb (where you select free/nonfree drivers)?

have you tried using the simple option to detect an already installed manjaro bootloader?

if you have fast boot enabled windows doesnt actually shutdown when you choose shutdown, only partially which is the reason for a "fast boot".

1 Like

Done that, it's all set the same as it was when I first loaded Manjaro.


No, not sure how to do that.

I've made no changes of that nature since successfully booting from the liveUSB last week.

when you get to that grub screen there should be something like "Detect bootloader" on the bottom IIRC.

if your manjaro is installed as UEFI, boot the usb in UEFI mode. sometimes on a UEFI system there are 2 entries on the boot selection menu. 1 for legacy and 1 for UEFI.

Not seeing anything like that. I'll Google it and see if there's a different way of getting to it.

Right, I have two options for my USB in my boot options. "SanDisk" (my USB) and "UEFI: SanDisk". The second option does nothing (ie computer boots to windows from the second hard drive). The non-uefi boot works up to the options screen but then runs into the problems noted.

is this the same usb you used to install manjaro or did you make another after this problem started?

make a new usb from windows with etcher and try again.

in bios, check these options

  • drive should be AHCI and not RAID
  • disable any "optane" crap if you have it. i thinks it's called RST in bios.
  • secure/fast boot disabled
  • if compatibility mode is enabled, try disabling it.

delete the manjaro boot entry from bios and add it again. it will ask you to specify which file and it should be something like

then set it to be the first in the boot order. be sure to save before exiting bios. this should make manjaro's grub boot before windows.

Not interrupting dgit (he's doing fine), but this does not look good

And even if it were started in wrong uefi/bios-legacy mode, the grub menu should appear.
Unless you have a separate boot partition. Do you?
[And there is a separate way to handle this in the link]

Can you recall what are the 2 packages ?
grub-customizer? I hope not.

1 Like

Yes, same one, it's also the same one that installed Manjaro on my laptop.

To be honest, this is the part of 'starting again' that I was most trying to avoid. If it does come to making a new USB, I'll probably just wipe the drive and start again entirely. Still want to know what happened though, otherwise I'm likely to just do it again next time.

I will try to carry out your instructions though, thanks.

The hard drive with Manjaro on has a 300mb EFI system partition, an 8gb partition (not sure what for) and then the rest. All this was put in place on a brand new hard drive by the Manjaro installation defaults.

The USB is exactly as Rufus made it.

I've done so little since I installed I could practically give you a list of every action, but the packages were Qgis (GIS software) and Clementine (music player). All I did else was change the workspace colours (and obviously whatever I did that screwed all this up, but it wasn't anything intentional, so I can't report it I'm afraid)

Forum kindly sponsored by