Manjaro stuck on booting, ACPI Error: Namespace lookup failure, AE_NOT_FOUND

This is my first post on any Linux forums and I also consider myself newbie (have used Linux before but not that much), so please bear with me.

I have laptop (Lenovo Y50-70) with a dual boot setup:

  • Windows 10 (1803)
  • Manjaro

are both installed, and have been working fine.
I haven't used Manjaro in the past week or so but yesterday I tried booting it up, and got this:

ACPI Error: [AR02] Namespace lookup failure, AE_NOT_FOUND (20170728/psargs-364)
ACPI Error: Method parse/execution failed \_SB.PCIO.PEGO._PRT, AE_NOT_FOUND (20170728/psparse-550)

(I typed this from the picture so sorry if there's a typo)
So i can't really use Manjaro now but I would love :heart: to! (Windows is working fine.)
I appreciate the help in advance!

Also here's some more info about my machine:

These infos are from LiveUSB:
fdisk -l

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 892DA805-2BA3-4DE4-85FD-A84698184BBA

Device          Start        End   Sectors   Size Type
/dev/sda1        2048     923647    921600   450M Windows recovery environment
/dev/sda2      923648    1128447    204800   100M EFI System <- this is where GRUB is installed
/dev/sda3     1128448    1161215     32768    16M Microsoft reserved
/dev/sda4     1161216  734128508 732967293 349.5G Microsoft basic data
/dev/sda5   734130176  735162367   1032192   504M Windows recovery environment
/dev/sda6   735164416  944879615 209715200   100G Linux filesystem <- my Linux installation
/dev/sda7   944879616 1347532799 402653184   192G Linux filesystem
/dev/sda8  1347532800 1364310015  16777216     8G Linux swap
/dev/sda9  1364310016 1953523711 589213696   281G Microsoft basic data

inxi -Fxz

  Host: manjaro Kernel: 4.14.52-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Desktop: KDE Plasma 5.13.2 tk: Qt 5.11.1 
  Distro: Manjaro Linux 17.1.11 Hakoila 
  Type: Laptop System: LENOVO product: 20378 v: Lenovo Y50-70 
  serial: <filter> 
  Mobo: LENOVO model: Lenovo Y50-70 v: 00000000Not Defined serial: <filter> 
  UEFI [Legacy]: LENOVO v: 9ECN43WW(V3.03) date: 08/12/2015 
  ID-1: BAT1 charge: 38.8 Wh condition: 45.7/54.8 Wh (83%) 
  model: LENOVO PABAS0241231 status: Discharging 
  Topology: Dual Core model: Intel Core i5-4210H bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23154 
  Speed: 798 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 852 2: 868 
  3: 881 4: 897 
  Card-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 
  v: kernel bus ID: 00:02.0 
  Card-2: NVIDIA GM107M [GeForce GTX 860M] driver: nouveau v: kernel 
  bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: intel,nouveau 
  unloaded: fbdev,modesetting,nv,vesa resolution: 1920x1080~48Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.1.3 
  direct render: Yes 
  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Card-2: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.14.52-1-MANJARO 
  Card-1: Intel Wireless 7260 driver: iwlwifi v: kernel bus ID: 08:00.0 
  IF: wlp8s0 state: down mac: <filter> 
  Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 v: 2.3LK-NAPI port: 3000 bus ID: 09:00.0 
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  HDD Total Size: 945.97 GiB used: 2.02 GiB (0.2%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPCX-24HWST1 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: A-Data model: USB Flash Drive 
  size: 14.45 GiB 
  ID-1: / size: 5.78 GiB used: 212.2 MiB (3.6%) fs: overlay dev: ERR-102 
  System Temperatures: cpu: 55.0 C mobo: N/A gpu: nouveau temp: 44 C 
  Fan Speeds (RPM): N/A 
  Processes: 178 Uptime: 52m Memory: 7.71 GiB used: 1.87 GiB (24.3%) 
  Init: systemd Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.12

I think those ACPI errors isn't the problem.
The other errors say you have misconfigured your clocks, which may have to do something but is not frequently stop booting.

  • It is common issue that when WinOS applies updates, re-enables Quick-boot, which needs to be disabled to use Linux dual-boot.
  • Also your Boot Settings show two WinOS options, was it always like this or did you have Manjaro there as well (sometimes we use a workaround to fake WinOS to boot Manjaro).
  • You could try going to TTY if possible (Ctrl+Alt+F3) and try to login, or boot straight to TTY (read this) and update your system and GRUB..
  • Try another kernel or recovery option in Grub Advanced options

Did you install some particular update the last time the system worked?

1 Like


Can Manjaro boot to prompt in the first place?
That should tell us what next steps to take in troubleshooting and fixing it.

To boot to prompt,
At grub menu, press 'e’
Arrow down to linux line
Arrow right past ‘quiet’ and 'splash’
Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
Add ‘3’ (without apostrophes meaning just 3)
Press F10 or ‘ctl’ + ‘x’ to boot

Login with password to prompt.

And suggest you make Manjaro up to date first with

sudo pacman-mirrors -f 3
sudo pacman -Syyu

After that, attempt to boot to graphical with


Let us know how it went.
Others will help you if you can boot to prompt (I'm no good with other stuff).

1 Like

Thank you very much for the clear steps!
I was able to boot to prompt. Here are two pictures before and after editing my Grub settings:

  • before
  • after (By the way what does that number 3 do there? Just curiuos about it. :smile: )

Then as you suggested I updated with pacman :

It updated a bunch of stuff.
After that tried startx, and got this result:

Here's the log file that's mentioned in the output.
I googled around and found this forum post.
The No drivers available and no screens found lines lead me to try this: mhwd -i pci video-linux (as it was written in the forum post).
And guess what it solved the problem! I was able to use the graphical interface again.

So it wasn't an ACPI related error. Should I edit the title accordingly or leave it as it is?

Also another quick question: as you could see in my pictures my terminal's resolution is pretty big because my display is 4k. Can I somehow change that? The log in screen is also displayed in 4k but after logging in my settings (full hd) takes place.

Thanks again for the help!

1 Like

No, as far as I can remember. Maybe firefox got an update that octopi notified me about and I installed that, but I dont think that caused the problem.

Check pacman logs

less /var/log/pacman.log   <== Press End to start from the last and up, checking dates

IMO leave the title, others may also get confused and try this and go to real issue. Add Update tag and maybe the specific package, if found.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by