Manjaro stuck on motherboard logo

After reading some, old and deprecated I think, articles around the internet I've probably done a mess out of the drivers in Manjaro. I've downloaded and "updated" (?) Intel drivers and then installed both video-linux and video-vesa drivers with mhwd command and I'm pretty sure the problem is there.
I booted Manjaro and... it stuck on the motherboard logo (in my case HP). Now, I tried using Manjaro's installation USB to open the terminal, but I'm not sure if I did it how it was supposed. I literally started Manjaro' s installation again (free/nonfree drivers, time and keyboard language), but instead of pressing "start installation" I opened the terminal. There I typed "manjaro-chroot - a" and then selected 0, but it gave me ERROR: You can't mount 0!. I have no idea what to do and wouldn't want to lose my data.
By the way, apart from this and the fact that I had to download and install wireless drivers manually I've been loving Manjaro Xfce. Works smoothly and without lags even on my low-end laptop without compromising on the the UI and aesthetic, that both look gorgeous. I thought that the Windows 10 > Linux passage would have been more difficult, but the only thing I'm missing is the applications support (BUT hey, there's Wine!).

change 0 to 1

I'll try, but then what should I do?

> sudo pacman-mirrors -f5 && sudo pacman -Syyu

## Installing nonfree driver

sudo mhwd -a pci nonfree 0300

## Removing Installed Drivers

> sudo mhwd -r pci video-linux


But that seems to be nvidia-related and not sure I should proceed from there.

P. S. While typing I tried what you said, it worked! Now I'm waiting answers for the question above, thanks :slight_smile:

EDI: I'm using Intel btw, that should have only free drivers.

Please for our helpers post output

inxi -Fxxxza --no-host
1 Like

Your inxi :wink:

[manjaro@manjaro ~]$ inxi -Fxxxza --no-host
  Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=it_IT keytable=it
  tz=Europe/Rome driver=nonfree nouveau.modeset=0 i915.modeset=1
  radeon.modeset=0 misobasedir=manjaro misolabel=MJRO1810 quiet
  systemd.show_status=1 apparmor=1 security=apparmor
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.10 info: xfce4-panel wm: xfwm4
  dm: LightDM 1.30.0 Distro: Manjaro Linux
  Type: Laptop System: HP product: HP 250 G7 Notebook PC
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10
  serial: <filter>
  Mobo: HP model: 84AA v: 82.31 serial: <filter> UEFI: Insyde v: F.07
  date: 11/23/2018
  ID-1: BAT1 charge: 17.3 Wh condition: 41.6/41.0 Wh (101%) volts: 11.1/11.4
  model: COMPAL PABAS0241231 type: Li-ion serial: <filter>
  status: Discharging
  Topology: Dual Core model: Intel Celeron N4000 bits: 64 type: MCP
  arch: Goldmont Plus family: 6 model-id: 7A (122) stepping: 1 microcode: 2E
  L2 cache: 4096 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4378
  Speed: 796 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 796 2: 796
  Vulnerabilities: Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Device-1: Intel vendor: Hewlett-Packard driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:3185
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting
  alternate: fbdev,vesa resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 600 (Geminilake 2x6)
  v: 4.5 Mesa 19.1.5 compat-v: 3.0 direct render: Yes
  Device-1: Intel vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
  bus ID: 00:0e.0 chip ID: 8086:3198
  Sound Server: ALSA v: k5.2.11-1-MANJARO
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus ID: 01:00.0
  chip ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  vendor: Hewlett-Packard driver: N/A port: 1000 bus ID: 02:00.0
  chip ID: 10ec:c821
  Local Storage: total: 495.01 GiB used: 51.3 MiB (0.0%)
  ID-1: /dev/sda vendor: Seagate model: ST500LM030-1RK17D size: 465.76 GiB
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  rotation: 5400 rpm serial: <filter> rev: RSM7 scheme: GPT
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Fit size: 29.25 GiB
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00
  scheme: MBR
  ID-1: / raw size: N/A size: 2.75 GiB used: 51.3 MiB (1.8%) fs: overlay
  source: ERR-102
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 149 Uptime: 8m Memory: 3.67 GiB used: 720.0 MiB (19.2%)
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9
  running in: xfce4-terminal inxi: 3.0.36

Oh sorry lol, posting directly the output here would have been better.
Now, do you know what commands should I type?
(I know I'm looking a little ingrate and inpatient, sorry)

That's ok,
use second link, Manjaro doesn't boot.

Finally I can update this thread. Sorry it took this long, but here it goes. As I thought the problem was with video-vesa, probably reading some old articles I messed up the drivers. Yes, I did what was written on the "black screen (which, btw, wasn't my problem was my PC just stuck on the motherboard logo, HP) article" but it didn't work.
Now, what I had to do in order to solve this was:

  1. Use the installation USB to boot Manjaro, again
  2. Open the terminal
  3. Type sudo manjaro-chroot -a and then type your system (in my case 1 was the answer)
  4. Then
sudo pacman-mirrors -f3
sudo pacman -Syyu
  1. And finally sudo mhwd -r pci video-vesa
    I rebooted and Manjaro booted without errors/problems. Thanks for helping through this!

point to the solution, your execution of the instructions to fix the bug is not considered a solution here in the forum.

Sorry, I don't understand. And I don't think it's a bug, but more like me messing up the drivers.

point to the solution, your execution of the instructions to fix the bug your problem (Manjaro stuck on boot) is not considered a solution here in the forum.

Ugh, I still don't understand. Why isn't that considered the solution? Like, it solved my problem. And why should I point to the "solution" (your "use the second link" message) when it isn't? Wouldn't that be misdirection?

Hi @userUSER English is not @SGS 's first language so let me see if I can help you understand what he is trying to explain to you.
The issue you had is a common one that is often asked by new users. As a result we have threads around the forum from the devs that help new users solve such situations. Instead of having multiple threads about the same problem being answered and solved with the same solutions we try to direct the user to an already existing thread that solves this common issue. This is exactly what @sgs did. He linked you to one such thread. The thread in detail describes the very steps you used to solve your problem. The real misdirection here is you deciding your post was the solution when in reality an already existing and linked to thread was the true solution. Does that make more sense?


What I was trying to say (English isn't my first language either :stuck_out_tongue:) is that the second link did NOT solve my problem (although some steps are similar, that I admit). To solve it I had to proceed with the steps I have written. That's why I pointed that as the solution and not the second link. Unless I have missed the solution/guide in the second link (and forgive me, if that is the case) I don't think I have done any real misdirection. Peace.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by