Manjaro under VirtualBox right guest addins

I run Virtual Box (6.0.10) on my Mac (ElCapitan) an installed ManjaroLinux (18.0.1) now with Kernel 4.19.60-1-MANJARO; Desktop Mate & Cinnamon; Updates installed.
With the default installed virtualbox-guest-utils the shared folders was seen in /media but no content.
I deinstalled all virtual-guest .....
installed linux419-virtualbox-guest-modules
all don`t work right.
So I deinstalled all virtual-guest ..... again and installed virtual-guest-utils (6.0.10-1) with linux419-rt-virtual-guest-mudules (6.0.10-2) new. Now it works well.
What's the difference between linux419-virtual-guest-mudules and linux419-rt-virtual-guest-mudules?

--
nice greetings
Fritz

All Manjaro virtualbox modules are kernel specific.

The rt kernel is a kernel compiled with real-time precision for music production.

I don't know about group membership in macOS - though I have a macBook I don't run VirtualBox on it - but a in a Linux VM the user must be member of vboxsf group to be able to access the shared folder.

All users are in the vboxsf group, this I made first.
This are made too: sudo chown root:vboxsf /media

I think I have no RT kernel, the wonder that the RT version of linux419-virtualbox-guest-modules now works fine.
Should I de-install linux419-rt-virtual-guest-modules and install linux419-virtualbox-guest-modules instead no? But if I remember right, this don't work before.
In another word why work linux419-rt-virtual-guest-modules?

I see now both are installed: linux419 and linux419-rt kernel and modules.

About my Manjaro:
OS: Manjaro Linux x86_64
Host: VirtualBox 1.2
Kernel: 4.19.60-1-MANJARO
Uptime: 6 mins
Packages: 1241 (pacman)
Shell: bash 5.0.7
Resolution: 1920x1200
DE: Cinnamon 4.2.2
WM: Mutter (Muffin)
WM Theme: cinnamon (Adwaita)
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: mate-terminal
Terminal Font: Monospace 10
CPU: Intel Core 2 Duo P8600 (1) @ 2.388GHz
GPU: VMware SVGA II Adapter
Memory: 602MiB / 1993MiB

$ inxi -Sz
System:
Host: voyager-march Kernel: 4.19.60-1-MANJARO x86_64 bits: 64
Desktop: Cinnamon 4.2.2 Distro: Manjaro Linux

$ cat /proc/version
Linux version 4.19.60-1-MANJARO (builduser@development) (gcc version 9.1.0 (GCC)) #1 SMP PREEMPT Sun Jul 21 12:17:26 UTC 2019

$ uname -a
Linux voyager-march 4.19.60-1-MANJARO #1 SMP PREEMPT Sun Jul 21 12:17:26 UTC 2019 x86_64 GNU/Linux

kernel 4.19.60-1 used
kernel 4.19.59_rt only installed
Manjaro-Kernels

I de-installed linux419-rt-virtual-guest-modules and kernel 4.19.59_rt and installed linux419-virtualbox-guest-modules - it don't work
I see the folders in /media but they are empty.

The type of network connection you choose for the virtual machine directly influence if you can share folders from the host.

If you choose to bridge the network to your lan - you cannot see the folders
If you choose to NAT the network - the folders are visible in the media folder

Also you need to enable and start the vboxservice on the client.

sudo systemctl enable --now vboxservice

Also you can get a hint of what is happening by checking the status of the vboxservice

systemctl status vboxservice

Back to linux419-rt-virtual-guest-modules and additional kernel 4.19.59_rt it works well!
Linux 4.19.60-1 runs, Linux 4.19.59_rt are only installed.

Which of the new kernels are recommend too 5.1.19-1, 5.2.2-1?

This I have done after each new install:
sudo systemctl enable vboxservice.service
sudo systemctl start vboxservice.service

The kernel that works for you :slight_smile:

How could I a fresh kernel 4.19.60-1 reinstall?
Is such a thing even possible and purposeful?

It's not.

How is this in principle with Linux, if an installation of a software patches (changes) the kernel and you uninstall this software again, is this change reversed in the kernel again or is this preserved as "dead code"? If so, can this lead to problems?
I have no experience with this.

I also ask this because during my experiments with the VirtualBox Client Extensions it happened (2x) that a longer script ran during boot.

The macOS (which I've been working with for over 10 years now) has no monolithic kernel (FreeBSD + Mach kernel) and works with kernel extensions (.kext). In macOS, kext are only active when needed. If such kext are not removed from the uninstall of a program, you can also delete them manually.

The background, why I am now more concerned with Linux, I am looking for a suitable task for my old, no longer Apple supported computers. I've known Linux for over 10 years now, started with Suse, Mandrake, RedHat (see also my self-portrayal in my profile).

Now I read that from this
https://archived.forum.manjaro.org/t/openbox-iso-refresh-august-10-2019/98287/34

Blockquote
VirtualBox installation
When creating a default VirtualBox VM the wizard creates it with a VMSVGA graphics controller.
Before launching the newly created VM goto the settings dialog of the VM and change the graphics controller to VBoxSVGA.

What now the better graphic controller in VirtualBox for Manjaro?
And could I change them on a installed system - what must I do that this work?

Today I use the default settings.

Use either vboxsvga or vboxvga with 3D acceleration enabled.

If you are using vmsvga today, you can change it. But after doing so you may need to use mhwd to install the virtualbox drivers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by