Manjaro update prevents system booting

I'm using the Gnome Edition with AMD 64 Vega GPU

I run an update at least twice a week on my system. This morning I ran a sudo -Syu update and after restarting my system and selecting Manjaro on the boot menu screen goes black then turns off completely. Hitting CTRL ALT F2 is useless the screen stays off. Here are some pictures.

Picture 1: My boot menu loads up.

Picture 2: Even by pressing Advanced option for Manjaro Fallback (Which usually works have no effect monitor still goes black hitting either normal or fallback start.

Picture 3: Hittig C to open command line only opens Grub command.


Obviously something in the latest update broke the video driver at start up. Since I can't seem to even get into command line to try fixing the issue i'm kind of stuck. I love Manjaro but using Gnome and KDE in the past time to time in certain updates it kills the video driver on boot. Ideas how to get back into the OS? Any help would be appreciated. Thanks guys.

Try via chroot.

Boot up from live Manjaro media then enter into the terminal:

manjaro-chroot -a

This is automatic chroot, useful when multi boot, will list all bootable partitions, select the proper (Manjaro) root partition then proceed with updating or fixing the system.
I would try it first.

sudo pacman-mirrors -f5 && sudo pacman -Syyuu

Thanks admdb but the issue is not with the " missing link to start the OS error " I'm pretty sure when I click on Manjaro the OS start booting up but because it doesn't load the GPU driver the monitor doesn't get signal and turns off. I can't see the screen but i'm pretty sure it hangs up at loading the vesa driver. Sadly time to time Manjaro update kills my driver. i'm using the open source drivers which should be even less likely to have problems when system updates.

I actually tried just in case your suggestion and all it did was to kill Linux Mint to boot. So now I have only windows booting up. I'm going to download the latest Manjaro KDE and reinstall the system but I'm really hoping to find a better solution for the occasional update the kills my video driver.

Normally the update does not broke the system.
As admdb suggested, use pacman -Syyuu.

I followed his suggestion to the letter with every step. Unfortunately did not fix the issue :frowning: .
No matter since I kinda need the system ruining I'm already reinstalling Manjaro ( This time the KDE version ) . I will keep an eye on it and see how it goes with this version. Thanks for your input.

It does not look like this. The third screenshot shows the grub prompt. That is your boot loader. If this is where you get stuck then it tells you that no kernel is started.

As mentioned before: You need to boot with a manjaro live CD, chroot to your system and fix the boot loader and the kernels.

Hopefully you setup Manjaro with the right partitioning (separate /home partition).

Mbod, the 3 screen shot if you read the " Picture 3 comment above my picture " I say if I hit C for command line it drops you to the grub, It has nothing to do with starting the OS. Not that confusing if you read it. Also when I press Manjaro or Rollback option ( not hitting command line by pressing C just forget about picture 3 ) clearly my keyboard and mouse lights flash as the OS begins to load and then the system hangs. However I can't see what the error message is because the screen turns off.

I tried admdb suggestion step by step to the letter and there was no change. To be clear I used a live cd to boot the system, then manjaro-chroot -a , then sudo pacman-mirrors -f5 && sudo pacman -Syyuu. After restarting there was no change. The OS started booting but the screen turned off.

Kersuskerfuerst " Normally the update does not broke the system. " I been using Linux for years and I know how to setup Linux to separate home partition. ( swap, boot .... ) done it hundreds of times with multiple OS and rarely had issues. Because as you wrote " Normally the update does not broke the system. " I have downloaded the latest Manjaro (Kde instead of gnome this time) and guess what? The OS worked great recognizing all OS and grub setup as it should be. Tired a few times turn off then on. OS loaded beautifully. Now at this point I had installed nothing else just the OS. Next step press update. Updated all files normally. Restart ! bang same crash as before. Now that makes it 100% logical that the update breaks something regardless of using gnome or kde desktop.

Looking at under technical issues / package update process / XFCE not even a black Screen after stable-update. I see a lot of people had the same issues after the last update. I keep digging there. Also 'linux-firmware 20190514.711d329-1' update prevents my system booting.

downgrade your linux-firmware package to the previous version, if you dont have the package of the previous firmware in your pkg cache you can use downgrade
sudo pacman -S downgrade
DOWNGRADE_FROM_ALA to 1 downgrade linux-firmware
there will be a list presented, select the previous firmware version. after downgrade finishes, reboot.

There's something similar here

Thanks dglt I read through that post and installed downgrade. However when I type " downgrade linux-firmware I got the following message.

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See for more details <<<<

So I looked at the page and it states type " DOWNGRADE_FROM_ALA=1 " to enable. So I pulled up terminal copy paste DOWNGRADE_FROM_ALA=1 hit enter. Looks like command executed. Great I type in downgrade again getting the same message as before

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See for more details <<<

No matter what i try to do downgrade option keep telling me is disabled. Even tried sudo su to make sure I got the access to enable it. Still no luck. Looks like i'm going in circles. What else can I do?

You have to put the option before the command, like:
DOWNGRADE_FROM_ALA=1 downgrade linux-firmware

Thank you very much Strit
That was the trick. I will run update now then before restarting the system will use this trick and see how it goes. Much appreciate it.


Thanks to everyone for your comments. Successfully downgrading to Firmware 201904 system running good. To recap, looks like people with AMD Vega & ( maybe Radeon VII ) cards should avoid the latest firmware upgrade. Let's hope the issue will be resolved with the next update. Will be looking for confirmation before jumping to a new firmware from 201904.
Thanks everyone.

$ inxi -Fxxxz
System:  Kernel: 5.1.4-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 tk: Qt 5.12.3 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HUAWEI product: KPL-W0X v: M1F serial: <filter> 
           Mobo: HUAWEI model: KPL-W0X v: M1F serial: <filter> UEFI: HUAWEI v: 1.19 date: 01/11/2019 
CPU:       Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: Huawei driver: amdgpu v: kernel 
           bus ID: 02:00.0 chip ID: 1002:15dd 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.30.0 5.1.4-1-MANJARO LLVM 8.0.0) v: 4.5 Mesa 19.0.5 direct render: Yes 

chopped up - but I will say that after inital investigation and some kernel params I have 0 problems. including with this update(s) [I'm on unstable]
I did run some debugging and have to reroute identifiers in order for everything to be proper.
Maybe thats whats missing?

I'm not sure what causing it with the monitor off I don't see where the system hangs. Yes, it is possible the identifiers don't line up with the new kernel.

anoobis wrote in his post >>>> " Having the same problem with a similar system (Ryzen 1700 / Vega 56). Booting Kernel 4.14 at least allowed me to launch Ctrl+Alt+F2 terminal but I couldn't fix it so far. " <<<<<

So I guess running the new firmware on kernel 4.14 allowed him to keep the monitor on thus probably having a visible error message. He may have an answer what hangs the system. Hope there will come a solution until then I can't install anything on octopi until I fully update my system. The only problem with the new update is the firmware. :frowning: . So the waiting game until we get the green light to update. Until then I will just stay on firmware 201904 which is working fine with the rest of the new updates.

Just to chime in here, so we don't scare of AMD users from updating the firmware package.

My laptop is a Ryzen 2700U with Vega Mobile GFX = Updated just fine.
My desktop is a Ryzen 2700 with an RX 560 = updated fine.

  1. My specs
    Ryzen Threadripper 2920x CPU
    Vega 64 GPU
    Kernel 4.19.45

  2. dyxzee specs
    Ryzen 5 2600
    Vega 64
    kernel: 4.19.45-1

  3. an00bis specs
    Ryzen 1700 / Vega 56

We have the same issue. Hope that narrows it down a little.

Forum kindly sponsored by