Manjaro vanished after update

I can't see this being related to an update of OpenSSH. Much more likely it's related to a Windows 10 update.

If you can boot into a live installer environment it might provide a starting point to diagnose the issue.

1 Like

"Manjaro vanished after update"

Update of what? Manjaro or Windows?
To be as nebulous as your request for help, there is an answer in this forum.
Go fix it.


For the third time, I go into the BIOS at once. The Bios shows my entire drive is a windows drive and the Bios does not show the USB stick with Manjaro on it. (latest version of KDE flashed by using Etcher.) So there is no way to select the stick for booting. This was a Manjaro KDE only setup. The are way more people complaining about the upgrade before the most recent one.

Simple thoughts come from a simple mind. There is nothing 'nebulous' in my request.

Maybe the BIOS was reset for some reason.
Check BIOS settings on boot order.
Use a non-USB3 port, better a USB2 or less.
And describe your system. Is there a reason for not doing it?

1 Like


Just a question? are you using UEFI or Legacy when booting?
How did you install Manjaro? did you install windows first then Manjaro?
Is it a dual boot situation? When using windows, it is better to install windows first , then install Manjaro, The windows boot and grub do not work well if you install windows last.
Also have you tried the USB stick in another computer to make sure it is formatted and working correctly? It's not easy to make assumptions about a issue as there can be thousands of reason why something does not work.

The easiest way is to install windows and Manjaro on different drives, dual booting is a pain with windows.

Also more information about your system as well as more information on troubleshooting would help. Unless there is people in this forum who's mind is a crystal ball it would be near impossible to come up with a resolution without more information.

The USB lights up, I assume that means it is working. I just found something in the Bios that forces it to use the USB and it worked. So now I have Manjaro 18.0.4 on my install stick displaying. So I will continue working on this.


The title of this thread was not chosen by me. @jonathon split this off into a new threadf and he chose the title. I have never said that Manjaro vanished.


  1. EFI and GPT
  2. no windows at all
    3.3. I used etcher on one of my other 64 bit machines.

So, jonathon split your post and made this title?
But the post is yours?

A windows update or a manjaro update which caused this problem each have different diagnosis and a different prognosis. Obviously. The fix is therefore different. Not so simple minded.

You don't have windows (now we know) yet system (uefi, now we know) when booted after this update (manjaro update, now we know) goes to a blue screen and offers to reinstall windows.

In uefi boots, any error in the efibootentry goes to the next efibootentry, in your case, a windows efibootentry; which means you have a windows efibootentry. Therefore the remedy is to fix manjaro efibootentry (and get rid of windows efibootentry). Both simple matters.

But now, we see you've marked your own post as a solution (unless somebody else again mark it?). And implied you solved it by using etcher and we have to assume with our simple minds that you have reinstalled.

ps: nebulous - vague or not clearly defined or stated.

This is strange, I have never had Windows 10 or any other version remove another OS as long as secure boot is disabled and the boot system is UEIFI.

Legacy Boot? It has happened but not for years.

Plus, from your description it sounds like Windows PARTITIONED your drive and expanded itself during an update which simply should be impossible.

It does not 'remove' OS. Just the bootloader; if bios-legacy, overrides mbr and if uefi and sharing the same $esp. And OP's update is not from windows but from Manjaro's update.

It is later clear that his manjaro bootloader efibootentry is compromised by manjaro's update and that he does not have a bootx64.efi even before the update; otherwise he would still be able to boot. But easy to fix.

See, even at this stage, you are still not clear. Don't blame you.
But OP is an old hand, not a new novice.

1 Like

Still, it sounds like secure boot was on; if UEFI without secure boot Windows shouldn't be able to remove the Linux boot option.
It can put itself as primary, maybe, but you still should be able to go into Setup and point "bios" to the Linux boot option.

No. Just a quick search (got tired after the first 5, there's more)

ps: since our installer and 'grub-install' commands does not generate a bootx64.efi, that's why I included this in this link. OP will have no problem if there is a bootx64.efi.

Yes, because you posted at the end of a thread asking whether a particular update was safe. This implied you thought your problem was related to that update.

What does this mean then:


Was Manjaro still visible/available/present? "Re-install" implies you already have Windows 10 on the system.

You're free to edit the title of the thread if you want.

The more specific you can be in your replies the less people have to guess and the less frustrating it is for everyone.

1 Like

JA! Ve vill haf discipline! You vill obey ze rules.

1 Like

What have happened here is that (probably) a Window update corrupted your Windows boot.

You have to do two things:

  1. Repair your Windows.
  2. Go into Bios and change the Manjaro boot option to primary.

Look, I down loaded 18.0.4, used Etcher on my 32bit machine to build a new install on a USB stick. Then, AMD in their bios, has a command to force the system to boot from the stick. It worked fine. So the rest of you can sit around and argue about 'how many angels can sit on the head of a pin' and I am now working on the latest R distro, and the open version of R-Studio and the R-Server.

I have spent most of my adult life as a researcher working in the area of Mental Health, Public Health, and issues around access to health care services in the USA.

My system is up and running. There is a new field called Data Science. I am taking courses at Johns Hopkins on line. I got the laptop so that I can continue to work while I enjoy my summer in Yosemite. I am 76 years old and I am not going to retire til I am dead.

So, if you want to have a serious discussion about health care in the USA, lets talk.


1 Like

So what you're saying is that you run linux from a stick?
Then of course your entire drive is a windows drive...?

I am sorry but while truly appreciate your skills, you have not explained your setup well enough to get proper help. And that is at least partly on you.

It looks like there are several tangents happening here. Whatever the issue was it apparently isn't an issue any more, so let's all move on.

Forum kindly sponsored by