Manjaro & Windows 10 dual-boot-system Grub broken after Windows update

First of all, Hello Manjaro Community!
I'm new to Manjaro, but not totally new to Linux or Unix-like stuff. I'm not that much experienced to call myself a "pro" or whatever, but i own a Macbook Pro from 2011 and have been playing around with the terminal and some advanced command-line stuff there before, if that counts as "unix-experience" ...:thinking:

Anyways.. My current setup is:
Lenovo Thinkpad T480s with Windows 10 and recently installed Manjaro as dual-boot. All has been fine, with nice GRUB-Bootloader and Manjaro-style boot-select-screen - dunno how to call it, but i believe you guys know what i'm referring to, haha :smiley: - until the last big Windows update came up and just totally messed with the dual-boot stuff.
I have read through several guides now, tried this and that and i don't know what to do more. Always at some point i run into some f*cked up error and i'm really frustrated to some point now. What i get when starting up the laptop without doing anything is the grub-rescue shell with "unknown filesystem" error. I manage to boot into the installed Manjaro via these steps:
ls to find out the ext2 partition
set boot=ext2 partition
set prefix=ext2 partiton/boot/grub
insmod normal
normal
After that it boots into Manjaro, but even if i do "sudo update-grub" and reboot...Same stuff again.

Also i am able to boot into Windows "normally" via interrupting the startup and manually selecting it from the (i guess it is) UEFI/BIOS boot menu.

So, what else? I grabbed some USB pendrive and set up a rescue drive with Rescatux Rescapp but no matter what i try there i get a bunch of errors. Sorry if i can't recall them all here, i just quit that and tried the next method.
Grub-bash via "C" from Live-Manjaro on a USB pendrive and trying to repair grub didn't go successful either.
So i tried booting into Live-Manjaro and mounted the ext4 partition to some /mnt location and chrooted into it. Began to perform grub-install with different parameters and different methods. But at some point i either get "that doesn't look like an efi partition" or "failed to get canonical path of .." or i don't know what else...

I try to provide some info now to help figuring out my problem, 'cause i'm stuck and tired of fiddling around with no result!

This is the output of "inxi -Fxz":

System:    Host: timm-pc Kernel: 5.3.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.16.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20L8S02E00 v: ThinkPad T480s serial: <filter> 
           Mobo: LENOVO model: 20L8S02E00 serial: <filter> UEFI: LENOVO v: N22ET57W (1.34 ) date: 09/02/2019 
Battery:   ID-1: BAT0 charge: 36.2 Wh condition: 50.0/57.0 Wh (88%) model: SMP 01AV480 status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 883 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 883 2: 921 3: 993 4: 1014 5: 1314 6: 892 7: 1156 
           8: 1024 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: intel resolution: 2560x1440~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.2.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.3.6-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: efa0 bus ID: 3d:00.0 
           IF: wlp61s0 state: up mac: <filter> 
Drives:    Local Storage: total: 491.60 GiB used: 25.74 GiB (5.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000L7 size: 476.94 GiB 
           ID-2: /dev/sda type: USB model: USB2.0 DISK size: 14.66 GiB 
Partition: ID-1: / size: 88.89 GiB used: 25.71 GiB (28.9%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 228 Uptime: 18m Memory: 15.53 GiB used: 1.84 GiB (11.8%) Init: systemd Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 inxi: 3.0.36

And the ouput of "lsblk -f":

NAME        FSTYPE  LABEL             UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda         iso9660 MJRO1810          2019-09-11-15-21-05-00                              
├─sda1      iso9660 MJRO1810          2019-09-11-15-21-05-00                              
└─sda2      vfat    MISO_EFI          07E3-BFF9                                           
nvme0n1                                                                                   
├─nvme0n1p1 ntfs    Wiederherstellung 0694786994785CDD                                    
├─nvme0n1p2 vfat                      7479-4438                              69,7M    27% /boot/efi
├─nvme0n1p3                                                                               
├─nvme0n1p4 ntfs                      7EEC93F8EC93A8C3                                    
├─nvme0n1p5 ntfs                      BA8288A7828869A9                                    
└─nvme0n1p6 ext4                      2c031e80-1a1b-4fc4-b802-02637fdebbc7   58,6G    29% /

Please let me know if i can provide some further info to help me out. As i said, i can boot into the installed Manjaro temporarily via grub-rescue, so i guess i can pretty much operate from here.

I guess that's it for now.
Any help is much appreciated! :slight_smile:

peace out,
flashmaster

You've done a great job, so far.
Now, just install grub (from inside your installed Manjaro) properly.

Get some help tips from this. I am sure you'll do fine!

If you still fail, which I doubt, post info as explained in the tutorial.

2 Likes

Thanks for the kind words, AgentS. :slight_smile:

I've actually stumbled over that same post before, but I guess I may have skipped some steps or didn't read properly enough through it. I just checked it again, do you think I should start from the part after using the live-system and the grub prompt where it says "if grub is really messed up"?

If it is windows that messed up, the [Simple First Start] will do.
But don't forget to do the 2 [Additional UEFI commands] after you boot up.

1 Like

@AgentS

I assume drives are gpt, where from this inxi thing that it shows?
What's ├─nvme0n1p3 ?
It appears to be an extended partition.

That's why I prefer parted -l, fdisk -l is okay not as good, lsblk not so and inxi if shown is hard to read. inxi is popular here I noticed. what's with inxi? :joy:

@gohlip

That's what parted -l shows:

sudo parted -l
[sudo] Passwort für timm: 
Modell: Unbekannt (unknown)
Festplatte  /dev/nvme0n1:  512GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende   Größe   Dateisystem  Name                          Flags
 1      1049kB  524MB  523MB   ntfs         Basic data partition          versteckt, diag
 2      524MB   628MB  104MB   fat32        EFI system partition          boot, esp
 3      628MB   645MB  16,8MB               Microsoft reserved partition  msftres
 4      645MB   414GB  413GB   ntfs         Basic data partition          msftdata
 5      414GB   415GB  677MB   ntfs                                       versteckt, diag
 6      415GB   512GB  97,5GB  ext4

I'll try the [Simple First Start] now.

I don't know, the "First Post Tips & Tricks" text mentioned that.. :sweat_smile:

Update

Executing the [Simple First Start] commands finally did the job! When the laptop boots up it shows a simple console-style boot-selection screen. It's like the one that came initially with the fresh manjaro installation, regarding the functionality. So I'm really happy with that now! :grinning:
Thanks for your help, guys.

The cherry on my happy-cake (cheesy, I know) would be the nice-looking manjaro-style boot-screen. I really liked that and was getting used to it, but if that's kind of a hassle to bring back now, I'm fine, too!

Can be done.
Print your /etc/default/grub
We'll fix it.

Encountered this issue as well, on a Lenovo laptop recently setup as Manjaro Windows dual boot. Ended up re-installing Manjaro partition. Partitioning scheme has one Manjaro Ext4 partition as done here. To prevent such issues in future, would it be better to have separate boot partitions for Manjaro and Windows?

/boot not-$esp partitions - no.
/boot/efi $esp fat32 partitions - yes.

@gohlip Thanks

How can that be done? :see_no_evil:

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires to
# set 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"

:slightly_smiling_face: Of course the best way is to have a separate $esp fat32 partition before installation and during installation select this partition for the $esp mounted as /boot/efi.

After installation, it can still be done. But careful steps are done in sequence and done properly. But I suggest you leave this for now since you now know how to get back your manjaro boot. Not too difficult right? :slightly_smiling_face: But here are the steps, just for your info.

  1. unmount /boot/efi
  2. uncomment present /boot/efi entry in fstab
    make entry for new /boot/efi in fstab to the new $esp
  3. mount new $esp as /boot/efi
  4. do 'grub-install' command


Okay, to your grub menu. I think you mean you now have a black text screen with grey/green text without any background. And you want a nicer 'theme' that you had before with background. Stop here if that is not so and explain. If so. continue.

  1. First to be sure, use your file manager and check there is a directory in /usr/share/grub/themes/manjaro/
  2. At your /etc/default/grub, change/uncomment/add the following lines
GRUB_TERMINAL_OUTPUT=gfxterm
GRUB_GFXMODE=1024x768x32
GRUB_GFXPAYLOAD_LINUX=1024x768x32
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

  1. At terminal
sudo update-grub

Done.

What am I missing here? What are you trying to do?
I thought OP wants a nice theme...

Every tool is good as long as you use it (properly?).

A lot. :rofl:
OP is asking how to have separate $esp in the question bkm asked.

You're losing it .... again.
Hey, wake up. You had a long siesta or how do you call it in greek?

I am in the process. Thanks!
Please try to read slower and use your meta-senses to see what OP really needs (vs. wants) and don't mix Users. I do that a lot...

Yeah.. you don't multitask.
Had your “ mesimeri ”?

1 Like

Haha, guys!
You really made me laugh now, nice misunderstandings around.. :smiley:

Chill out and be nice to each other :yo-yo:

@gohlip:
Thanks, that brought back the nice-looking bootscreen :slight_smile:

I'll just skip the steps you provided for arranging a separate $esp.. Windows messed up with the grub in the meantime again, so that i didnt have a choice at all and laptop by default booted directly into windows...But the simple process with the few commands to bring back grub worked like a charm again, so i'm fine without separate $esp as long as fixing stays easy!

Just to rant some more.. i encountered some more problems with that holy mother of jesus crapped update, as it messed up the beloved and very practical nightmode on my machine..:anger::angry: Even redshift doesn't work anymore now!
I'm getting nearer to the point to just screw that Wind€rps crap stuff totally and leave it behind forever, but i'm still not ready yet, unfortunately :roll_eyes:

Again, props for your support and understanding!

1 Like

Always happy to hear that. And you're welcome.

Oh no. AgentS and I are partners for a long time now. We help and correct each other in our own funny way. There is no misunderstanding at all. As someone said (or something like that)..

"Do not correct a fool or he will hate you. Correct a wise man and he will appreciate you."

AgentS is a wise man. LOL. :joy:

Cheers.

2 Likes

Ah, i see! Cool then. Nice to be part of this friendly community now. :partying_face:
Never had such a breeze of a support-like experience in many years of Windows-usage..

3 Likes

Forum kindly sponsored by