Manjaro + Windows10 | Windows is not booting now

I ran into a problem! I was a happy Manjaro + Win dual boot user. After updating bios, it messed everything. I'm using hp laptop. So I played with efibootmgr. My problem was my system was directly booting into Windows than booting grub. Later I found that my /dev/sda1 is mounted on /efi directory. Upon opening /efi ; there are

> /efi
> /EFI /system-volume 
> cd /EFI
> /Boot /Microsoft 
> cd /Microsoft

Microsoft has some files to boot into Windows. I also noticed bootmgfw.efi
Now my problem;
After setting grub to boot first than booting directly into Windows, I changed bootorder to grub. After generating grub configuration, I saw it detected Windows at /dev/sda1. But, the problem is, WINDOWS IS NOT BOOTING -_*
I tried hours and days figuring out the problem. I couldn't. But, Manjaro is booting fine.Later I noticed one thing;

efibootmgr command was showing EFI HARD DRIVE as 0002 and Windows boot manager as 0000. But, now when I'm doing efibootmgr command, I could not see 0002 EFI HARD DRIVE. I don't know why. I didn't delete any file from /Microsoft folder. What's happening? I'm sure that I didn't do anything with Windows partition or EFI. I think bootmgfw.efi is not working anymore?

This is my grub config file for windows

menuentry 'Windows Boot Manager (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-efi-56ED-23AC' {
        insmod part_gpt
        insmod fat
        set root='hd0,gpt1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt1' --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 -->
        else
          search --no-floppy --fs-uuid --set=root 56ED-23AC
        fi
        chainloader /EFI/Microsoft/Boot/bootmgfw.efi

my UUID list

/dev/sda1: UUID="56ED-23AC" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="e9280447-92cd-46bd-804f-f504d022c16a"

/dev/sda3: LABEL="Windows" UUID="84BAE764BAE7516A" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="3e1ad713-4760-47d1-9933-7f118bdb0a9c"

/dev/sda4: UUID="9610facb-eb6b-4732-a955-b7befd979aa9" TYPE="ext4" PARTLABEL="Basic data partition" PARTUUID="6309e421-775a-4383-b938-ff83c7c63f9a"

/dev/sda5: LABEL="OTH" UUID="01D53EEAB045EE20" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8f899f4c-f3e3-4e8a-aae3-bc0cf7c88182"

/dev/sda6: UUID="78DC-131C" TYPE="vfat" PARTUUID="009d57fd-ac3b-594f-875d-27eedcabc470"

/dev/sda7: UUID="256142ce-4823-4308-abd1-cf39a10725c0" TYPE="swap" PARTLABEL="Basic data partition" PARTUUID="2ce557c9-362b-4575-ba05-f5a440256dbd"

/dev/sda8: LABEL="RECOVERY" UUID="16DC224ADC222509" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="5f70438d-7be9-442f-be0e-b4dac27a8234"

/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="f192bb20-8ce8-4a2b-9dbe-e0bb1625442d"

FInally, lsblk says

$ lsblk                            
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0   260M  0 part /efi
├─sda2   8:2    0    16M  0 part 
├─sda3   8:3    0 755.7G  0 part 
├─sda4   8:4    0    96G  0 part /
├─sda5   8:5    0  62.2G  0 part 
├─sda6   8:6    0   524M  0 part 
├─sda7   8:7    0   979M  0 part [SWAP]
└─sda8   8:8    0    16G  0 part 
sr0     11:0    1  1024M  0 rom 

Somebody give some helpl ,please!!

The two vfat partitions are sda1 and sda6 the later has no mount point is this the windows one?

I think move Windows to separate Drive would help:

  1. Hook up additional ssd with windows 10 (not yet activated).
  2. Boot into BIOS and change boot order so new Windows 10 ssd boots first.
  3. Complete windows 10 activation.
  4. Shut down and boot into BIOS again to reset boot order priority to Manjaro.
  5. Update Grub in Manjaro.
1 Like

Sda1 is Windows. I think sda6 , I made it accidentally or I don't know why it's there. People asked me about that before!

Can't I fix this by booting into live cd of Windows and fix MBR? Can I fix it from within Manjaro itself? Btw,I already purchased Windows 10. So if I wipe everything from my system, and download the win10 iso, can I activate it with my old product id? Or what's step 3?

Moved from #technical-issues-and-assistance to #newbies because the OP has not yet used the forum search function.

But still, you did something. I guess you forgot, or ...?

How/why do you mount $esp on /efi and not /boot/efi?

More info may help you

efibootmgr -v
sudo parted -l
lsblk -f | grep -v loop
inxi SMaxxxz
grep -v ^# /etc/fstab

Maybe this will help:

sudo pacman -S what-have-i-done

:stuck_out_tongue_winking_eye:

1 Like

If you put manjaro grub on sda1 it will have wiped out windows boot loader if you formatted it as /boot/efi

This is really confusing. I did something wrong? I shouldn't have installed thing in /efi ? Should've been /boot/efi ?

If it has wiped, what's the solution?

At least one thing... you haven't used Manjaro User's Guide, which makes things look confusing.
Else they wouldn't... :wink:

1 Like

@Benjamin007
Before doing anything, can you check the contents of sda6?
Confirm contents of sda1 as well.
Is there (hd0,1)/efi/Microsoft/Boot/bootmgfw.efi
Is there (hd0,6)/efi/Microsoft/boot/bootmgfw.efi

Use Manjaro file manager to check, it might be easier.

If you wiped Windows, the only responses we can give in increasing order of data loss are:

  • Restore your back-up (data loss since last backup)
    OR
  • Try TestDisk. It's not perfect: uncertain amount of data loss, depends on what you did.
    OR
  • Reinstall Windows (everything that was on that partition before is lost) but it seems that you have 2 more NTFS partitions, so those will remain intact.

Ok. I fixed it! The problem was I accidentally replaced bootmgfw.efi with bootx64.efi using bcdedit in Windows. I understood this by noticing the checksum of both. They were same. So then I understand bootmgfw.efi is missing. Then I copied from my other computer and things are working good now.
Thanks everyone!

I m-i-s-100 ! :slight_smile:

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by