Manjaro with Ryzen 3 3200g (Vega 8) any experience ?

@Librewish, thanks for your input, this looks promising... if Vega 11 works
ok, Vega 8 will probably too, because only difference is in number of cores I believe.

Do you maybe have a spare monitor to connect on other mobo port
and see if dual monitor setup works? :slight_smile:

no i have one monitor only

I plan to use 2 DDR4 modules of 4, or 2 modules of 8 gb, in any case two modules.
Motherboard I plan to use is Asus PRIME-B450M-K, so probably I will go with
2 modules on 3200Mhz with better latency like 15.

Normally it should work OK. With 18.1.2 we ship a new linux53 kernel. We will soon prepare 19.0 development ISOs with Linux54. The feedback is normally good now.

2 Likes

Glad to hear that! :slight_smile:

I'll get my Asrock Deskmini A300 with Ryzen 3400G & dual monitors next week.
Will install Manjaro XFCE and Manjaro KDE dualboot.
I'll check Steam Gaming and video encoding (Kdenlive).
Will report then.
:nerd_face:

Thats great, thanks! I try to get as much info as I can...

install this kernel.
from aur.
it fixes glitches and freezes on ryzen 5 3400g

https://aur.archlinux.org/packages/linux-amd-raven/

as manjaro kernel glitches and freezes.

@philm
i hope you add the patches from this kernel to
manjaro kernel

2 Likes

We were unable to install any distribution on a Ryzen 3400G, MSI Mortar Max, BIOS updated. We always failed to load the live sessions. We finally succeeded to install 18.1.0 Architect. We even saw the lightdm login screen with Linux54 RC but right after login to the Xfce desktop our box always freezes with a green screen.

After plugging in an old Nvidia GTX-210 card to the PCI slot everything went smooth. We now happily run this system on Linux53 (stock 5.3.8.) but we do look forward for the Vega 11 APU support to land in the stable kernel branch. :smiley:

it is already there since months. Something else must be wrong on your end.

@Librewish - Ryzen 3 3200g is not Raven Ridge, it is Picasso (successor of Raven Ridge),
does this patch addresses it too?

yes i am using it on ryzen 5 3400g

Ok, thanks.

Hopefully 18.1.2 ISO will work.

Got my new Ryzen 5 3400G computer today. AMD CPU internal graphics only.
Tried to live boot Manjaro 18.1.3 (XFCE):

Tried to live boot Manjaro 18.0.4 (XFCE):

  • Hangs after:
[OK] Started Light Display Manager.
[OK] Reached target Graphical Interface.
[OK] Started TLP system startup/shutdown
_ (cursor blinking forever)

Updated BIOS to newest (AGESA 1.0.0.3) and still no boot into live environment possible (tried 18.1.3 & 18.0.4 again).
Selecting free / non-free drivers doesn't change anything.

I'm in panic now, don't know what to do. :pleading_face:

Please help,

UPDATE:
Manjaro 18.1.3 (KDE-VERSION !) boots into live environment
Manjaro KDE installed / Installer fc when selecting "Manual partitioning", must select "Delete drive" during install process.

pappl

Is it working? :slight_smile:

When you have some more info, please post :slight_smile:

Asrock Deskmini A300 & Ryzen 5 3400G is working fine with KDE (only), but haven't tested gaming, video editing or any other GPU features now.
Youtube seems fine at first glance.
All hardware components (Audio In/Out / HDMI / DP / Ethernet / Wifi / Bluetooth/USB/NVMe,...) working.
CPU temps are normal. :slight_smile:

Strange XFCE doesn't work.

you could try wayfire linux it works.
just update the kernel to linux54
or to linux-amd-raven
or to linux-mainline
or to linux-tkg-{pds,muqss,bmq}
after install.
and install mesa-git from repo.

2 Likes

Stock kernel (5.3 and RC 5.4) with Ryzen 3400G generates glitches and freezes.
Thanks @Librewish for a hint with raven kernel - works like a charm. I hope Manjaro Team will patch stock kernels.

1 Like

Cinnamon version boots and installs fine

Forum kindly sponsored by