Manjaro won't boot up, stuck at ASUS splash screen

Hello guys,

I have problem with my laptop where it won't boot up and stuck at the ASUS splash screen. This has happen multiple time before and I can solve it by chroot into the system using LiveUSB and entering the command below.

sudo manjaro-chroot -a
sudo pacman _Syyu
sudo update-grub

The problem now is the command above won't work anymore and i have tried to solve it by following the step stated here, GRUB/Restore the GRUB Bootloader and also here, Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader but still it will stuck at splash screen.

I'm at a bit of a loss here and can anyone know how to solve it. I didn't want to do a fresh install because I didn't have the backup on my data.

Thank you.

Hello,

that either was a typo here, or maybe you did the same on the system ...
was supposed to be -Syyu

Can you access TTY2 by using CTRL+ALT+F2 when booting the installed system?
Do you have access to GRUB boot menu and adit it by pressing e, then remove quiet and splash from the kernel linux line, then press F10 to save and continue booting?

Use an updated version.

Well, well, well...another lesson learned the hard way.

3 Likes

Oh sorry typo in the writing

I can access the tty2 but then what should i do, should I try to reinstall the bootloader

I can access the grub menu but didn't know how to remove the parameter because pressing e didn't do anything

I did use the latest version, that link is just for guidance

Hahaha i just ditched windows a couple of weeks ago so i didn't think of to backup my data

GFY! :+1:

If you can still access the unbootable partition, you can still make a backup of your data. That should be your first priority, especially if it's valuable data you're talking about.

So if i still have the access to the partition, how to make a backup and will it backup all the data including the app and also the wine configuration?

From live media you can backup everything you want on an external HDD. Just mount the drive you have the installation and data and copy it elsewhere where is safe. later you can restore it from your installed and working system.

2 Likes

Alright thanks

1 Like

I login into the tty and after write the command startx, the tty freeze. Any other way to detect the problem?

If you have access to TTY, you could investigate why the session doesn't load. You didn't mentioned what DE you have installed. We don't know what system you have nor what driers for GPU. Still, once you are in TTY, run this command:
sudo pacman-mirrors -f && sudo pacman -Syyu
once the updates are done run this command
systemctl reboot

Sorry about that.

This is the spec for my laptop:
Rog GL553VD
Cpu: Intel® Core™ i5 7300HQ Processor
Gpu: NVIDIA GeForce GTX 1050
driver used is nonfree installed using mhwd
De used is gnome

I've done this and still nothing change

In tty, i tried to look for error in /var/log/Xorg.1.log but i can't find any error message

A discussion about same type of freezing at startup
https://bbs.archlinux.org/viewtopic.php?id=238048

The problem is, from ASUS site, the specifications of the laptop only mention the GeForce GTX 1050 GPU, but from the discussion on arch forum it seems is a hibrid and using bumblebee ...
Try to install wgetpaste to be able to share terminal output per dpaste.
sudo pacman -S wgetpaste
Then share the links from this commands:
inxi -Fxxxza --no-host | wgetpaste
and
mhwd -li | wgetpaste

EDIT: Since you mentioned Gnome, i wonder if you have an extension that fails to load, hence making GDM to fail too. So you could try from TTY to run:
gsettings set org.gnome.shell disable-user-extensions true
to disable all extensions, then reboot the system:
systemctl reboot
and see if after that the GDM loads and you can properly log in. If that works, then one by one enable the extensions and see which extension is failing.

this is the output from the inxi -Fxxxza --no-host command

12System:    12Kernel 5.4.23-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 9.2.1 
           12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=Asia/Hong_Kong 
           driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 misobasedir=manjaro 
           misolabel=MANJARO_GNOMEM_1902 quiet systemd.show_status=1 apparmor=1 security=apparmor 
           12Desktop Gnome 3.34.4 12wm gnome-shell 12dm N/A 12Distro Manjaro Linux 
12Machine:   12Type Laptop 12System ASUSTeK 12product GL553VD 12v 1.0 12serial <filter> 
           12Mobo ASUSTeK 12model GL553VD 12v 1.0 12serial <filter> 12UEFI American Megatrends 12v GL553VD.308 
           12date 04/29/2019 
12Battery:   12ID-1 BAT0 12charge 37.1 Wh 12condition 37.1/48.2 Wh (77%) 12volts 16.2/14.4 
           12model Simplo SDI ICR18650 12type Li-ion 12serial <filter> 12status Full 12cycles 33 
12CPU:       12Topology Quad Core 12model Intel Core i5-7300HQ 12bits 64 12type MCP 12arch Kaby Lake 12family 6 
           12model-id 9E (158) 12stepping 9 12microcode CA 12L1 cache 256 KiB 12L2 cache 6144 KiB 
           12L3 cache 6144 KiB 
           12flags avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 20004 
           12Speed 900 MHz 12min/max 800/3500 MHz 12Core speeds (MHz) 121 901 122 900 123 900 124 900 
           12Vulnerabilities 12Type itlb_multihit 12status KVM: Split huge pages 
           12Type l1tf 12mitigation PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           12Type mds 12mitigation Clear CPU buffers; SMT disabled 
           12Type meltdown 12mitigation PTI 
           12Type spec_store_bypass 
           12mitigation Speculative Store Bypass disabled via prctl and seccomp 
           12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization 
           12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           disabled, RSB filling 
           12Type tsx_async_abort 12status Not affected 
12Graphics:  12Device-1 Intel HD Graphics 630 12vendor ASUSTeK 12driver i915 12v kernel 12bus ID 00:02.0 
           12chip ID 8086:591b 
           12Device-2 NVIDIA GP107M [GeForce GTX 1050 Mobile] 12vendor ASUSTeK 12driver nvidia 12v 440.59 
           12bus ID 01:00.0 12chip ID 10de:1c8d 
           12Display 12server X.Org 1.20.7 12driver nvidia 12compositor gnome-shell 
           12resolution 1920x1080~60Hz 
           12OpenGL 12renderer Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) 12v 4.6 Mesa 19.3.5 
           12compat-v 3.0 12direct render Yes 
12Audio:     12Device-1 Intel CM238 HD Audio 12vendor ASUSTeK 12driver snd_hda_intel 12v kernel 
           12bus ID 00:1f.3 12chip ID 8086:a171 
           12Sound Server ALSA 12v k5.4.23-1-MANJARO 
12Network:   12Device-1 Intel Wireless 7265 12driver iwlwifi 12v kernel 12port e000 12bus ID 02:00.0 
           12chip ID 8086:095a 
           12IF wlp2s0 12state up 12mac <filter> 
           12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor ASUSTeK 
           12driver r8169 12v kernel 12port d000 12bus ID 03:00.0 12chip ID 10ec:8168 
           12IF enp3s0 12state down 12mac <filter> 
12Drives:    12Local Storage 12total 935.12 GiB 12used 98.85 GiB (10.6%) 
           12ID-1 /dev/sda 12vendor Seagate 12model ST1000LM035-1RK172 12size 931.51 GiB 12block size 
           12physical 4096 B 12logical 512 B 12speed 6.0 Gb/s 12serial <filter> 12rev SDM1 
           12ID-2 /dev/sdb 12type USB 12vendor Kingston 12model DT 101 G2 12size 3.61 GiB 12block size 
           12physical 512 B 12logical 512 B 12serial <filter> 12rev 1.00 
12Partition: 12ID-1 / 12raw size 914.13 GiB 12size 898.79 GiB (98.32%) 12used 98.10 GiB (10.9%) 12fs ext4 
           12block size 4096 B 12dev /dev/sda2 
12Sensors:   12System Temperatures 12cpu 58.5 C 12mobo N/A 
           12Fan Speeds (RPM) 12cpu 3200 
12Info:      12Processes 203 12Uptime 27m 12Memory 15.53 GiB 12used 1.38 GiB (8.9%) 12Init systemd 12v 244 
           12Compilers 12gcc 9.2.1 12Client Unknown Client: kworker/u8:0-events_power_efficient 
           12inxi 3.0.37

from mhwd -li command

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

and another question is it seem that i have connection to the internet from ping 8.8.8.8 command but when i tried to update the mirror is stated that internet connection appears to be down

I think you provided the inxi from live media, so now you managed to "confuse" me :slight_smile:
Are you booting from live media and is stuck at Asus logo and you can only access TTY?
Is the installed system booting only if you use the usb install media boot, and you can only access the TTY that way?

Really sorry about that, earlier i did manage to access the tty even without the live media but just now it seem that after i boot up the laptop, it will just shut down after a while after showing the asus logo and i didn't even manage to access tty. So yes for the reply above I chroot from live media.

edit: really sorry for all the hassle, now i have access to the tty
for the inxi command : http://dpaste.com/0WV116E
for mhwd -li : http://dpaste.com/0YY5M30
i also tried to disable gnome extension but still the same

hmm ... nothing obviously wrong with what you have there. What i would do to save that install is switch to testing branch while still in the installed system TTY:
sudo pacman-mirrors --api --set-branch testing
After you changed the branch, rebuild the mirror list and update your packages:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
then reboot the system
systemctl reboot

Another thing i would do is to switch after that, or before switching brances ... to kernel 5.5
sudo mhwd-kernel -i linux55
and reboot after that with the same command i mentioned:
systemctl reboot

Sadly nothing happen after doing all that switching. Looks like i need to do a fresh install and thanks for all the help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by