Manjaro XFCE 20.0.3 - Persistent USB - released

There was always the demand of persistent USB-images. Since our manjaro-tools are not able to produce them, we looked for a different way. We found ALMA, which we modified to our needs. With it it is easy to create your personal persistent USB-images. Simply install alma-git from our unstable branch and checkout our presets.

pamac install alma-git

You may also follow our video tutorials:

Or simply download our USB-Image and flash it with Etcher. Username is manjaro, Password is manjaro.

direct | sig | sha1


Yes! I'm going to give this a try ASAP. Thanks so much for this!

After burning the USB-Image to a stick with Etcher, I'm able to boot into XFCE, but I find that the user manjaro is not in the sudoers file, and I get and "Authentication error" when attempting to switch to root. I searched for a way to fix this but have hit a wall so far.

Thanks from Brazil!

I just flashed to my USB KingDian Portable SSD and tried on my notebook.

First, I changed to use mirrors from Brazil and cannot get the kernel update. So I reflashed and not touch the mirrors.

Second, I tried to change the keyboard to Brazilian ABNT2 and it not worked.

Again, thanks so much for provide this alternative to use Manjaro!

Also, pulseaudio is not connecting at boot.

I switched with ctrl+alt+f1 to a different login (guessed around and root/manjaro worked). Fixed the sudo and other things from there.



In 2019 I built a persistent installation on an usb stick with your manjaro kde image flashed on an usb stick, the persistent usb is working well, I don't forget the update.
I only boot this persistent usb without any other os, disc.

Some issues may happen as we are on an early stage here. Fixes will be shared as we go along.


I'm pretty new with Manjaro xfce (2018) and to be honest I have had to mess much less with it than getting Mint xfce working to my liking. I tried this persistent USB and I had the issue with pulse audio not being able to access the server. The notifications area in the panel, I was not able to implement as it isn't intuitive to me which package would need to be installed as there is no hint in the panel add items area. I had guessed maybe xfce-goodies or something similar but was unable to find what was needed. To get the Trash icon on my desktop the gvfs install hint worked and after a reboot the Trash icon was on my desktop. I would have liked to add myself as administrator. No hardware was detected in Hardware Configuration. I changed kernel to 5.7.xx but that didn't fix the audio issue (feeble newbie attempt). Overall nice job. I am sure you guys will get this fixed up nicely soon. Thanks.

Nice, now I can test Manjaro on my MacBook Pro 13" (without touchbar) 2017, without erasing the drive :slightly_smiling_face: :tada:

I've had good luck configuring my new persistent stick, although I do have a lingering issue with a missing network icon on the panel. I understand that "notification area" should be added to the panel in order to show the network applet, but the "notification area" choice is grayed-out in the panel addon utility. Any ideas on how to get this going, so that I can access a wifi connection?

Don't know about the "notification area" but you can create the wifi network connection via nmcli. See examples here.

1 Like

We still have to add more packages to the profile to make it fully working. more or less it is an early example.

1 Like

It is a lot of hustle to get it to work on a mac :joy:

Hi @philm,

I tried it today and it works fine so far. But there are two important things missing in the *.toml files:

  1. package network-manager-applet to configure wireless network
  2. the "wheel" settings in the sudoers file. Without that you can not enter a root shell. I solved it by adding:
script = """
set -eux
echo "%wheel ALL=(ALL) ALL" > /etc/sudoers.d/99_wheel

Thanks a lot, I always wanted to install Manjaro on a USB stick. :slight_smile:

But I have a problem. Yesterday I installed Manjaro XFCE Minimal and wanted to test ALMA.

I ran that command:

sudo alma create --image 15GiB almatest.img

Unfortunately, after a while I get this error message every time:

Generating locales...
  en_US.UTF-8... done
Generation complete.
 2020-07-08T08:28:44.038Z INFO  alma                       > Generating initramfs
/usr/bin/mkinitcpio: line 265: /etc/mkinitcpio.d/linux.preset: No such file or directory
==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linux.preset'
 2020-07-08T08:28:44.443Z INFO  alma::storage::loop_device > Detaching loop device /dev/loop0
Error: Failed to run mkinitcpio - do you have the base and linux packages installed?

Caused by:
    Bad exit code: exit code: 1

I've already installed the basepackage. I have also looked for help online and reconfigured mkinitcpio, unfortunately without success.

I would really appreciate some help. Thanks in advance. :slight_smile:

Maybe you mixed up the alma from the AUR and the alma from @philm. You need to checkout alma git repo by @philm, build it and run this alma.

Thanks for the answer. I used the command pamac install alma-git and installed it from the aur.

Our package is only in testing and unstable branch. Get it from here:

pamac install


I will try. Thank you. :slight_smile:

Forum kindly sponsored by