Manjaro xfce and VNC on Raspberry Pi 4

Anybody have a working solution?

I tried TigerVNC and can get to having the VNC Server respond to requests but then I just get a black screen and an error about not connecting to configuration server.

Hi,

Some links here, look the second post with tigervnc.

I was overthinking it and figured it had failed due to errors in the logfile. Turns out they were not the problem.

dbus-launch /usr/bin/startxfce4 & in xstartup did the trick along with specifying the port (5901) in the tigerVNC client

OK, so now I have it working in what the TigerVNC arch wiki entry says is user mode and I get an xfce desktop and it appears to work except for some permissions errors that prevent some stuff from working such as adding apps or editing configuration.

I disabled user mode and tried the next step which is multi-user mode following the wiki and when I connect I now just get a window with a black screen instead of the desktop.

Any ideas?

Found it. Needed to follow the XDMCP setup for lightdm.

Short version in /etc/lightdm/lightdm.conf
[XDMCPServer]
enabled=true
port=177

if truely headless do this (no local screen started or needed)
[LightDM]
start-default-seat=false

then restart lightdm
systemctl restart lightdm

So here is the summary of how to get TigerVNC to work like RealVNC on Raspberry Pi OS

//ssh into RPi
ssh @

//install TigerVNC
sudo pacman -S tigervnc

//configure XDMCP - Modify /etc/lightdm/lightdm.conf
sudo nano /etc/lightdm/lightdm.conf

#in [LightDM] section
#uncomment and set start-default-seat=false

#in [XDMCPServer] section
#uncomment and set enabled=true
#uncomment port=177

//restart lightdm
sudo systemctl restart lightdm

//create /etc/systemd/system/tigervnc.socket
sudo nano /etc/systemd/system/tigervnc.socket

#paste in
[Unit]
Description=TigerVNC Server

[Socket]
ListenStream=5900
Accept=yes

[Install]
WantedBy=sockets.target

//create /etc/systemd/system/tigervnc@.service
sudo nano /etc/systemd/system/tigervnc@.service

#paste in
[Unit]
Description=TigerVNC Per-Connection Daemon

[Service]
ExecStart=-/usr/bin/Xvnc -inetd -query localhost -geometry 1440x900 -once -SecurityTypes=None
User=nobody
StandardInput=socket
StandardError=syslog

//use systemctl to start and enable
sudo systemctl start tigervnc.socket
sudo systemctl enable tigervnc.socket

//reboot
sudo reboot

This topic was automatically closed 89 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by