Manjaro Xfce - Building from AUR using "Add/remove" (package-manager) doesn't work from shortcut unless terminal

So - all day I have realised I cannot build using the pamac GUI - I can use pacman -S comfortably but ideally I am lazy.

When I launch pamac-manager via the shortcut in the Whisker menu:

*Could only have 1 image so removed this - but the Whisker menu "Add/remove programs" button is what I mean :slight_smile: *

I cannot "Build" anything from AUR: Regardless of the package if it is from AUR I get the following errors:

Screenshot_2020-02-27_23-56-13

This is really frustrating as I use ULauncher (and this same shortcut) to open "Add/remove programs"

Things to note >

  • I have tried reinstalling pamac by uninstalling and then sudo pacman -S pamac-gtk pamac-commons etc.

  • I CAN use pamac-manager from terminal if sudo (that is if I call the shortcut from any directory I can install as usual - however the build is in that directory)

  • I CAN install packages using just pacman as usual.

I am confident this is a permissions problem somewhere given the mkdir is failing oddly, however when I run the same shortcut from terminal I am ok. I believe this shortcut runs package-manager and not sudo package-manager - however I haven't changed anything, how/where in linux can I change the script for a built-in command to run as root? and is this not unsafe practice to build from AUR as root?

Please someone help - I just wish to be able to use the Pacman Gui shortcut from the Whisker menu. Instead of manually installing everything in future :cry:

I have git globally, and gtk-2, and gtk-3, and alpm.

Pamac AUR build location is /var/tmp as it has been since I started my linux journey (on Monday)

Here is the result of pacman -Qqs pamac

image

Do you have the base-devel group installed? See the Arch wiki:

sudo pacman -Syu --needed base-devel

Also, please paste terminal output as preformatted text (the </> button), not images.

Ok, I went into MenuLibre to see how the commands working - it looks like there is 2 "Add/Remove Software" buttons - 1 is home/<user>/.local/share/applications/pamac-manager.desktop
the other is home/<user>/.local/share/applications/org.manjaro.pamac.manager.desktop

The former was set to "Hide" and the latter to "Show" - after switching these around (so the pamac-manager.desktop is showing in the menu) my problem is solved.

I don't really understand why there's 2 and the difference between them both - if someone would care to explain please do, I will open both files now and see what I can learn. (I was supposed to be asleep 2 hours ago - linux is fun but really plays rough with life cries)

fix

Pamac installed /usr/share/applications/org.manjaro.pamac.manager.desktop, you shouldn't have one in ~/.local/share/applications/.

Thank you so much for the reply - sorry, i've been working on some very graphics based stuff with my team on GitHub so in the habit of screenshotting current state for issues lol

I already am loving this community and thank you for the advice so quickly :slight_smile:

sudo pacman -Syu --needed base-devel output is:

:: Starting full system upgrade... there is nothing to do

Sorry, can you explain what you mean by this? Pamac came with the distro hence I can't see where both files came from and are causing problems - I also don't see why they're in ~/.local/share/applications/

Are you sure you ran that command exactly? There should have been more output. It either would have installed what was missing from the base-devel group or warned you that the packages were up to date and skipped them.

There was all up-to-date messages followed by continous warnings and that was the final message - sorry, I thought the full output is too long

Good, that's what should have happened. What's the output of:

pamac build shutter

A bunch of checking interconflicts followed by -

`To build (7):
gnome-perl 1.045-8 AUR
perl-gnome2-wnck 0.16-17 AUR
perl-gtk2-imageview 0.05-10 AUR
perl-gtk2-unique 0.05-24 AUR
perl-cpanel-json-xs 4.18-1 AUR
perl-json-maybexs 1.004000-1 AUR
shutter 0.94.3-1 AUR

Edit build files ? [y/N] `

/usr/share/ is a system directory, ~/.local/share/ is user directory. Packages do not touch user directories. Perhaps you copied the desktop file there?

I can see they both exist in /usr/share also - I have not made any mv commands besides moving a java jdk from Downloads -> jvm

Do you suggest I change their paths in MenuLibre?

Answer n (<--- one backtick on either side of the lettter) and see if it builds. FYI, it's three backticks, not one for a block of code. :wink:

No, just delete the one in ~/.local/share/applications. Anything you put there overrides what's in /usr/share/applications/. Sometimes that can be useful if you want to change something, however.

1 Like

Ok well it also contains Plank.desktop and my chrome-aapocclcgogkmnckokdopfmhonfmgoek-Default.desktop

I take it I should remove these also - or are these in local due to my current session?

No, those should be fine. I'm not sure about Plank since I don't use it. If it ain't broke, don't fix it. :wink:

The Chrome shortcut is normal, that's where they're placed when a shortcut is created in Chrome by the user or perhaps an Extension.

Thanks so much, I don't understand how this is working tbh I imagine its all session related... I deleted them but once I opened pamac GUI and closed again -> then checked MenuLibre and once again the paths changed to ~/.local/applications

Except now there is no problem? It looks like whenever you delete them they come back upon execution of pamac-manager on that note I will head to sleep - thank you internet stranger :slight_smile: :blue_heart:

MenuLibre can do weird things, it could be doing it. Good night! :night_with_stars:

1 Like

I removed the self solve as has nothing to do with the issue described in the first comment. This seems another XY Problem kind of topic.

Forum kindly sponsored by