Manjaro XFCE doesn't boot after update


My fresh installation of Manjaro XFCE (PI 4) stopped booting after first update (before that it booted without problems). In the beginning I thought that the image was corrupted but I performed the fresh install and it happened again. Also when I tried to log out only I saw the black screen.

During boot it stops in this moment:


What should I do now?

Could be a kernel issue.
I updated the kernel in the repo recently.

Try doing a fresh install and update everything but the kernel. Like:
sudo pacman -Syu --ignore linux-rpi4

Unfortunately, it doesn't work.

So you updated everything, except the kernel and it still does not boot?

That means it's not a kernel fault.

Can you login to TTY then?

No, after log in, same things are showing up.

BTW. Yesterday I tried KDE version and after updates there weren’t any problems.

So you get to the login screen, and login with your password, and it just shows this?

What if you press CTRL+ALT+F3?

With this key combination I was able to enter the tty.

Can you give me the output of:
systemctl status lightdm

journalctl -xe

image image image

But immediately after that it showed again brcmfmac: power management disabled


Can you try running:
sudo systemctl start lightdm

And then again (assuming it fails) check
journalctl -xe

There are more than 6000 lines so I included only last part. image image


Seems like an Xorg dump.

Okay so what do you suggest me to do now?

The problem is resolved in this thread. You need to downgrade mesa or install the updated mesa-git.


Thanks, I’ll try it tomorrow.

Same problems to me after update

Do what @kayhan1996 linked this thread.

1 Like

I have the same issue.

Forum kindly sponsored by