Manjaro XFCE Theme not being used on XFCE Logout Prompt

Hey, so my theme is not being used for 1 specific window and thats the window that shows up when you click the logout button, how could I go about fixing this, the only thing I know is, what triggers this is disabling xfwm4 in the session, save the session (im doing this to use bspwm)


1 Like

I had a look at the first post you mentioned before and I tried one of the combinations of settings/session package that were supposed to work for me, unfortunately as I mentioned it did theme the logout prompt, but as soon as I disable xfwm4 on the sessions and save it (in order to run bspwm) it stops working. About the second post, I guess I can post my inxi if that helps:

System:    Host: bsantos-pc Kernel: 4.19.60-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: Xfce 4.13.5git-645f19 
           tk: Gtk 3.24.10 info: xfce4-panel wm: bspwm 0.9.7-2-g342c2e3 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X510UNR v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X510UNR v: 1.0 serial: <filter> UEFI: American Megatrends v: X510UNR.307 date: 03/13/2018 
Battery:   ID-1: BAT0 charge: 37.1 Wh condition: 38.7/42.1 Wh (92%) volts: 11.5/11.5 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Not charging cycles: 56 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A bus ID: 01:00.0 chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.5 driver: intel compositor: compton resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.1.3 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.19.60-1-MANJARO 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 chip ID: 8086:24fd 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 29.15 GiB (12.2%) 
           ID-1: /dev/sda vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> rev: A020 
           scheme: GPT 
Partition: ID-1: / size: 95.62 GiB used: 29.12 GiB (30.5%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 229 Uptime: N/A Memory: 15.55 GiB used: 664.7 MiB (4.2%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: zsh v: 5.7.1 running in: terminator inxi: 3.0.35
1 Like

Sorry, I am not helpful in bspwm, maybe @Chrysostomus could help.

Maybe try setting the theme with both lxappearance and xfce settings? I'm guessing you are running xfce session and replacing xfwm with bspwm? So the theme should be set by xfsettingsd, but for some reason it is not?

1 Like

Exactly, but the only window with the theme not applied is the Logout Propmpt referenced in the other post.

Edit: Tried applying the theme in both lx and xfce settings and still unthemed.

Yeh I've done that already. and as I said, before I change to bspwm (disabling xfwm4 in the session) the logout prompt is themed, as soon as I change it, it gets unthemed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by