Mate: Alt-Space behaviour


i hope this is no duplicate, didn't find the topic anywhere.

So the default keybinding alt-space was the windows context/system menu since the early days.

As of mate 1.24(?), there is a new feature which opens a search box on top on top of the screen. I'd like to disable that (i'm using alt-f2), because it disables the window menu, and i'm really used to press i.E Alt-Space, x to make Windows Fullscreen.

Does anybody know how this new component is named, and if it is possible to rebind or disable it? I can't find it in the process list or in the mate keybinding settings.


It's called "Run Application", and you can rebind it.

However I use mate 1.24 and both keybindings work as expected here. Alt + Space even works on the run application dialog box.

The keyboard shortcuts are:

'Show the panel "Run Application" dialogue box'
'Activate the window menu'

Disabling the keybinding would only stop you from using it, it's part of mate-panel. Also why would run application disable anything?

Sounds more like the window menu keybinding is wrong, or maybe it's something else.

Thanks for your answer. The run application box is this, right?

I should have posted this screenshot i made, the new feature i meant is this box, at the top of the screen:

Sorry for being unclear. So the old run application dialogue works just fine (bound to alt-f2 for me). And even the window menu works in the run application dialoge. Both are rebindable.

The new box (bound to alt-space by default) overwrites my alt-space window menu.

Oh, and sorry for the http

Ah, it all makes sense now. :grin:

That looks like krunner, have you got KDE installed?

Here's an image of krunner from a KDE install:


I may be wrong, it might just look a little like it. Also it's normally bound to Alt + F2.

Haven't found any reference to this in mate's docs.

Oops forgot to ask, can you run xprop on it? If so what does it give for WM_CLASS and WM_NAME?

Oh, that explains it. Yes, the newest kde is also installed on that machine, something starts krunner on the mate sesssion, at least the process is running.

Thanks for the hint, i'll have a look how to remove it from the mate session. No idea why it gets started tho.

I never would have identified it, thanks :smiley:

oh and xprop sais

_NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0x4a00028
		window state: Normal
		icon window: 0x0
_KDE_NET_WM_SHADOW(CARDINAL) = 77594655, 77594656, 77594657, 77594658, 77594659, 77594660, 77594661, 77594662, 1, 6, 6, 6
_KDE_SLIDE(_KDE_SLIDE) = 0x0, 0x1
_KDE_NET_WM_BACKGROUND_CONTRAST_REGION(_KDE_NET_WM_BACKGROUND_CONTRAST_REGION) = 0x0, 0x0, 0x1de, 0x27, 0x1, 0x27, 0x1dc, 0x1, 0x3dfe2535, 0xbc430fb5, 0xbc430fb5, 0x0, 0xbd240cba, 0x3dc480cf, 0xbd240cba, 0x0, 0xbb847cd3, 0xbb847cd3, 0x3e071faf, 0x0, 0x3e23d70b, 0x3e23d70b, 0x3e23d70b, 0x3f800000
_KDE_NET_WM_BLUR_BEHIND_REGION(CARDINAL) = 0, 0, 478, 39, 1, 39, 476, 1
XdndAware(ATOM) = BITMAP
_NET_WM_NAME(UTF8_STRING) = "KRunner — krunner"
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x2, 0x1, 0x0, 0x0, 0x0
WM_CLIENT_LEADER(WINDOW): window id # 0x4a00015
		Client accepts input or input focus: True
		window id # of group leader: 0x4a00015
WM_CLASS(STRING) = "krunner", "krunner"
		user specified location: 721, 24
		user specified size: 478 by 40
		program specified minimum size: 478 by 40
		program specified maximum size: 478 by 40
		window gravity: Static

So yes, your guess was right

You're welcome. :slight_smile:

Are you using the same user for both mate and kde? It's generally best to use separate users so that settings don't conflict.

Yes, i'm a s*cker for desktop environments, i have a look at different ones every few months, even if i use mate and i3 for my daily work.

But yes, using another user to test kde etc. seems a really good idea. Especially with the behaviour of Gome/Mate to launch everything once running forever in it's session :slight_smile:

Yep a user for each DE, especially for kde and gnome. :slight_smile:

I've pretty much always used mate (and before that gnome2) but every now and again I'll try out a few of the others and then go back to mate. I've never quite gotten used to tiling window managers.

I sometimes fire up xfce on a tty under a different user, mate and xfce can run alongside each other like that, kde crashed when I tried it*. I should try that with a tiling wm.

*I may have been lazy and used the xfce user, also 3 full DEs plus a game running in another tty, may be pushing it a bit.

Forum kindly sponsored by