MediathekView yaourt

Hallo zusammen,
ich wollte gerne MediTHEKvIEW INSTALLIEBN und habe diese Anleitung gefunden:

$ sudo pacman -S vlc ffmpeg
$ yaourt -S mediathek flvstreamer

Bei yaourt -S mediathek flvstreamer kommt diese Meldung:

yaourt -S mediathek flvstreamer
bash: yaourt: Kommando nicht gefunden.

Ich konnte yaourt leider auch nicht installieren, kann mir hier bitte einer helfen??

Try:

pamac build mediathek flvstreamer
3 Likes

Und das ist auch gut so yaourt wird seit lĂ€ngerem nicht mehr weiter entwickelt und sollte nicht mehr verwendet werden. Es wurde schon lange aus den Repos genommen. Es gibt genĂŒgend andere AUR-Helfer: https://wiki.archlinux.de/title/AUR_Hilfsprogramme oder man verwendet pamac der bereits installiert sein sollte.
Außerdem sollte man wissen was das AUR ist, wenn man es verwendet: https://wiki.archlinux.de/title/Arch_User_Repository und die Sicherheitshinweise beachten: https://wiki.archlinux.de/title/AUR_Sicherheitshinweise

Mit pamac geht das einfach so:

pamac build mediathek flvstreamer

Da war wohl einer schneller. @dalto I just explained that yaourt is unmaintainend and was removed from the repos and referred to general Information about the AUR and the German best practices for the AUR in the German sections of the AUR

3 Likes

Hallo und Danke fĂŒr die schnelle Hilfe und die passenden Linkis zum Thema.

Ich habe mit ```
pamac build mediathek flvstreamer
das Tool installiert:
In der Konsole bekomme ich nach der Eingabe:

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: mediathek/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:757)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
at java.lang.ClassLoader.loadClass(ClassLoader.java:352)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)

Habe ich eine alte oder fehlerhafte Java Version?

Möglich.

$ archlinux-java status
$ archlinux-java set ...

Siehe auch: https://wiki.archlinux.de/title/Java

1 Like

Ich hatte vor lÀngerer Zeit ebenfalls ein Problem mit diesem Programm. Aber es geht auch ohne Installation:
https://mediathekviewweb.de/

Könntest du mal versuchen es mit yay zu installieren?

sudo pacman -S yay
yay mediathek

Jupp. FĂŒr gelegentliche Nutzung sicherlich einfacher, da fehlen mir allerdings die Abos.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by