megasync is core dumping

Hello,

The megasync tool used to work flawlessly but now I notice it's not starting. Launching from the command line shows:

$ megasync 
Setting QT_SCREEN_SCALE_FACTORS= "eDP1=1"
Segmentation fault (core dumped)

Maybe it's a linking issue because now the dynamic library which the binary was linked has changed.

The fact is I've downloaded the last version from MEGA.nz site and installed using

$ sudo pacman -U https://mega.nz/linux/MEGAsync/Arch_Extra/x86_64/megasync-4.3.1-1-x86_64.pkg.tar.xz
 megasync-4.3.1-1-x86_64                                  12,6 MiB  3,67 MiB/s 00:03 [################################################] 100%
 megasync-4.3.1-1-x86_64.sig                             181,0   B  0,00   B/s 00:00 [################################################] 100%
loading packages...
resolving dependencies...
error: could not open file /var/lib/pacman/local/linux56-rt-5.6.10_rt5-1/desc: No such file or directory
looking for conflicting packages...

Packages (2) qt5-tools-5.14.2-2  megasync-4.3.1-1

Total Installed Size:  56,81 MiB

:: Proceed with installation? [Y/n] 
(2/2) checking keys in keyring                                                       [################################################] 100%
(1/2) checking package integrity                                                     [################################################] 100%
(1/2) loading package files                                                          [################################################] 100%
(2/2) checking for file conflicts                                                    [################################################] 100%
(2/2) checking available disk space                                                  [################################################] 100%
:: Processing package changes...
(1/2) installing qt5-tools                                                           [################################################] 100%
Optional dependencies for qt5-tools
    clang: for qdoc [installed]
    qt5-webkit: for Qt Assistant
(2/2) installing megasync                                                            [################################################] 100%
==> Updating trust database...
gpg: next trustdb check due at 2020-05-31
  -> Locally signing key 8F208FBF12FEE766AA32AEAF03C3AD3A7F068E5D...
==> Updating trust database...
gpg: next trustdb check due at 2020-05-31
fs.inotify.max_user_watches = 524288
Optional dependencies for megasync
    sni-qt: fix systray issue on KDE and LXQt,
    nautilus-megasync: for integration with nautilus
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating icon theme caches...
(3/3) Updating the desktop file MIME type cache...
$

Anyone here can run megasync with ease? Maybe I should install some backward compatible libraries?

$ ld /usr/bin/megasync
ld: warning: cannot find entry symbol _start; not setting start address

$ file /usr/bin/megasync
/usr/bin/megasync: ELF 64-bit LSB pie executable, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, BuildID[sha1]=bf0ddb33baa26415707ac887d575e5a49f3d0fd5, for GNU/Linux 3.2.0, stripped

Regards,

Gabriel

This is an issue you should fix

You have tagged your topic with #deepin so just a reminder as Deepin is unsupported.

I would advise against changing system libraries - it will only worsen your situation.

No problems

➜  ~ pacman-mirrors -G
unstable
➜  ~ inxi -Sxxxxz --no-host
System:
  Kernel: 5.6.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  Desktop: Openbox 3.6.1 info: polybar, tint2 dm: LXDM Distro: Manjaro Linux 

Which branch is your system set to?

pacman-mirrors -G
2 Likes

Yes, I know. It used to be a lovely Desktop Environment. Now it has turned into an ungly one after the v20 redesign. The fact is my disk is too small to get another WM/DE and still need the computer on a daily basis so re-installing isn't planned in a short term.

As a matter of fact, any suggestion would be welcome... LXqt is nice but still not as pretty as Deeping used to be...

$ pacman-mirrors -G
stable

$ inxi -Sxxxxz --no-host
System:    Kernel: 5.4.40-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Deepin 20 tk: Qt 5.14.2 info: dde-dock 
           wm: DeepinWM dm: LightDM 1.30.0 Distro: Manjaro Linux 

Regards,

You're right. I don't know what's that. BTW, in my /boot partition there are still 5.6-rt images but the package isn't installed

$ ls /boot/ |grep rt
initramfs-5.6-rt-x86_64-fallback.img
initramfs-5.6-rt-x86_64.img

Regards.

Megasync works fine on my side.

What is your side? :slightly_smiling_face:
libQT version maybe?

I mean on my Manjaro Plasma, testing branch

$ megasync
Not setting scale factors. Using predefined QT_SCREEN_SCALE_FACTORS= eDP-1=1;HDMI-1=1;DP-1=1;HDMI-2=1;

Qt 15.4.2

My qt-base package is 5.14.2-2.

I don't use Plasma and my Manjaro is on the stable branch.
How did you query your qt version?

Well I just looked in KInfoCentre, on installations other than Plasma one can look at packages in pacman database, for instance, pacman -Qi qt5-base.

Setting the correct environment variable got it finally to work. It was a QT thing and a Deepin 20 issue.

The solution was posted on Reddit and then I made my own CLI launcher (just the export and the binary invocation... rocket science :smile:).

There is a github issue open for this as well https://github.com/meganz/MEGAsync/issues/443
although it seems its more a qt5integration issue with the last push?

you can use "downgrade deepin-qt5integration" and downgrade to 5.1.0.1-1 and megasync will work again, however the deepin theme will be messed up, hence they pushed the 5.1.0.1-2 to fix the theme issues.

Hello.
Thanks for the link.
As you say, downgrading the qt5 deepin integration wouldn't be a good idea.

As I posted here the solition came in form of setting an environment variable.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by