Megasync not run

Hello friends:
I have installed Megasync since months ago. In this time Megasync run normally, but now, when I try to run in terminal say this:

"megasync: error while loading shared libraries: libraw.so.20: cannot open shared object file: No such file or directory"

Any solution, please? Thanks!

1 Like

First of all, how you installed MegaSync? via aur?

1 Like

Is libraw installed?

Sometimes after an update, it's worth just checking and installing again...
pamac install megasync
Then report back :wink:

If it's aur package, then you must check depedencies. Because Manjaro Stable is some packages version behind than Arch which actually PKGBUILD based on!

No, it's fine - I just installed and removed it myself :wink:

~ >>> pamac install megasync                                                                                                 
Preparing...
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: ben
Password: 
==== AUTHENTICATION COMPLETE ====
Synchronizing package databases...
Refreshing chaotic-aur.db...                                                                                                  
Warning: nutty-git: local (172.56f5996-1) is newer than chaotic-aur (1.1.1.r42.gfa9ad5b-1)                                    
Resolving dependencies...
Checking inter-conflicts...
To install (1):
  megasync  4.3.1.0-2    chaotic-aur  7.6 MB

Total download size: 7.6 MB
Total installed size: 14.0 MB
Apply transaction ? [y/N] y
Download of megasync (4.3.1.0-2) started                                                                                      
Download of megasync (4.3.1.0-2) finished                                                                                     
Checking keyring...                                                                                                      [1/1]
Checking integrity...                                                                                                    [1/1]
Loading package files...                                                                                                 [1/1]
Checking file conflicts...                                                                                               [1/1]
Checking available disc space...                                                                                         [1/1]
Installing megasync (4.3.1.0-2)...                                                                                       [1/1]
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                                                                           [1/3]
Updating icon theme caches...                                                                                            [2/3]
Updating the desktop file MIME type cache...                                                                             [3/3]
Transaction successfully finished.
~ >>>  
2 Likes

Hi, via megasync web launcher

Yes, and also libraw1394

I try before, but not run

I'm sorry, but terminal return me the same error

find /usr -name "libraw.*" 2> /dev/null

What does the above return?

Sorry, but have been reviewing the dependencies of LibRaw and seems that the version of LibRaw is to update at the version 0.20 (https://www.libraw.org/), therefore it requests me the archive "libraw.so.20": it is this possible?

sudo pacman -U https://www.mirrorservice.org/sites/repo.manjaro.org/repos/unstable/extra/x86_64/libraw-0.20.0-1-x86_64.pkg.tar.zst

Should do it.

3 Likes

Ohhhh yes! Now it's runing!!! Thanks!!

It works. But why is it needed? Why pacman allowed the megasync update if its dependencies where not fulfilled. Does not look reliable.
This time is megasync but some other time might be a critical component of the system.

:man_shrugging:

Your observation is quite correct.

~ >>> sudo pacman -Q megasync                                                                           [1]
error: package 'megasync' was not found

Why would pacman allow the megasync update when megasync isn't available?
Surely you'd need to get it from AUR or some other non-official source, right?

Thanks!!!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by