Messed up MBR and Dual Boot

I'm fairly new to Linux overall, but decided to try out some gaming to get the feel for it over time. I planned to install Manjaro on its own drive as I have 5 and am not currently using one of them. I wanted to use the bootloader for dualboot and make it easier on myself, I went through the instillation of Manjaro to my drive and when I got to where to put the MBR I selected my SSD because that's my main drive for Windows 10 and what I want it to boot from thinking it would write the MBR with the bootloader and id restart to grub. When I did restart I was greeted with >grub recovery, so I started doing more research to try and fix it myself, went through about 12 forum posts trying to find someone else who was doing dualboot across at least 2 drives each dedicated to an OS to no avail so I started taking bits and pieces from each to try and solve my problem. Now all I can do it boot into the Live install on my USB, can't even get into windows anymore and I'm hoping to atleast be able to recover my old MBR to boot into windows.

Restore the GRUB Bootloader

okay so going through that, I get to step 2 and It appears I don't actually have Manjaro installed? I don't know, the only thing that is bootable is my system reserved from a 3rd drive. Am I even trying to do the dualboot correctly? Should I just stick it on the same drive as my Manjaro instal and call it a day or is this possible and I'm just stupid?

This may be easier. Definitely safer.
[Simple First Start] should do.
oh..if unsure where your primary drive is, do all
sudo grub-install /dev/sda
sudo grub-install /dev/sdb
sudo grub-install /dev/sdc
Don't worry, it wont kill your mouse.

I do that and I get "grub-installer: error: failed to get canonical path of 'overlay'"

okay so im stupid, doing the simple first start instead of just doing the commands you put in the response, it says /etc/manjaro-release is not a device after doing grub> search.file /etc/manjaro-release root

You booted into the livecd OS.
Read again. Do not boot into livecd OS but at grub menu, press 'c'.

If you this command (without the 'root')

grub> search.file /etc/manjaro-release

Do you get any output?
If you do not, then your installation (the OS, not just grub) is not complete.

I get error: no such device: /etc/manjaro-release. So I should reinstall manjaro right? If so how can I do this properly so this doesn't happen again. Is it even possible to have the bootloader do dualboot across multiple disks?

Yes, it is possible. Just more simple with a single disk.

i kind of gave up on it and am hoping that if I do an in place install or run the repair from the windows media creation tool it will fix my problem. I did get manjaro running finally without the live CD but I still can't get grub to find my windows 10 install, other than that I think it all worked but I don't know how to get it to see the Win X install

Tried 'sudo update-grub' ?
If done and not worked, print from manjaro terminal

sudo parted -l

small 'L', not 'one',
all output, all disks, do not omit or truncate.

sudo update-grub works, it finds 4 images but none of them are Win X

[ceilingspy@CEILINGSPYPC ~]$ sudo parted -l
Model: ATA WDC WD2500BPVT-2 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 250GB 250GB ext4

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 250GB 250GB primary ntfs
2 250GB 250GB 489MB primary ntfs diag

Model: ATA WDC WD10EZEX-00B (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 577MB 576MB primary ntfs boot
2 577MB 1000GB 1000GB primary ntfs

Model: ATA ST2000DM006-2DM1 (scsi)
Disk /dev/sdd: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 2000GB 2000GB primary ntfs

[ceilingspy@CEILINGSPYPC ~]$

Can you see your windows installation on that disk where you had it?
Open file manager mount the right partition and look if you even have the windows there

its there for sure, i can see all of the files

Okay, your windows is in msdos/bios-legacy
Your manjaro in gpt/uefi
Won't work.

If you want to boot windows and not want to reinstall manjaro in msdos/bios-legacy
go to boot setup key (F8 ~ F12) and choose the device drive that windows is in without the UEFI prefix and boot windows.

4 images? what's that?
print out 'sudo os-prober' (easier and shorter to see).

no output

Okay, what 4 images?

[CEILINGSPYPC ceilingspy]# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
[CEILINGSPYPC ceilingspy]#

Okay. Fine. Got it.
Alright, you try to boot windows the F~something way or you can reinstall manjaro in msdos/bios-legacy. Up to you.

do not mix uefi and bios-legacy
do not mix gpt and msdos (OS disks - even with data disks with no problem, why mix? why indeed.)

Forum kindly sponsored by