Mhwd-chroot - I must be doing something wrong?

Following up from my earlier problem. I couldn't chroot into my system.

  • Tried manjaro-chroot - not longer exists?

  • Quick search - tried mhwd-chroot:

sudo lsblk                                                            
[sudo] password for steve: 
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0   1.8T  0 disk 
|-sda1   8:1    0   512M  0 part 
`-sda2   8:2    0   1.8T  0 part 
sdb      8:16   0 232.9G  0 disk 
|-sdb1   8:17   0   512M  0 part 
`-sdb2   8:18   0 232.4G  0 part /mnt
sdc      8:32   1  57.3G  0 disk 
|-sdc1   8:33   1   512M  0 part 
`-sdc2   8:34   1  56.8G  0 part /
sudo mount -o subvol=@ /dev/sdb2 /mnt 
sudo mhwd-chroot /mnt /bin/bash

Opens a new terminal with the message no linux system found then closes.

My main system is on a 250gb SSD (sdb) and is btrfs, currently logged in to a 64gb USB "recovery" thumb drive (a full ext4 install).

Now I haven't needed to use a chroot for ages - What am I doing wrong?

What are you doing lurking about in the noob section? :exploding_head:

The last couple of chroots i did were via this method, which worked fabbo for me... Tutorial: How to magically fix most computers that will not boot after a manjaro update!

1 Like

Well I thought it would be more useful here :smiley:

~ >>> sudo mount /dev/sdb2 /mnt                                             
~ >>> sudo mount /dev/sdb2 /mnt/@                                           
~ >>> sudo mhwd-chroot                                                      
konsole --separate -e mhwd-chroot-shell

Same problem, no linux system found :frowning:

Back on my SSD - sudo mhwd-chroot -a takes me into a chroot of my USB :confused:

I have never had a problem before.

I've always used manjaro-chroot, not mhwd-chroot, FWIW.

I don't use the -a option, just pass it a mounted root file system.

Used manjaro-chroot to fix the unstable issue with double-conversion a few hours ago, so I can confirm it works!

1 Like

I am still around, having a kitchen fitted and the power keeps getting turned off by the electrician

this is

manjaro-chroot -a

@stephane - I am using btrfs not ext4, I need to specify the @subvol that holds the root partition.

So no ideas? If I bork my system I have no way of recovering it? :roll_eyes:

OK to add to the mystery, arch-chroot works out of the box:
image

On my system manjaro-chroot still works with btrfs from live system.
Tried it 10 minutes ago.

For bad times, here the procedure for a 0815 chroot.

mount -o subvol=@ /dev/nvme0n1p2 /mnt
mount /dev/nvme0n1p1 /mnt/boot
# additional btrfs mounts
mount -o subvol=@pkg /dev/nvme0n1p2 /mnt/var/cache/pacman/pkg
mount -o subvol=@log /dev/nvme0n1p2 /mnt/var/log
mount -o subvol=@snapshots /dev/nvme0n1p2 /mnt/.snapshots
# default chroot
mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
mount -t devpts pts /mnt/dev/pts/
chroot /mnt /bin/bash
1 Like

As I said - weird, was working.

I tried copying manjaro-chroot across but could not get it to work.

Have bookmarked this to try later....

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by