MHWD only Shows Auto install Open Source Drivers

Hi All,

I've installed the Ryzen+Nvidia Driver on Asus Tuf A15 FA506IV with guide by swagglepuf but in MHWD it only shows install open source drivers how do you enable the proprietary section to show up ?

System:    Host: ahmad-tufgamingfa506iv Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           Desktop: KDE Plasma 5.18.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FA506IV_FA506IV v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FA506IV v: 1.0 serial: <filter> UEFI: American Megatrends v: FA506IV.304 date: 03/24/2020 
Battery:   ID-1: BAT1 charge: 38.0 Wh condition: 45.7/48.1 Wh (95%) model: ASUS A32-K55 status: Discharging 
CPU:       Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92661 
           Speed: 1397 MHz min/max: 1400/2900 MHz Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1396 5: 1397 6: 1372 7: 1353 
           8: 1328 9: 1397 10: 1397 11: 1397 12: 1396 13: 1397 14: 1397 15: 1397 16: 1397 
Graphics:  Device-1: NVIDIA vendor: ASUSTeK driver: nvidia v: 440.82 bus ID: 01:00.0 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 06:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,nvidia resolution: 1920x1080~144Hz 
           OpenGL: renderer: AMD RENOIR (DRM 3.36.0 5.6.16-1-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-2: Advanced Micro Devices [AMD/ATI] vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 06:00.1 
           Device-3: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A bus ID: 06:00.5 
           Device-4: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 06:00.6 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave driver: rtw_pci v: N/A 
           port: d000 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 2.73 TiB used: 977.26 GiB (35.0%) 
           ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M81000G size: 931.51 GiB 
           ID-2: /dev/nvme1n1 vendor: Intel model: SSDPEKNW010T8 size: 953.87 GiB 
           ID-3: /dev/sda vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB 
Partition: ID-1: / size: 915.60 GiB used: 19.49 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A gpu: amdgpu temp: 37 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 305 Uptime: 20m Memory: 30.79 GiB used: 2.08 GiB (6.8%) Init: systemd Compilers: gcc: 10.1.0 Shell: bash 
           v: 5.0.17 inxi: 3.0.37 

I don't think MHWD has the optimus-switch-amd ... if you installed from the mentioned topic how to, then you are safe, disregard what MHWD shows or not, especially if your system works.

Thanks for the reply, but I have a quest regarding prime-run how do you enable it on steam to use dGPU (RTX 2060)?

I don't think i get it.
If you set it to AMD, then glxinfo |grep "vendor" from terminal, should show the AMD one
If you switch to Nvidia then that will be shown, hence nvidia is the used GPU
I see no prime-run related command in that how to.

I mean like DRI_PRIME=1 for Discrete GPU what is the equivalent for Nvidia since my laptop has Ryzen + Nvidia.

From the tutorial you linked:

Okay but if you try the alias with steam properties it dose not recognize it so do I have to add this "__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia" in the properties ?

I think you set the launch options in Steam to

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia __VK_LAYER_NV_optimus=NVIDIA_only %command%

where %command% should be replaced with the real command.

Thanks Got it to work now.
One last question can you advise on screen flickering that happens when I disconnect from HDMI or the screen sleeps that it randomly flickers near bottom to application launcher ?

I have zero personal/hands on experience on laptops with such hardware, and all i know about is from reading. I'm affraid that i don't know the answer to the flickering part after disconnecting from HDMI, and i don't want to speculate on something that i don't fully understand. Maybe someone else will pass by with some information about it, hopefully :slight_smile:

Thanks :slightly_smiling_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by