Mid June, my T580 emited a beep sequence. Black screen, fan on high, no response.

Running latest stable KDE (Minimal) at the time.

Almost killed it when, unbeknownst to me, one of my machines spat a beep sequence (which I though was somebody's retro ringtone) right before I placed it in its bag.

The laptop became so hot I wouldn't touch it. Fan on high, battery died, and some 12 hours later it booted just fine. Has happened 3 times, but not once in the last week.

In order to flex its warranty I need help identifying the cause.

Only took place during shutdown.

  • Shutdown > verbose log > black screen > BEEP MOTHER ■■■■■■ BEEEP! > fan on high indefinitely.
1 Like

https://support.lenovo.com/gb/en/solutions/ht035729

1 Like

Didn't memorize the sequence, how could I? Beeps were loud and quick as projectile vomit.

Was hoping somebody with more experience could help identify the culprit.

EDIT Well @xircon it can only be one (or both?) of two things:

  • DIMM
  • System Board

Can't be anything else. I'll do the extended memtest later today.

The beeps are the only thing that will identify the problem. They signify the component with the problem.

3 Likes

Pull out your phone and get the laptop to do it again and record it with your phone. Sound recorder or video. both should record it.
Then "flex" your warranty.

:upside_down_face:

1 Like

You said that your machine got really hot. This suggests that the CPU or GPU is for some reason consuming a lot of electricity. Maybe those components have developed internal shorts?

1 Like

One has to when dealing with Lenovo. Their remote depo service center(s) are garbage. This thinkpad in particular was serviced approximately 11 times in its first 6 months. All major components replaced. Arguing with Mr.-thick-accent-whose-name-is-totally-John breaks spirits. Hence purchasing additional, overpriced warranty is practically mandatory.

The little ■■■■ won't beep for the camera. :sob:

Got hot from being in a bag with the fan on high. Whatever's failing keeps the fan on post-shutdown. Only times it's beeped is immediately after shutdown (verbose) log. However, only when/after it beeps does the fan stay on.

Does it remain hot after shutdown? Does only Manjaro do this, or do other operating systems do it? Does it matter how you shut it down?

1 Like

It remained hot, but not specifically due to hardware failure. Well, technically as a result of it. Regardless, keeping any powered-on computer inside a bag = very hot components.

Manjaro was the only OS installed. June testing updates couldn't possibly be at fault. All of my machines are on testing except my productivity pc.

  • Shutdown from menu is Ok
  • Issuing poweroff and shutdown commands is Ok
  • Force shutdown (besides feeling like murder) is Ok
  • Agreeing to Restart or Shutdown "now" is Ok

Could you try to drain the battery without heating it, and heating it without draining the battery? Maybe someone at Lenovo thought loud beeps and tons of heat was a good way to tell you that the battery died or the system overheated?

1 Like

The laptop overheated due to storage conditions after the fact.

Did both. Happened with my first (and last) Dell.

Since you've been kind enough to stay, I'll do it again. :nerd_face:

Being the experienced Linux user that you are, I'm surprised you haven't posted any of the information required to troubleshoot your issue.

Please post the text output of the following commands (no pics please):

sudo dmesg  | grep -Ei 'error|segf|fail|broke|warn|dump|denied|firm|oops|bug' | grep -viE 'acpi|ras'
journalctl -b -1 | grep -Ei 'error|segf|fail|broke|warn|dump|denied|firm|oops|bug'
inxi -Fxxxz  && inxi -Fxxxz  | grep -q ANJ || echo check required && ls /usr/share/xsessions/ && head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11

Have you tried reseating your RAM?

Is your bios up to date?

Have you tested at least 3 alternate kernels (both newer and older)?

OTP app had a "panick", lost my codes, couldn't sign-in on time to respond. The issue has been resolved.

@hacker was on the money, bad board castrated my CPU. Fan and battery couldn't cope, sumtotal yielded a beep sequence. Thrashed it, computer seppuku'd. Was able to reproduce the beep sequence, which in turn confirmed my suspicions.

@tbg logs were of no use, I checked before posting. Next time I'll share, extra set of eyes are better than an angry pair.

Have you tried reseating your RAM?

Ram was properly seated.

Is your bios up to date?

Yes.

Have you tested at least 3 alternate kernels (both newer and older)?

Did not do this originally, but everything between 4.19.59 to 5.2 is present.

1 Like

Forum kindly sponsored by